On-Screen Navigation (Back Button BUG)

  1. lcsmith303 Froyo Mar 19, 2017

    lcsmith303, Mar 19, 2017 :
    Can confirm this is happening for me on OOS 4.1.0.

    Was fine on OOS 4.0.3

  2. nutkabpom Cupcake Mar 19, 2017

    nutkabpom, Mar 19, 2017 :
    I'm experiencing same problem, I'm using on screen navigation bar, when I accidently touch back button on screen and on physical button at the same time it not register the back button. Even I already disabled physical button. Is anyone notice this? It's very annoying.

  3. lcsmith303 Froyo Mar 19, 2017

    lcsmith303, Mar 19, 2017 :
    Same here.

  4. lcsmith303 Froyo Mar 19, 2017

  5. pabloppp Cupcake Mar 19, 2017

    pabloppp, Mar 19, 2017 :
    I have the same issue, I hope it gets fixed soon because I prefer on screen buttons :( I really wouldn't want to disable them but sometimes it takes 4 or 5 touches for the bsck button to work (I guess that's because I also touch the hardware button by accident).

    lcsmith303 likes this.
  6. pauleverson Donut Mar 20, 2017

    pauleverson, Mar 20, 2017 :
    me too. was working on 4.0.3

  7. pauleverson Donut Mar 20, 2017

    pauleverson, Mar 20, 2017 :
    me too. was fine on 4.0.3

    lcsmith303 likes this.
  8. pauleverson Donut Mar 20, 2017

    pauleverson, Mar 20, 2017 :
    Are oneplus tracking this bug and trying to fix? I'm experiencing it on 4.1.0 4.0.3 was fine.

    (sorry for the multiple comments btw but this site won't let me post a new article until I have 5 posts!)

    lcsmith303 likes this.
  9. creamywhite Eclair Mar 25, 2017

    creamywhite, Mar 25, 2017 :
    Experiencing the same issue with OOS 4.1.0. Everything was ok on 4.0.3. Super annoying.

  10. lcsmith303 Froyo Mar 25, 2017

    lcsmith303, Mar 25, 2017 :
    Got this from Lynn at OP:



    Thanks for the response. It appears to be that the capacitive buttons and hardware buttons issues are caused by Google Talk back. Please try to uninstall it and see it if helps. Meanwhile, we're contacting Google regarding this issue.

    Let me know how it goes.




    Thought it was worth sharing.

  11. pabloppp Cupcake Mar 26, 2017

    pabloppp, Mar 26, 2017 :
    And how did it go?
    I already uninstalled it a few days ago and nothing changed, did you had any better luck?

  12. rvdz93 Froyo Mar 27, 2017

    rvdz93, Mar 27, 2017 :
    Actually hade the same problem, but only occasionally in WhatsApp, and haven't really experienced the issue in other apps.

  13. lcsmith303 Froyo Mar 27, 2017

    lcsmith303, Mar 27, 2017 :

    OK so after trying this out for a few days, it seems to be a bit better. I never have to click more that twice now, whereas before I would have to click up to 6 times sometimes.

    Although better, I still wouldn't call this resolved as I often have to click back twice.

    I'd also like to reiterate a point I made in a similar post about the on screen back button which I think is probably related:


    It seems that if I click at the bottom of the screen, beneath the back button logo (and slightly to the left), I still get the haptic vibrate feedback and the on screen feedback (as if the back button has been clicked on) but the operation of the back button doesn’t work.

    It’s seems like the back button link area doesn’t reach all the way down to bottom (left) of the screen.


    This is still happening regardless of the whether the Talk Back app is enabled or not.

    Still some more work to be done here unfortunately.

  14. e8genius Eclair Mar 29, 2017

    e8genius, Mar 29, 2017 :
    I have a same issue. It's going from first OOS versions (from OnePlus Two), until 4.1.1

    Can't use on-screen buttons :(

  15. rvdz93 Froyo Mar 30, 2017

  16. ArmoSA Donut Mar 30, 2017

  17. lcsmith303 Froyo Mar 30, 2017

  18. lcsmith303 Froyo Mar 30, 2017

  19. rvdz93 Froyo Mar 30, 2017

    rvdz93, Mar 30, 2017 :
    Did you try a factory reset? As you stated before, it worked before, so it might be a software issue.

  20. creamywhite Eclair Apr 5, 2017