1
OxygenOS Oneplsu Two Encryption unsuccessful error

  1. vrc007
    Gingerbread Feb 1, 2017

    vrc007 , Feb 1, 2017 :
    @Naman Bhalla & @Reboot101


    I was talking on a phone and suddenly my OP2 got restarted and what I see is "Encryption Unsuccessful".
    I don't know what has gone wrong, maybe when on call it just got mistakenly browsed into encryption option or something?

    I am on Oxygen OS 3.5.6 and rooted with TWRP 3.0.2-2.
    Now whenever I boot my phone it shows
    "Encryption unsuccessful
    Your phone storage has been damaged, please download the firmware package to brush".


    It appears that some part of OS is loaded because when I change the volume the android styled indicator bar and the settings gear appears but nothing happens when I tap it.

    I entered TWRP to erase data (again because I'm sure had checked it) and it says (in red):
    E:Unable to load '/twres/languages/en-US.xml'
    Could not mount /data and unable to find crypto footer.
    Failed to mount '/cache' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    ...done
    Unable to mount storage.
    Failed to mount 'data' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    Full SELinux is present.
    Failed to mount '/cache' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    Unable to mount /data/media/TWRP/.twrps
    MTP Enabled
    Failed to mount '/data' (Invalid argument)
    Formatting cache using make_ext4fs...
    Failed to mount '/cache' (Invalid argument)
    Updating partition details...
    Failed to mount '/data' (Invalid argument)
    Failed to mount '/cache' (Invalid argument)
    ...done
    Unable to mount storage

    When I go to Wipe / Repair File System selecting Data partition it shows me:
    Present: Yes
    Removable: No
    Size 0MB
    Used: 0MB
    Free: 0MB
    Backup Size: 0MB

    When I select Internal Storage and tap Repair or Change File System it says Invalid partition selection (in red).

    Tried this: https://forum.xda-developers.com/oneplus-2/general/guide-official-op2-stock-reset-to-oos-3-t3402020

    but I am stuck at recovery tool. After clicking the square button it shows ok and then pressing start it starts some procedure and then stuck on something called FirehoseCheckRSPE and some Chinese thing written ahead of it.

    https://drive.google.com/file/d/0B_l...ew?usp=sharing

    Tried fastboot comands to check whether it works and it does work.
    Like when entered comand fastboot devices, it does shows the device.
    I tried to flash stock recovery by --> fastboot flash recovery recovery.img
    It succeeds like this
    target reported max download size of 536870912 bytes
    sending 'recovery' (17013 KB)...
    OKAY [ 0.400s]
    writing 'recovery'...
    OKAY [ 0.086s]
    finished. total time: 0.490s

    But when i restart to recovery it still shows TWRP.

    What should I do?
    I just need my phone to work.
    Please help me out
    I really don't know how it even happened suddenly.

    Thank-you in advance.
     
    Last edited: Feb 2, 2017

    #1
    sokheang likes this.
  2. vikramanananda
    Cupcake Mar 28, 2017

    vikramanananda , Mar 28, 2017 :
    Hello i bought oneplus two from ebay new
    when i tried to power on nothing happen
    I tried to connect to computer it went to QHSUB_BULK mode,
    I went on to try your method 1,2&3 no result
    Can you guide me to come out and give life to my new oneplus 2
    thanks
     

    Attached Files:

    • 3.PNG
      3.PNG
      File size:
      53.3 KB
      Views:
      89
    • 2.PNG
      2.PNG
      File size:
      16 KB
      Views:
      55
    • 1.PNG
      1.PNG
      File size:
      29.2 KB
      Views:
      74

    #2
  3. G_Chris_Murphy_ymNT
    Eclair Mar 28, 2017

    G_Chris_Murphy_ymNT , Mar 28, 2017 :
    contact ebay seller they should give a refund if not send it to oneplus
     

    #3
  4. anupritaisno1
    KitKat Dec 6, 2017

    anupritaisno1 , Dec 6, 2017 :
    After almost a year of research I've found an answer to why this is happening

    Your chip is dead and a protection mechanism has been triggered which has made your entire chip read-only

    Unfortunately the only way to fix this is a motherboard replacement
     

    #4
  5. vrc007
    Gingerbread Dec 8, 2017

    vrc007 , Dec 8, 2017 :
    Solution :
    Unfortunately it's Motherboard replacement.
    :(
     

    #5