9
Oneplus 2 Auto rotation not working properly "ROM BUG"

  1. EgyGomaa
    Cupcake Sep 13, 2016

    EgyGomaa , Sep 13, 2016 :
    The solution for Google Maps is you have to rotate before starting navigation. So exit navigation, then rotate, then press continue navigation.
     

    #61
  2. eye842
    Lollipop Sep 15, 2016

    eye842 , Sep 15, 2016 :
    I'm still on oxygen 2.2.1 and I get that bug now and then, last time it was YouTube.
     

    #62
  3. domuzy
    Cupcake Sep 28, 2016

    domuzy , Sep 28, 2016 :
    i have a permanent problem, THAT'S what i have. Only from OOS 3.0.1 the rotation (and camera) gone bad.
     

    #63
  4. Lancelot_69
    Lollipop Sep 28, 2016

    Lancelot_69 , Sep 28, 2016 :
    Delete my bad
     

    #64
  5. fancsali
    Eclair Sep 29, 2016


    #65
  6. G_ali khan
    Cupcake Oct 8, 2016

    G_ali khan , Oct 8, 2016 :
    Hey I am using OnePlus 2 with 3.0.2 but it is not rotating
    Plz help me oneplus
     

    #66
  7. nassehk
    Cupcake Feb 11, 2017

    nassehk , Feb 11, 2017 :
    My phone dies not auto rotate in any app unless manually told to by the app. I checked accelerometer works. I am on oxygen 3.5.6. Please help.
     

    #67
  8. G_brijesh_patel_ciVJ
    Cupcake Feb 11, 2017


    #68
  9. hareshdc
    Eclair Feb 14, 2017

    hareshdc , Feb 14, 2017 :
    There are lot of bug fixes to be done. I experienced the same , auto rotation did not work. My phone got slow though i dont save much data on the device. I had to reset my device, now i can auto rotate, but thats not how it should be fixed. OP guys its time to release a bug fixes update.
     

    #69
  10. G_Anubhav_Singh_NETd
    Gingerbread Feb 14, 2017

  11. KarlEric
    Donut Feb 14, 2017

    KarlEric , Feb 14, 2017 :
    I have had this same issue, but the quick reboot always helped.
     

    #71
  12. akshaysihag
    Honeycomb Feb 14, 2017


    #72
  13. Saifullah_Awan
    Eclair Feb 15, 2017

    Saifullah_Awan , Feb 15, 2017 :
    Same issue here on 3.5.6..a quick reboot fixes it but it's very annoying.. Hope it gets fixed in the next update!
     

    #73
  14. qsdfqsdf
    Donut Mar 4, 2017

    qsdfqsdf , Mar 4, 2017 :
    It doesn't help at all... Hope this will be fixed soon!
     

    #74
  15. BrunoNRG
    Ice Cream Sandwich Mar 6, 2017

    BrunoNRG , Mar 6, 2017 :
    I had the same issue on my OP2, screen not rotating from portrait to landscape unless I rebooted the phone, and it happened several times a day. I'm using official 3.5.6 OxygenOS rom, with no root, and this is how I fixed this issue:

    I use Nova Launcher Prime as my main launcher, under Nova Launcher settings, go to Look & feel > Screen orientation and choose Auto-rotate, that's it, it will auto rotate your screen even on homescreen.

    I never had the screen rotation issue again, I really have no idea if, because the auto-rotate is enabled, Nova Launcher keeps the gyroscope working all the time (if so, there are no battery drain issues caused by this), but it solved the problem for me, I hope this is helpful for those who are experiencing the same. ;)


    Is it just my impression or did the default message app and system settings menu work on both portrait and landscape mode before the last firmware update... anyone else notticed this? Also miss the red Accent color, they replaced it with something called Vibrant red, yeah right... IT'S PINK!!! :p
     

    #75
  16. fancsali
    Eclair Jun 22, 2017

    fancsali , Jun 22, 2017 :
    C'mon guys. This thread is more than 2 years old, several updates have been published since then, and the issue is still there.

    This is ridiculous. Definitely not the way to convince me to replace my Opt with the brand new, shine five.

    Sorry...
     

    #76
  17. aashutoshtaikar
    Cupcake Sep 3, 2017

    aashutoshtaikar , Sep 3, 2017 :
    I'm using OP2 having updated to the latest 3.6.0 T-mobile; still, the auto-rotate stops working which is really annoying. I gave up on One Plus, time to buy some other brands.
     

    #77