0
OnePlus 2 OOS 3.0 Bluetooth issue

  1. waqas281
    Froyo Apr 6, 2016

    waqas281 , Apr 6, 2016 :
    I have this terrible bug every time I turn on Bluetooth and connect to external speakers or pair with my car my phone starts freezing and apps start crashing Spotify, chrome, vlc player, phone app. Not just that I can't get the phone to output any audio on the external Bluetooth paid speakers. Only way to fix the crashes and phone freeze up is if I kill the bluetooth. Has anyone ran into this issue if so has anyone found a fix
    Rom: OOS 3.0, exposed installed and rooted.
     

    #1
  2. dsmonteiro
    Community Consultant Staff Member Apr 6, 2016

    dsmonteiro , Apr 6, 2016 :
    Are you using any exposed module related to sound or Bluetooth?

    Regardless, I'll test my phone once I get home.
     

    #2
    waqas281 likes this.
  3. thesign
    Gingerbread Apr 6, 2016

    thesign , Apr 6, 2016 :
    Had the same problem. Media did not have any problem on speaker phone, but the moment you connect it to any Bluetooth device it acts up. Had flashed another OS since taking calls in my car via Bluetooth is a big thing with me -_-
     

    #3
    waqas281 likes this.
  4. BOSSPDA
    Jelly Bean Apr 6, 2016

    BOSSPDA , Apr 6, 2016 :
    Well my experience with this rom it's absolutely amazing. Since march 30th I'm using without trying other roms.
    So, about Bluetooth, for the very first time, I have a nice pairing with my car and about music, using Bluetooth connection, I can control musics and the sound is very good. I'm using Viper4android, while the final release waits for to be unleashed to the community.
    Try to install again, from scratch, not using dity flash. Wipe all, but not Internal Storage and maybe you'll have another behavior from your phone
     

    #4
    stefan_ddorf likes this.
  5. waqas281
    Froyo Apr 6, 2016

    waqas281 , Apr 6, 2016 :
    Yup exactly what's happening to me
     

    #5
  6. waqas281
    Froyo Apr 6, 2016

    waqas281 , Apr 6, 2016 :
    No only thing I was using is for minmin guard YouTube addaway, youtube background player and amplify, greenfiy are the add on I've installed, I just tried it with xposed disabled and still no bingo.
     

    #6
  7. marinobiagio
    KitKat Apr 6, 2016


    #7
  8. bubbob
    Eclair Apr 12, 2016

    bubbob , Apr 12, 2016 :
    Having car audio issue. The phone pairs but now the on-screen buttons to control phone audio (ie. play, pause, advance, etc) are ghosted. All interaction now must be done on the phone. 2.2.1 was bad already with no audio data being displayed, now it has regressed even worse with just sound coming through...I guess the next update will leave me with no sound.....
     

    #8
  9. ashokmor007
    Honeycomb Apr 12, 2016


    #9
  10. dontutella
    Cupcake Apr 13, 2016

    dontutella , Apr 13, 2016 :
    Using bluetooth earphones here too and they're working fine.. but I'm on Seraph08's deodexed and debloated OOS 3.0 stock, Xposed not installed, maybe you want to try flashing that build and see how it goes?
     

    #10
  11. marinobiagio
    KitKat Apr 13, 2016

    marinobiagio , Apr 13, 2016 :
    Nope I'm fine with stock OOS 3.0 :)
     

    #11
  12. bartje
    Cupcake Jul 30, 2016

    bartje , Jul 30, 2016 :
    @waqas281 any progress so far?

    I have been searching for OP3 users with the same issue as mine. Yours comes closest..
    Could you let me know if you or others experience this;

    Bluetooth connection is established. Songs play. Suddenly an audio glitch somewhere in the song of one second. Then the pitch of the audio increases (like the stream wants to catch up with where the song should be). After ten seconds, the audio signal dies for one second. Only to pick it up again where it left me. Audio continue's with many songs.

    At least once in 20 minutes, this happens.
     

    #12
  13. ranguleo
    Donut Jan 22, 2017

    ranguleo , Jan 22, 2017 :
    I do have a same problem on my device. I use Sony Bluetooth SBH52 everyday. it will act weird sometimes while handling calls and many times it will lead in rebooting the device aslo and as soon as the reboot 20%-30% of battery percentage will drop its veey irritating. Clean wipe done. Im using stock os and not rooted.
     

    #13