4
Oneplus 2 OOS3 Fingerprint unlock bug

?

Do you face this Fingerprint unlock bug?

  1. Yes

    57 vote(s)
    51.8%
  2. No

    53 vote(s)
    48.2%
  1. bala
    Gingerbread Mar 31, 2016

    bala , Mar 31, 2016 :
    I'm using the mm update community build from last night .. so far, its good no real lag or slow downs.

    Coming to the point, i have noticed a weird bug where even though i have the fingerprints set up when i try to unlock the device via fingerprint while the screen is on it takes me to the input pattern unlock screen i'm sure that the fingerprint matches because i could feel the vibration of the sensor reading my print but the bug is after it reads it instead of unlocking it goes to the pattern panel....To resolve this issues everytime i need to go to the lockscreen->fingerprint and then when i lock the screen with the settings app open and try to unlock it fingerprint works once i clear the settings app from memory the fingerprint stops unlocking but the fingerprint scanner reads my print.

    Note : i tried using an app that locks apps and when im unlocked and try to use the app lock with fingerprint as security open locked apps it works like charm :) this means that there is a little bug causing this hetic state of reading but not unlocking bug ..

    EDIT 1 - After a little bit of banging head found that this only happens with NOVA launcher ( i use the nova launcher pro), when i use stock OP launcher it just takes me to homescreen as normal blazingly fast :) if you are facing this issue with custom launchers switch back to stock op launcher to solve this bug temporarily.

    EDIT 2 - Got a picture of whats the reason behind this misbehaving thing, apparently it due to MM processes and FP management, It is not the fault of NOVA launcher. It is caused only for people who use software methods to lock their devices i.e in my case nova activities, the moment you turn off the software and start using the hardware lock key to lock your device down this annoying issue won't mess with you :)


    I have created a poll up to let OP know how many of the people are facing this bug ! vote up to let them know and help the ROM get more stabler before public OTA ! thanks

    P.S - The reproducibility rate of this bug is 50% (atleast for me)
     
    Last edited: Mar 31, 2016

    #1
  2. pranayysharma
    Ice Cream Sandwich Mar 31, 2016

    pranayysharma , Mar 31, 2016 :
    Hey man.
    When using nova launcher. Do you lock your screen by double tap or something?
     

    #2
  3. kushalpandya
    Honeycomb Mar 31, 2016

    kushalpandya , Mar 31, 2016 :
    I'm facing the same issue, but I guess problem is not with custom launcher. Here's what is happening in my case. I'm using Nova Launcher Prime.

    1. I lock my phone using screen-lock app https://play.google.com/store/apps/details?id=com.katecca.screenofflock
    2. I try to unlock my phone using home button, it vibrates and wakes up the phone but I'm presented with Pin prompt where I need to further provide Pin to unlock it.
    However, if I use power button to lock to phone instead of any app, it unlocks just like it should. I'm not sure if same behavior is present in case I use OnePlus launcher.
     

    #3
    bala likes this.
  4. bala
    Gingerbread Mar 31, 2016

    bala , Mar 31, 2016 :
    yup i lock the screen by double tapping but i have noticed that even when you lock using power button when you use nova this bug happens
     

    #4
  5. bala
    Gingerbread Mar 31, 2016

    bala , Mar 31, 2016 :
    May be there is a problem in using soft ways to lock the phone instead of using hardware buttons...this isnt a that big of a bug but i see many people using some kind of software and nova launcher activities to turn the screen off, hope people who are scratching why their fingerprint isnt working finds this thread useful
     

    #5
  6. pranayysharma
    Ice Cream Sandwich Mar 31, 2016

    pranayysharma , Mar 31, 2016 :
    If locked by non official ways (read power button/capacitative buttons), the fingerprint reader does not work.
    I'm not sure but I think it didn't work on 2. 2.1 as well.
    Either way. 3.0 definitely doesn't use it
     

    #6
  7. kushalpandya
    Honeycomb Mar 31, 2016

    kushalpandya , Mar 31, 2016 :
    It did work in 2.2.1 and I used it primarily, any Nexus 5X or 6P users? can you confirm if this behavior is from Marshmallow or a genuine bug in OOS 3.0?
     

    #7
  8. pranayysharma
    Ice Cream Sandwich Mar 31, 2016

    pranayysharma , Mar 31, 2016 :
    Oh yeah. I may not have noticed it because it worked.
    But I'm definite that smart locks were disabled on Lollipop everytime I locked with double tap on nova. Maybe MM reads for as smart lock. Hence the issue.
    I agree that nexus users may be of help here.
     

    #8
  9. Rick Manders
    Community Veteran Mar 31, 2016

    Rick Manders , Mar 31, 2016 :
    On the 6P, on unlocking on first boot and you use the fingerprint, I also have to use my PIN.

    This is only on the first boot when you switch on your phone. All other times I can use the FP to unlock.
     

    #9
  10. kushalpandya
    Honeycomb Mar 31, 2016

    kushalpandya , Mar 31, 2016 :
    Yes but how about when you lock your phone using any third-party app instead of power button and then use fingerprint to unlock it? does it ask for PIN again or takes to straight to Home screen?
     

    #10
  11. harnie
    Gingerbread Mar 31, 2016

    harnie , Mar 31, 2016 :
    I had the same issue using Nova (paid version) in combination with a screen-lock app to be used with a double tap. Same issue as described above. Using that feature fp didnt work to unlock the phone it just wakes up the phone and I had to enter my pin.
    As I am using a book-cover with magnet I didnt use it much so I just deleted the lock-screen app for now.
     

    #11
  12. Rick Manders
    Community Veteran Mar 31, 2016

    Rick Manders , Mar 31, 2016 :
    I don't use 3rd party apps to lock my phone so I can't help you there.
     

    #12
  13. kushalpandya
    Honeycomb Mar 31, 2016

    kushalpandya , Mar 31, 2016 :
    It is debatable whether this is a security feature (to prevent any third-party app from taking over phone locking) or a bug (only Nexus 5X/6P users can confirm by actually trying any screen locking app from play story to lock the device, looking at you @Rick Manders ;)).

    Although, I'm now using Double Tap to lock on Recents button which works pretty well (configure it from Settings > Buttons > Recents button > and set Double tap action as Turn off screen.
     

    #13
    ione2020 likes this.
  14. hlin9
    Honeycomb Mar 31, 2016

    hlin9 , Mar 31, 2016 :
    You need root to enable FP unlocking if locked via third party app, e.g., Nova Launcher, or other screen lock apps. This is the same behaviour as on N5X/N6P. I am using gravity screen app and got the same behaviour if I lock using gravity screen shortcut. Quote from the developer:

    Hence this is not OOS3 issue.
     
    Last edited: Mar 31, 2016

    #14
  15. varunsood
    Froyo Mar 31, 2016

    varunsood , Mar 31, 2016 :
    When i restart the device it ask for pin to unlock not through fingerprint is it in the marshmellow or the bug?
     

    #15
  16. NikRamakrishnan
    Froyo Mar 31, 2016

    NikRamakrishnan , Mar 31, 2016 :
    So I noticed this as soon as I registered the fingerprints on the device after flashing MM.

    1. While Charging
    • The fingerprint scanner doesn't seem to work most of the times while charging. When you keep your finger on the scanner, the display turns on and goes to the PIN/Password/Pattern input screen. You must now input the Password to continue. The device continues to vibrate when you touch the home button/FPS.
    • This is temporarily resolved when you unlock and relock the device but that too, is uncertain.
    • Whenever this happens, the fingerprint icon does not show up.
    2. Not Charging
    • The FPS works fine when you are locking the device using the Power Button.
    • When you lock the device using an application (I use double tap to lock on Nova), the FP icon does not show up and you are shown the Password input screen when you try to unlock via fingerprint.
    • Please confirm this with other apps/launchers.
    Please reply if you find any other issues with the FPS. I will add it here.
     
    Last edited: Mar 31, 2016

    #16
  17. hlin9
    Honeycomb Mar 31, 2016

    hlin9 , Mar 31, 2016 :
    Standard. When you restarted your device, you will always need to also unlock using your PIN/pattern/etc. After certain period of time of keep using FP (can't remember exact number of hours), you will also be prompted for PIN/pattern/etc again even if you do not restart the device. This is by design, not a bug.
     

    #17
  18. puneet_si
    Froyo Mar 31, 2016


    #18
  19. Jitesh Saitawadekar
    KitKat Mar 31, 2016


    #19
    JustAPhone likes this.
  20. hlin9
    Honeycomb Mar 31, 2016


    #20