7
OnePlus 2 Stock Recovery Image

  1. CookiiM0nster
    Donut Apr 30, 2016

    CookiiM0nster , Apr 30, 2016 :
    Oh nevermind... This has put my phone into boot loop....

    EDIT: Wrong forum lol, I had loads of tabs open thought I was on the right one
     

    #21
  2. bigross86
    Donut Jun 9, 2016

    bigross86 , Jun 9, 2016 :
    I'm trying to deal with a similar issue, and it's just not working for me.

    I bought an OP2 with an invite when it initially came out. Hadn't played around with it much, all I did was unlock bootloader and root the phone with TWRP so I could have root access for Titanium Bcackup, Greenify, etc.

    Because I was rooted, I wasn't getting OTA updates. I wanted the MM upgrade, so I manually flashed the stock upgrade to 2.2.1, and then from 2.2.1 to 3.0.2. All is awesome, phone is running MM, cool beans!

    Except I realized that root access had now disappeared, I couldn't even flash into stock recovery.

    Here's where I am now:

    1) oxygen 3.0.2 is running fine, but I have no root.
    2) Can't flash into recovery, neither stock nor TWRP
    3) Phone will restart into Fastboot mode, but nothing happens. Running CMD through ADB just has the message <waiting for device> (See attached image).
    4) "Fastboot Devices" doesn't return any results.
    5) I don't want to go the standard way of unlocking bootloader and rooting, because every single tutorial I've seen says that will lead to me losing all my data, which is something I really do not feel like dealing with atm.

    Therefore, I ask, my friends - Is there any way for me to restore root access without losing everything?
     

    Attached Files:


    #22
    M.Tayyip likes this.
  3. iamneuron
    Donut Jul 5, 2016

    iamneuron , Jul 5, 2016 :
    @bigross86 this happened to me also.

    Make sure you see the fastboot logo (power on without a pc connection)
    Connect to pc
    Use 'fastboot continue'
    Phone should boot ok.


    My issue is that I've had this once and managed to get my recovery back by the following:
    1st: download latest official TWRP https://dl.twrp.me/oneplus2/twrp-3.0.2-1-oneplus2.img.html and place it in fastboot folder
    2nd: on your phone go to fastboot mode and type this:
    - fastboot erase recovery
    - fastboot reboot-bootloader (i had to disconnect from pc to boot it to fastboot or i just got a black screen)
    3rd: once boolotader reboots flash official downloaded TWRP using command 'fastboot flash recovery twrp-3.0.2-1-oneplus2.img'
    4th. DO NOT restart your phone. Once you flash recovery hold power button until your phone shuts off and then hold power button and volume down to see if TWRP loads.

    Now it has happened again though and I can't get my recovery to stick!

    I enabled the advanced reboot menu in dev options and held power down to reboot into bootloader and it says 'factory resetting, rebooting'. I wonder if this menu is messed up in the latest build and wipes your recovery?

    I've also noticed tapping the clock in the notification panel takes you to time options and not the clock.
     

    #23
  4. iamneuron
    Donut Jul 6, 2016

  5. gaster
    Moderator Moderator Jul 6, 2016

    gaster , Jul 6, 2016 :
    Thanks buddy
     

    #25
  6. Spannaa
    KitKat Jul 8, 2016


    #26
  7. Deactivated User
    Jul 10, 2016


    #27
  8. hackworks
    Gingerbread Jul 11, 2016

    hackworks , Jul 11, 2016 :
    Curiosity: please tell us how you extracted? I had tried just using 'dd' on recovery partition but that did not get the boot image. In short, it was not sufficient
     

    #28
  9. Spannaa
    KitKat Jul 11, 2016


    #29
    hackworks likes this.
  10. raghus_id
    Froyo Jul 14, 2016

    raghus_id , Jul 14, 2016 :
    Did you just flash the OOS3 stock recovery through TWRP? Did it wipe out any data?
     

    #30
  11. Deactivated User
    Jul 14, 2016


    #31
  12. omararod
    Gingerbread Sep 29, 2016

    omararod , Sep 29, 2016 :
    I know this is old but this helped me unroot, thanks.
    for anyone that wants to unroot: go to supersu, press unroot, then flash the recovery from the zip.
     

    #32
  13. Manish421
    Cupcake Dec 3, 2016

    Manish421 , Dec 3, 2016 :
    Is this Oxygen recovery or H2OS recovery
     

    #33
  14. user 7
    Ice Cream Sandwich Dec 6, 2016

    user 7 , Dec 6, 2016 :
    The latest oxygen recovery can be downloaded from oxygen official website
     

    #34
  15. user 7
    Ice Cream Sandwich Dec 6, 2016

    user 7 , Dec 6, 2016 :
    It wont wipe data. Only unlocking bootloader will format data
     

    #35
  16. Anime_Life
    Donut Jan 1, 2017


    #36
  17. spacebite
    Cupcake Jan 11, 2017

    spacebite , Jan 11, 2017 :
    i tried to do this but all i got was
    target reported max download size of 536870912 bytes
    sending 'recovery' (31501 KB)...
    OKAY [ 0.688s]
    writing 'recovery'...
    FAILED (remote: device is locked. Cannot flash image
    finished. total time: 0.708s

    i dont know what has hapened to my phone all of a sudden i couldnt get into twrp recovery and now i need to get into some recovery because i cant unroot via supersu nor the phone.
    im sorry probably the wrong thread to post in but im so stressed up about it :(
     

    #37
  18. Reddie308
    Eclair Jan 17, 2017

    Reddie308 , Jan 17, 2017 :
    Hi all..i'd like to ask..
    anybody have a port of stock recovey.img of Oxygen OS 3.5.6?
    i want go back to fullstock.
    Thanks in advance.
     

    #38
  19. vrc007
    Gingerbread Feb 2, 2017

    vrc007 , Feb 2, 2017 :
    I was talking on a phone and suddenly my OP2 got restarted and what I see is "Encryption Unsuccessful".
    I don't know what has gone wrong, maybe when on call it just got mistakenly browsed into encryption option or something in a setting?

    I am on Oxygen OS 3.5.6 and rooted.

    Got a message saying:
    Encryption unsuccessful
    Your phone storage has been damaged, please download the firmware package to brush.
    It appears that some part of OS is loaded because when I change the volume the android styled indicator bar and the settings gear appears but nothing happens when I tap it.

    I entered TWRP to erase data (again because I'm sure had checked it) and it says (in red):
    Could not mount /data and unable to find crypto footer.
    Failed to mount '/data' (Stale NFS file handle).
    Unable to mount storage

    When i go to Wipe / Repair File System selecting Data partition it shows me:
    Present: Yes
    Removable: No
    Size 0MB
    Used: 0MB
    Free: 0MB
    Backup Size: 0MB

    When I select Internal Storage and tap Repair or Change File System it says Invalid partition selection (in red).

    I followed your solution but I am stuck at recovery tool. After clicking the square button it shows ok and then pressing start it starts some procedure and then stuck on something called FirehoseCheckRSPE and some Chinese thing written ahead of it.

    https://drive.google.com/file/d/0B_l6Qvh1m7AAN3llRGZCVnhjQUE/view?usp=sharing

    What should I do?
    I just need my phone to work, if data goes it's fine.

    Thank-you in advance.
     

    #39
  20. Spannaa
    KitKat Feb 2, 2017

    Spannaa , Feb 2, 2017 :
    You could start by not posting the same thing in multiple, random threads...
     

    #40