Oneplus 3 - Android Auto (3.2.1)

  1. ebomb321
    Cupcake Jul 15, 2016

    ebomb321 , Jul 15, 2016 :
    Hi All,

    I'm sorry for starting a thread with this, but I have not heard anything back on the post in the bug thread.

    Has anyone had success keeping a GPS lock in Android Auto since the 3.2.1 update?

    Prior to the update I drove from NY to NC and did not have a single GPS drop the entire 9 hours in each direction. Since the update, i cannot keep lock for more than 10 minutes at max.

    When i loose GPS lock i am able to go into setting, disable location, then re-enable and keep lock for another 2-5 minutes. if i don't do this it sits on searching for GPS in Android Auto.

    I cant tell if I am having any other issues with GPS.

    Any advice or comments would be appreciated. Am i alone here?


  2. bertboy
    Donut Jul 15, 2016

    bertboy , Jul 15, 2016 :
    If you use Google Maps navigation, it loses signal? I use mine almost daily without any problem. Mostly for traffic info, i know how to drive to work by now ;-)

    For me the gps is working flawlessly. I use a parking-app to pay for parking spots in the street. When I opened the app on the OP2 i always had to wait like 10 seconds before there was an accurate location, often the location would not become accurate to the exact street (Which did work in Google Maps...). Now with the OP3 he knows the exact street that i'm in from the second I open the app!

  3. pbyrond
    Cupcake Jul 15, 2016

  4. ebomb321
    Cupcake Jul 18, 2016

    ebomb321 , Jul 18, 2016 :
    you guys are on 3.2.1?

  5. es.salby
    Gingerbread Jul 18, 2016

    es.salby , Jul 18, 2016 :
    I havent used android auto, but have used g-maps navigation twice with 3.2.1, for about 2 hours a time, and had absolutely no problems at all, except for passing through a 2mile tunnel. Have you tried g-maps or only android auto?

    gl0b4l likes this.
  6. ebomb321
    Cupcake Jul 19, 2016

    ebomb321 , Jul 19, 2016 :
    Well I'm sorry for not trying this sooner, but i cleared data, uninstalled, and reinstalled Android Auto and it seems to be solid again.


    Mitsu71 and bertboy like this.
  7. ylambert
    Cupcake Jul 25, 2016

  8. stefanlange
    Cupcake Jul 26, 2016

    stefanlange , Jul 26, 2016 :
    First I thought it doesn't work in my new Seat León 2016. But I got it running after I reinstalled Android Auto, activated USB debugging in the developer settings and used the original USB Type C cable.

  9. AnantK123
    Cupcake Aug 14, 2016

    AnantK123 , Aug 14, 2016 :
    I had a tough time getting Android Auto working with my Honda accord 2016. All other phones worked fine except the op3.

    Finally was able to get it to work. Here is what i did:

    1. Enable developers options
    2. Connect the phone to the car while the car is on
    3. Go to developers options and under "select USB configuration" pick "MIDI"

    Then Android Auto connects to the car. It is really disappointing to see the bugginess of the phone. I really like the hardware. But the software is s**t. If I wasn't past the return date I would have gotten a different phone. Oh well at least I got it to work for now. Hopefully op will release an update to fix the glitches.

    Had connected to support and asked them about Android Auto support before i figured out the work around. They flatly stated that Android Auto is not a supported feature. Support was supposed to be added in "a few weeks". Don't know how long weeks are in OP land

    Cheers and hope this helps someone

  10. dipesharora
    Eclair Nov 26, 2016

    dipesharora , Nov 26, 2016 :
    My Android Auto started working after I changed the USB configuration to MIDI. On my sister's phone, this works even if set to USB charging. Also, when I flashed CM14.1 nightlies on my phone, it worked with USB charging also. So, my guess is that the issue is with Oxygen OS and not the device. I am currently running Oxygen OS 3.2.8 and have a Honda Accord 2016.

  11. shravanm18
    Froyo Mar 29, 2017