0
OnePlus 3 - "Login Temporarily Failed.." error on SnapChat - Rooted - FreedomOS - No Xposed

  1. mharis
    Ice Cream Sandwich Nov 1, 2016

    mharis , Nov 1, 2016 :
    Hi,
    I have been having this widely known "Login temporarily failed.." problem with SnapChat. Most of you must have heard of it if you have been using xposed and tried to run SnapChat.

    The problem is that I do not have Xposed installed, I never installed it. Possibly, it was installed during the first time I installed FreedomOS but I have recently uninstalled the framework if it was there using:

    1. Recovery flashable xposed uninstaller zip
    2. Xposed Installer app - Uninstall framework.

    The Xposed Installer app shows me "Xposed Framework is not installed".
    I do not understand why SnapChat still does not log in!

    I am on FreedomOS 1.6.1 with ElementalX kernel 0.25 (no profile in use).
    Also not using a VPN.

    I have tried:
    - Clearing the app cache and data
    - Uninstalling and Reinstalling Snapchat
     
    Last edited: Nov 1, 2016

    #1
  2. MBJTempel
    Froyo Nov 1, 2016

    MBJTempel , Nov 1, 2016 :
    I had the same problem with my oneplus one (op3 atm) i wonne have some new emojis in snapchat and so
    i did not use a custom rom or what ever just unlocked with twrp cound fix the snap chat error so i went back

    i would love to root my op3 but i wonne have a fix for snapchat

    (sorry for my bad gramma and so)
     

    #2
  3. mharis
    Ice Cream Sandwich Nov 1, 2016

    mharis , Nov 1, 2016 :
    Well let's hope we get a solution here :)
     

    #3
    PJTempel likes this.
  4. anttinym
    Eclair Nov 1, 2016

    anttinym , Nov 1, 2016 :
    I just uninstalled root from supersu, rebooted, logged in snapchat, flashed supersu again, worked.
     

    #4
  5. anttinym
    Eclair Nov 1, 2016

    anttinym , Nov 1, 2016 :
    You should always have a titanium backup of snapchat for these situations [e]261d[/e]️
     

    #5
    eedo likes this.
  6. Scherpenseel
    KitKat Nov 1, 2016

    Scherpenseel , Nov 1, 2016 :
    It's not a bug so there won't be a fix. Snapchat blocks root so you are not able to save snaps.

    As for a solution, did you ever use the SuperSU app? If yes, and you used the "unroot" option within the app it might be there is still some residu from the Supersu removal that Snapchat is recognizing. You can try to remove that with Root explorer. If this is not working it might be that Snapchat is recognizing FreedomOS as a rooted OS.
     

    #6
    PJTempel likes this.
  7. p2p
    Ice Cream Sandwich Nov 1, 2016

    p2p , Nov 1, 2016 :
    Root = no Snapchat nor androidpay nor pokemongo....

    All that apps include a root checker based on google safetynet api.

    Solution? Unroot or use suhide 0.54
     

    #7
    mharis and Jamal751 like this.
  8. mharis
    Ice Cream Sandwich Nov 1, 2016

    mharis , Nov 1, 2016 :
    I am assuming SnapChat will check for root again the next time you try to run it.. no?

    I have the SuperSU app since it comes preflashed with FreedomOS but I am definitely not looking to let go of root for an app so I will have to see other alternatives.

    Looks like I will have to say Goodbye to SnapChat at least for now.
     

    #8
  9. MBJTempel
    Froyo Nov 1, 2016

    MBJTempel , Nov 1, 2016 :

    thx i could try it i used the stock rom from oneplus to root together with twrp and yes i used Supersu (btw im realy new to rooting haha)
     

    #9
  10. anttinym
    Eclair Nov 1, 2016

    anttinym , Nov 1, 2016 :
    I dont think so, you can just log in while you're not rooted, then root and never log out to prevent this happening again. I believe that root check happens only as logging in.
     

    #10
  11. mharis
    Ice Cream Sandwich Nov 2, 2016

    mharis , Nov 2, 2016 :
    Hmmm that could be equally possible, thanks for the help. This can be called a workaround for now I guess, If I am really compelled to use the app then I may think about doing this :)
     

    #11
    andrneumann likes this.
  12. KevinJohnson
    Donut Nov 21, 2017

    KevinJohnson , Nov 21, 2017 :
    After upgrading to the latest beta version I faced this problem. But after creating the new account, I'm able to use it fine. After a few hours I tried to use my old Snapchat login and it also runs fine on the same phone. If you are still facing this problem, then check it out this handy guide.
     

    #12