0
Oneplus 3 (o2-uk) - LTE/H/E issue.

  1. ritchiedrama Ice Cream Sandwich Jul 5, 2016

    ritchiedrama, Jul 5, 2016 :
    Okay, I got my phone a few days ago, LTE working great, amazing speeds for my area 20mb+ for 3 days straight.

    Now it's either on H or E - only comes back if I reboot, put airplane mode on or turn wifi on/off.

    However, that lasts for about 25-30 seconds and goes back to E or H..

    From my research it seems Android 6.0.1 does this. But the forum has no-one else with issues?

    Any help? Thanks.
     

    #1
  2. JasonMR KitKat Jul 5, 2016

    JasonMR, Jul 5, 2016 :
    Working fine for me on O2, might be worth checking your APN settings are correct.
     

    #2
  3. JasonMR KitKat Jul 5, 2016

    JasonMR, Jul 5, 2016 :
    Here are the settings O2 sent me:

    Mobile Web & MMS



    This device allows you to reset your settings to default, please try method 1 before method 2.

    1. Tap Settings
    2. Go to Connections
    3. Tap Mobile Networks
    4. Make sure that the Mobile Data box has a green tick in it (tap box to change)
    5. Tap Access Point Names
    6. Tap More (Softkey in top right of screen)
    7. Tap Reset to default
    Please ensure that when entering O2 into the settings that the letter O is selected and not a zero. When entering the following information do not press Save until told to in the instructions.

    1. Tap Settings
    2. Go to Connections
    3. Tap Mobile Networks
    4. Make sure that the Mobile data box has a green tick in it (tap box to change)
    5. Tap Access Point Names
    6. Tap Add (top of screen)
    7. Tap Name and enter O2 Pay Monthly then tapOK
    8. Tap APN and enter mobile.o2.co.uk then tapOK
    9. Leave Proxy blank
    10. Leave Port blank
    11. Tap Username and enter o2web then tap OK
    12. Tap Password and enter password then tap OK
    13. Skip past Server as this is preset as Not set
    14. Leave MMSC blank
    15. Leave MMS proxy blank
    16. Leave MMS port blank
    17. Tap MCC and enter 234 then tap OK
    18. Tap MNC and enter 10 then tap OK
    19. Tap Authentication type and tap PAP
    20. Tap APN type and enter default,supl then tapOK
    21. Leave Bearer as unspecified
    22. Press the back key
    23. Tap the circle beside your APN to set it as default
    24. Press the Menu key
    25. Tap New APN
    26. Tap name and enter O2 MMS
    27. Tap APN and enter wap.o2.co.uk
    28. Leave Proxy blank
    29. Leave Port blank
    30. Tap username and enter o2wap
    31. Tap password and enter password
    32. Leave Server blank
    33. Tap MMSC and enterhttp://mmsc.mms.o2.co.uk:8002
    34. Tap MMS proxy and enter 82.132.254.1
    35. Tap MMS port and enter 8080 then tap OK
    36. Tap MCC and enter 234 then tap OK
    37. Tap MNC and enter 10 then tap OK
    38. Tap Authentication type and tap PAP
    39. Tap APN type and and enter mms then tap OK
    40. Leave APN protocol as IPv4
    41. Leave Enable/disable APN as ticked
    42. Leave Bearer as Unspecified
    43. Press the Back key to return to the main menu
     

    #3
  4. ritchiedrama Ice Cream Sandwich Jul 5, 2016

    ritchiedrama, Jul 5, 2016 :
    I contacted O2, APN settings were reset (as they asked). I hard reset the phone, I re-inserted the SIM. Could you link me to the same APN (or screenshot yours) just for peace of mind sake so I can check they're the same as mine?

    I am on monthly which I assume you are too.
     

    #4
  5. JasonMR KitKat Jul 5, 2016

    JasonMR, Jul 5, 2016 :
    Mine are set up as above, also on monthly plan.
     

    #5
  6. ritchiedrama Ice Cream Sandwich Jul 5, 2016

    ritchiedrama, Jul 5, 2016 :
    Made no difference with those settings either (most were similar, just the MMS part wasn't).
     

    #6
  7. JasonMR KitKat Jul 5, 2016

    JasonMR, Jul 5, 2016 :
    That's odd then because that is how they should be set up according to O2.

    Have you tried it in any other areas, maybe there are issues where you are at the moment?
     

    #7
  8. ritchiedrama Ice Cream Sandwich Jul 5, 2016

    ritchiedrama, Jul 5, 2016 :
    I contacted O2 and they said there are no issues and yes I went 8 miles out to a different area today and had none either. It's strange.. I know its something else because as I said, if I put airplane mode on and off - it works for a short time then stops.

    Google is full of this issue blaming android
     

    #8
  9. JasonMR KitKat Jul 5, 2016


    #9
  10. ritchiedrama Ice Cream Sandwich Jul 6, 2016

    ritchiedrama, Jul 6, 2016 :


    Here is my issue :D
     

    #10
  11. Galaxykeks Froyo Jul 6, 2016

    Galaxykeks, Jul 6, 2016 :
    I saw that too, even though mine goes back to H/LTE, but it takes way longer than the Nexus 6P. But it does it on it's own.
    So no need for a reboot here...
    If I do airplane on/off it's instantly on the faster network.
    I noticed this specially from 2G -> 3G/4G.
     

    #11
  12. ritchiedrama Ice Cream Sandwich Jul 6, 2016

    ritchiedrama, Jul 6, 2016 :
    Sent a refund request in, don't like dealing with hassle, lol back to my old S3 I guess :D
     

    #12
    malidan likes this.
  13. jak Ice Cream Sandwich Jul 15, 2016

    jak, Jul 15, 2016 :
    I can reproduce this here in Germany. The OnePlus One stays in the same LTE network all the time, whereas the OnePlus 3 cycles through two LTE towers, to a HSPA+ tower, to a 3G connection, to Edge. It's insane. Looking at the stats, the connection is really weak, despite the phone showing a lot of bars. The SNR is about 4-9 on the good network whereas the OnePlus One has 9-14, both at about -109 dBm.

    And the OnePlus One does not even support band 20, which is the only LTE connection that is listed as available in this place (we are surrounded by some others, but the provider map does not show them as covering us...).

    I can reach 20 Mbit/s downstream and 1 Mbit/s upstream on the fast LTE connection, with 50 ms pings. Which is OKish, but after some time, it just goes to HSPA (which achieves 6 Mbit/s down at 90ms ping), and then to Edge...
     

    #13
  14. Pdajah Ice Cream Sandwich Jul 16, 2016

    Pdajah, Jul 16, 2016 :
    I've been using LTE on O2 today for over 30 minutes and no issues. I have a strong LTE signal. I have found, however, the One plus 3 does not like a weak signal for data. Had a lot of difficulties earlier last week when I had a weak 2G signal and would not give me a data connection. Please note the LTE mast may limit connections in very busy city areas and the One plus may not be happy with a weakening signal and therefore switches to the other options.
     

    #14
  15. G_Simon_Atkinson_wqNP Eclair Jul 17, 2016

    G_Simon_Atkinson_wqNP, Jul 17, 2016 :
    According to the specs, the Oneplus 3 does support band 20... as long as you got the Europe model.

    https://oneplus.net/uk/3/specs
     

    #15
  16. omar2016 Cupcake Jul 18, 2016

    omar2016, Jul 18, 2016 :
    im on the o2 network and thankfully i have had no issues regarding the data connection dropping to E.You could of returned the phone and ordered another one.
     

    #16
  17. Curious5555 Cupcake Jul 18, 2016

    Curious5555, Jul 18, 2016 :
    From my research it seems Android 6.0.1 does this. But the forum has no-one else with issues?

    Any help? Thanks.
     

    #17
  18. jak Ice Cream Sandwich Jul 18, 2016

    jak, Jul 18, 2016 :
    Yes, I wrote that the OnePlus One does not support it, but still has better results than the OnePlus 3 which supports the band...
     

    #18
  19. G_Simon_Atkinson_wqNP Eclair Jul 18, 2016

    G_Simon_Atkinson_wqNP, Jul 18, 2016 :
    Apologies. Missed the second one! Must get new glasses!
     

    #19
  20. rmarrins Cupcake Jul 20, 2016

    rmarrins, Jul 20, 2016 :
    This problem isn't just specific to o2 in the UK, happening to me all the time on Vodafone UK and seems like three users are also having problems. What an earlier poster said, it seems like unless the 4g signal is really storng, the phone will automatically switch to a 3g/2g networks. Never had this issue on Vodafone UK with any other handsets, so I am sending the phone back.
     

    #20
    malidan likes this.