2
OxygenOS Oneplus 3 / Oneplus 3t Unbrick Simple steps

  1. vai04
    Cupcake Nov 24, 2017

    vai04 , Nov 24, 2017 :
    So I am going to make some simple steps which will be simple for everyone
    To Unbrick your Oneplus 3 / Oneplus 3T You need to start from downloading Unbrick tools here.

    1. You can download the complete unbrick tool from here
    HTML:
    https://mega.nz/#!Q1YnTTAT!gnLf6NEkSRy7W-WY8J0H2SmJJLzO91-vReKx7B1VVpI
    2. Drivers from here
    HTML:
    https://mega.nz/#!AgohmbqC!h16GeeOnlvubYDyfID3feY-qVJuBZiWVvYsXSAeKIA8
    3. ONLY IF YOU ARE ON Windows 8 OR HIGHER download and follow this guide
    HTML:
    https://www.howtogeek.com/167723/how-to-disable-driver-signature-verification-on-64-bit-windows-8.1-so-that-you-can-install-unsigned-drivers/

    With These three you are ready to unbrick your device.
    1: Extract Drivers and Recovery Tool files on Desktop.
    2: Install the drivers from drivers folder.
    3: If you are using windows 8 Or higher follow the guide in STEP no -3 above.
    4: Switch off your device and wait for 60 seconds.
    5: Press [VOLUME + AND VOLUME -] TOGETHER and HOLD while holding them plug your USB DASH CABLE ON PHONE (that cable needs to be connected on the PC first)
    6: Go to unbrick tool and extract the files and run the MSM Download Tool as administrator.
    7:If you see the phone is connected in one of the com ports shown click start at top left corner and wait for it to finish (green text will come). AND YOU ARE DONE YOUR DEVICE WORK AGAIN.
    8: If you don't show the connection in com port. You need to follow the 5 STEP again while running the tool.
    9: Even if that doesn't work you need to install the drivers again and try step no - 6 and step no 5 again usually it works in first time.

    HOPE IT HELPS THANKS :)
     

    #1
    nxll and avfoster like this.
  2. Timothy Garcia
    Cupcake Dec 14, 2017

    Timothy Garcia , Dec 14, 2017 :
    Hi, yesterday, my OP3 started to malfunction and stop all apps and have random hard bricks. I would force restart the phone and try to wipe all the cache and data but it says that "device state is locked". I haven't got the chance to run fastboot on it through cmd prompt and try to force reboot the bootloader. But now my phone is hardbricked with no response at all whenever I press all the buttons with the combinations for hard reset. So I followed the steps but still no luck. The device is recognizable by my pc whenever I plug and unplug but once I run step 6 & 7, it always fails. Once I press start, it would say "open serial device" and shortly after, "Start download Firehose Binary" and then "waiting for the device connection" beside it. And then it will say "Sahara Communication Failed", and when I verify it, the results says all are okay (please see attached photos below). I also made sure to power down the device by holding down the power down button for 40 seconds but still no luck.

    Waiting for your feedback. Thanks!
     

    Attached Files:


    #2
  3. vai04
    Cupcake Dec 15, 2017

    vai04 , Dec 15, 2017 :
    Hi, I would suggest you to try the below drivers and a different tool because the tool you are currently using is dedicated to 3t
    Drivers
    HTML:
    https://androidfilehost.com/?fid=24052804347799753
    TOOL
    HTML:
    https://androidfilehost.com/?fid=24591000424942573
    Run as administrator for both and please confirm when you follow step 5 and phone gets recognized by pc you do see notification light works or not?
     

    #3
  4. Timothy Garcia
    Cupcake Dec 15, 2017

    Timothy Garcia , Dec 15, 2017 :
    Hi. no notification light. no response whatsoever. But I let it rest over night without charging and then the next day, when I charged it, I was able to turn it on and it went into fastboot so I started to unlock the device and enable dm-verity but still no luck. So I just used the device hoping that it wont crash, but then it started to restart and hard brick once again.
     

    #4
  5. Timothy Garcia
    Cupcake Dec 15, 2017

    Timothy Garcia , Dec 15, 2017 :
    Just an update, I was able to start download from MSM but it would always stop and fail and say "SetBootAbleStorageDriveto1 Failed".
    (See attached image)
     

    Attached Files:


    #5
  6. Timothy Garcia
    Cupcake Dec 15, 2017

    Timothy Garcia , Dec 15, 2017 :
    update once again. It finished downloading, however the phone failed to boot up and the pc made a sound that recognizes the phone and the download process started to begin once again. Help please Idk what to do anymore.
     

    Attached Files:


    #6
  7. vai04
    Cupcake Dec 18, 2017

    vai04 , Dec 18, 2017 :
    1. If you can make fastboot work again don't try to enable dm-verity as encryption is different for all phones.

    2. I would suggest you if FASTBOOK works USE ADB sideload and install the stock rom and it will work then you can go ahead and unlock the boot loader if needed. and I would suggest you to unlock it without enabling dm-verity.

    3. Now if you can't make it till FASTBOOT, I think there is issue with drivers or PORT you can try changing the USB post as when I used MSM the phone worked like a charm with same rom.

    4. Use MSM try to get into ADB sideload or FASTBOOT and FLAST STOCK firmwire switch on the Phone and then go ahead for Unlocking bootloader and ROOT
     

    #7
  8. MysteriousPatron
    Cupcake Apr 4, 2018

    MysteriousPatron , Apr 4, 2018 :
    unbrick tool went success.. bt still my device won't boot up.. it comes to that red and white dot animation, stays normal till around 30 secs.. and bam, switch off again... anyone familiar with this?? help me
     

    #8
  9. ttttoshutripathi
    Cupcake Jul 15, 2018

    ttttoshutripathi , Jul 15, 2018 :
    ---------sorry for my bad English---------]
    ------my mobile stuck on boot animation... reloading again n again( not -rooted no custom recovery, it's a stock ROM ..even never open dev setting)

    2 days ago my mobile gets switched off at night /.....early morning I plugged in .after around 1 hr I saw mobile is not getting switched on.
    only fast boot mode working at that time..(stock recovery also not working).
    So far what i did

    1--First of all, I used the unbrick tool.( mega.nz/#!Q1YnTTAT!gnLf6NEkS...1-vReKx7B1VVpI)..
    2-- All Drivers and adb Installed
    3-- after When the process is complete with the MSM Tool, the Green Line Text also came.
    I got the cable out of the mobile and then started it. Again stuck in boot animation. This process only got the benefit that stock recovery started again.
    I started stock recovery and did not know how many times I wipe cache, wipe all data but the result was same all time ..still stuck in boot animation.

    4---After that, I installed ROM from the ADB sideload(command was -------adb devices then ADB sideload "filename".zip).
    but nothing changed..still stuck on boot animation. (only stock rom OnePlus 3T OxygenOS 3.5.4 and OnePlus 3T OxygenOS 3.5.3 is working, Both of these ROMs come up to Boot animation, The rest of the rom is switched off only after powered by Android)

    lastly, I tried to unlock OEM but it says remote OEM unlock not allowed . its failed 0.016 sec
     

    #9