4
Oneplus 3 refuses to update to 4.0.3

  1. Kiran.a.joseph
    Jelly Bean Feb 13, 2017


    #41
    rcain68 likes this.
  2. JacKok
    Cupcake Feb 13, 2017


    #42
    rcain68 likes this.
  3. AbieAmadea
    Cupcake Feb 13, 2017


    #43
  4. F_Ayush_Mishra_Lhjk
    Cupcake Feb 14, 2017


    #44
  5. MD ANIS ANSARI
    Cupcake Feb 14, 2017

    MD ANIS ANSARI , Feb 14, 2017 :
    1.4 gb would be the the update of nougat and 91 mb update is for 4.0.3.
     

    #45
  6. Hish98
    Ice Cream Sandwich Feb 14, 2017

    Hish98 , Feb 14, 2017 :
    i got the same problem and my update got failed so what i did was download ota manually (91mb) and install it from recovery
    piece of cake
     

    #46
  7. Kamlesh.07
    Cupcake Feb 14, 2017


    #47
  8. kintar
    Froyo Feb 14, 2017

    kintar , Feb 14, 2017 :
    yep same problem. first it's only 97mb update. and then goes to 1448mb update. try to restart it, and failed on recovery mode.
     

    #48
  9. fiechr
    Cupcake Feb 14, 2017

    fiechr , Feb 14, 2017 :
    Same issue here. All stock, no root. Previous updates worked fine.

    Device is encrypted.
    1. Small 4.0.3 update downloads and fails (Recovery appears instead of just doing the update and restart).
    2. Full 4.0.3 update downloads and also fails (same behaviour).
    3. Tried to manually install the zip file which was downloaded by the updater - but the recovery/device won't accept my unlock pattern (decryption failed). Though this may be normal and has nothing to do with the actual error.
     

    #49
  10. rembeau
    Cupcake Feb 15, 2017

    rembeau , Feb 15, 2017 :
    Same issue. I get a bunch of options on the reboot screen and it the installation still fails. Guess I'll wait until they fix the bug.
     

    #50
  11. G_PRADEEP_MAHATO_ObXt
    Cupcake Feb 15, 2017


    #51
  12. kintar
    Froyo Feb 15, 2017

    kintar , Feb 15, 2017 :
    after some trial error, I successfully install the latest update. Maybe it's quite easy for you guys but lot of people experiencing the same problem and didnt know how to solved it.

    updating via setting > system updates always failed for me. and then i try to re-download the update. and after finished, i go to file manager (I use root explorer, not default file manager from oneplus), then copy (copy, not cut) file update (zip file) from folder .OnePlusH2Ota to root memory.

    then go to setting > system updates, press reboot now. Phone will asking for patern password, then failed to flash, and it will go to recovery mode.

    in recovery mode, choose english, go to wipe data and cache > choose wipe chache. oh, please dont press the other wipe menu, wipe cache ONLY. then press back (press right softkey for back ;) ),

    then press install from internal storage > choose file that we have copied earlier (zip file) in root memory. wait till done. it will takes a several minutes.

    congratulation for the latest update :D
     
    Last edited: Feb 15, 2017

    #52
    ushe123 likes this.
  13. ushe123
    Cupcake Feb 15, 2017

    ushe123 , Feb 15, 2017 :
    This actually helped dude, i followed every step and it actually went through the update without errors or anything. Thanks man. To all the others out there, this is what a stock user like me (who knows nothing about rooting, sideloading or whatever) needs, to get through this. An easy to follow step by step guide :D
     

    #53
  14. Walter.White
    Eclair Feb 18, 2017

    Walter.White , Feb 18, 2017 :
    Hi, thanks for the info.
    I have few simple questions:

    Will this procedure wipe my phone's apps and data?
    Also as a stock user (non rooted), I don't see the option how to access root in any file manager, so I'd appreciate a bit of help here as well.

    Cheers!
     

    #54
  15. kintar
    Froyo Feb 19, 2017

    kintar , Feb 19, 2017 :
    as long as you only wipe cache, you are good to go. it won't affect apps and data whatsoever. so don't worry.

    my device is not rooted too ;) root memory means the storage/emulated/0 as you can see on attachments below. (use root explorer apps or similar apps)

    hope this will help ;)
     

    Attached Files:

    Last edited: Feb 19, 2017

    #55
  16. Walter.White
    Eclair Feb 26, 2017

    Walter.White , Feb 26, 2017 :
    Thanks kintar!

    I'd like to confirm that provided method works without any problems. Also no harm for existing apps and data, clean update!

    One additional question: I guess it's safe to delete .zip file (after successful update) which I copied to root memory?
     

    #56
  17. kintar
    Froyo Feb 28, 2017

    kintar , Feb 28, 2017 :
    yes you can delete it :)
     

    #57