1
OnePlus 3 VoLTE not working after rooting [India - Jio 4G]

  1. jitheshkt
    Donut Jul 24, 2016

    jitheshkt , Jul 24, 2016 :
    I am not sure about this. But after rooting (unlock bl, changing recovery to TWRP, installed SU) my Reliance Jio app is not detecting the SIM card to enable VoLTE. However, 4G data is working fine in the same SIM card. Is root is the cause for this ? is there any place I have to enable VoLTE in OP3 after a factory reset/wipe ?
     

    #1
    adcool2007 likes this.
  2. Deactivated User
    Jul 24, 2016


    #2
  3. jitheshkt
    Donut Jul 24, 2016

    jitheshkt , Jul 24, 2016 :
    Thanks for the reply. But I don't have enhanced LET in Cellular Network Settings. However when I search for it in Settings, it shows in the search result, but when I click on it it takes me to Cellular Network Settings and there I can't find it. Please advice.
     

    #3
  4. Sukhpreet Gill
    Gingerbread Jul 24, 2016

    Sukhpreet Gill , Jul 24, 2016 :
    You dont need the JIO app to activate the VoLTE. It is a feature of the sim and not the app. As soon as the phone detects a VOLTE enabled sim, VoLTE toggle apears under the cellular settings. If the LTE data is working fine then a simple reboot should fix your problem. Rooting has nothing to do with it.

    Additionally, JIO doesn't play nicely with a dual sim as it is suposed to be used on Samsung phones for now. I am.not sure if it is a OOS side gltich or Jio side. My primary sim is Airtel and whenever a call comes on Airtel, Jio VoLTE disconnects automaticaly and post that i have a hard time to enable it again. A manual reboot and manual selection of the carrier fixes the problem. However, if you used as a single sim then it runs like a boss.
     

    Attached Files:

    Last edited: Jul 24, 2016

    #4
  5. jitheshkt
    Donut Jul 24, 2016

    jitheshkt , Jul 24, 2016 :
    Thanks for the detailed explanation. Mine is not a hacked sim. It is a retailer sim. So it does support any device officially (been using this on my OPO, Xperia, X Play). I just lost VoLTE after rooting and factory resetting. Now completely wiped and installed 3.2.1 still the same. Trying on single SIM now.

    Update : no hope. What are the chances that this is network glitch ?
     
    Last edited: Jul 24, 2016

    #5
  6. ungeeked
    Ice Cream Sandwich Jul 24, 2016

    ungeeked , Jul 24, 2016 :

    There is an app called hideroot and xposed module called rootcloak. If Reliance is detecting root status then these should help. However, how is Reliance detecting the root in the first place?

    I also heard that Reliance has issued notices to all retailers to not give Sim unless the person shows an eligible Samsung device.

    If they are blocking VOLTE by detecting device, maybe then device faker xposed module might help.
     

    #6
  7. pablofg1978
    Spanish POC Assistant Head Moderator Jul 24, 2016


    #7
  8. jitheshkt
    Donut Jul 25, 2016

    jitheshkt , Jul 25, 2016 :
    As I have told above, they have no reason to block my SIM card. I am using a retailer SIM. Its been with me more than 3 months now. Never faced this till now. :(
     

    #8
  9. ithehappy
    Cupcake Jul 25, 2016

    ithehappy , Jul 25, 2016 :
    Have you found a solution? If you've then please mention.

    I am not a One Plus phone owner by the way, so if my post is not suitable here please feel free to delete it. I use a Note 4 and I've got the Jio SIM just yesterday. Everything was working all fine, but then I did a clean installation of the ROM as I had an update, but since then the VoLTE (or basically any voice calls, both incoming and outgoing don't work, outgoing texts don't work either) is disabled, I can only use the LTE option to access internet. When others are calling my Jio number it is being mentioned as switched off or out of reach, and I even get the text message notification on the Jio number about the missed call! I have all the Jio apps installed. I have tried rebooting multiple times, selecting Jio 4G network manually and even chatted with Reliance CCR to redo my APN settings freshly! Nothing!

    Here's a video of the problem,

     

    #9
  10. Bibin138
    Gingerbread Jul 27, 2016

    Bibin138 , Jul 27, 2016 :
    Im using it in my OP3, in my primary sim i have put vodafone 4g and in secondary sim im using jio sim, but i see that jio is getting disconnected and reconnected to LTE frequently. Did anyone else facing this issue ?
     

    #10
  11. Bibin138
    Gingerbread Jul 28, 2016

    Bibin138 , Jul 28, 2016 :
    I have checked jio sim in slot 1 and i see that network get disconnected after couple of hours and i need to manually reconnect it. im using vodafone 4g sim in slot 2. anyone else facing this issue?
     

    #11
  12. blr
    Donut Jul 31, 2016

    blr , Jul 31, 2016 :
    Hello,

    Alomost same problem for me on my Rooted and Bootloader Unlocked OnePlus Two.

    I have to use JioJoin app for Voice Calls as there is no Jio VoLTE support in OnePlus.

    I was able to complete JioJoin app installation couple of times. But I am unable to make calls as its gets disconnected before placing. Switched off message is heard for incoming calls.

    So tried reinstalling JioJoin app and now I am unable to complete installation.

    Let me know if any solution.
     

    #12
  13. munnangiaswin
    Cupcake Aug 5, 2016

    munnangiaswin , Aug 5, 2016 :
    @Bibin138
    I think there is some issue of Jio Sim compatibility with OP3. I am also facing the same situation. Irrespective of the SIM Slot, JIO sim is going into No network mode after 1 to 2 Hours. I request OP3 to look into the issue and solve the problem.
     

    #13
  14. Bibin138
    Gingerbread Aug 6, 2016

    Bibin138 , Aug 6, 2016 :
    Go to developer option and switch on " always keep mobile data on" option. this is the second last option under networking. This will solve the issue. How is your battery life when you are on jio ?
     

    #14
  15. pkarthik24
    Cupcake Aug 25, 2016

    pkarthik24 , Aug 25, 2016 :
    I used the method you have mentioned, hope it works perfectly, will update after using for a day... by the way, by enabling always Data on option, will that consume more amount of battery?
     

    #15
  16. munnangiaswin
    Cupcake Sep 3, 2016

    munnangiaswin , Sep 3, 2016 :

    Sorry to say that this technique is not working
     

    #16
  17. amitsanon
    Cupcake Sep 5, 2016

    amitsanon , Sep 5, 2016 :
    I recently got the op3. Got an update and it was running 3.2.4. Volte was working just fine in dual sim mode - Jio as primary and Airtel 4g as secondary sim. No disconnections. I rooted my phone and installed op3-lite rom (from XDA). Volte still working and no problems whatsoever
     

    #17
  18. Bibin138
    Gingerbread Sep 10, 2016


    #18
  19. Aswinisal
    Donut Nov 21, 2016

    Aswinisal , Nov 21, 2016 :
    I am also having this same problem after the rooting. have you solved it ???
     

    #19
  20. Saurav Pillai
    Honeycomb Nov 22, 2016

    Saurav Pillai , Nov 22, 2016 :
    go to sim toolkit and select sim 1>home IMSI
    u will lose the signal after this and then just reboot ur phone ,volte sign should appear
     

    #20