22
Network/Connectivity

oneplus 3 wifi is very sensitive and keeps disconnecting.

  1. sahirhussain Honeycomb Jul 17, 2016

    sahirhussain, Jul 17, 2016 :
    i have 3 oneplus 3's in my house and all 3 have a problem connecting to wifi at my house. all my other wifi devices can connect and work fine but all our OP3s keep disconnecting every 2-3 minutes and display an exclamation mark on the wifi icon. 3.2.1 made the situation worse so i downgraded my phone to 3.1.2 but the problem still persists. it seems that the wifi software or the wifi radio is pretty sensitive to fluctuations in network and simply chooses to disconnect even at the slightest hint of a disruption while other devices can neglect that minute fluctuation and maintain a connection.
    I have tried multiple wifi connections and mobile hotspots to confirm my findings.
    @Adam Krisko @Carl

    UPDATE
    those experiencing wifi problems please do this and report back. check aggressive wifi handover settings in developer options.
     
    Last edited: Aug 2, 2016

    #1
  2. 3XP0R Eclair Jul 17, 2016

    3XP0R, Jul 17, 2016 :
    I'm getting sick of the fact that Oneplus is not fixing the wifi issues in Oneplus 3. They really need to be fixed and they haven't yet.
     

    #2
  3. wwn Cupcake Jul 17, 2016


    #3
  4. sahirhussain Honeycomb Jul 17, 2016

    sahirhussain, Jul 17, 2016 :
    it is hampering the experience for me. i ended up overshooting my mobile data limit because of the above mentioned wifi issue and will now have to huge overage fees. this needs to be addressed as soon as possible by the oneplus team.
     

    #4
  5. Pdajah Ice Cream Sandwich Jul 17, 2016

    Pdajah, Jul 17, 2016 :
    Have you used in a case or "naked"? I found the wifi is not as good as reception on my LG G5 but using it without a case does help.
     

    #5
  6. sahirhussain Honeycomb Jul 17, 2016

    sahirhussain, Jul 17, 2016 :
    i am using it without a case. also, a case does not matter when you are in the same room as the router and have a full signal only to find that it suddenly disconnects.
     

    #6
  7. Pdajah Ice Cream Sandwich Jul 17, 2016

    Pdajah, Jul 17, 2016 :
    Wow. I didn't realise. I've never had that issue with my OP3. Have you got any BT devices around connected to your OP3? WiFi and BT do interfere with each other. Also see if you router can run at 5ghz.
     

    #7
  8. iverness Cupcake Jul 17, 2016

    iverness, Jul 17, 2016 :
    Both of my OP1 and 3 are having the same issue unable to connect to the wifi whereas my Nexus 7 2013 is fine. It seems to happen rather recently
     

    #8
  9. sahirhussain Honeycomb Jul 17, 2016

    sahirhussain, Jul 17, 2016 :
    my router isnt 5ghz capable but since this happens on all wifi connections (i have tried at my friend's place), it isnt a router issue.
     

    #9
    nousername098 likes this.
  10. jaylar Eclair Jul 17, 2016

    jaylar, Jul 17, 2016 :
    Never had a problem with mine have you tried it on a different WiFi supplier virgin for example
     

    #10
  11. gamecrawler Cupcake Jul 17, 2016

    gamecrawler, Jul 17, 2016 :
    Im having a similar problem, my OP3 had extremely slow wifi speeds until i have to reset the router.....none of my other divices have this issue. Strange indeed..
     

    #11
  12. tomtiti Cupcake Jul 17, 2016

    tomtiti, Jul 17, 2016 :
    Oh I thought I was the only one getting this exclamation mark issue :(

    Even at a short distance, wifi is really bad, I have a great wifi router with fiber optic: I "only" achieve 120mbps on speedtest.net. I had about 360mbps with my galaxy s6.
     

    #12
  13. jayrob Honeycomb Jul 17, 2016

    jayrob, Jul 17, 2016 :
    Time to invest in a new router perhaps.
     

    #13
  14. TheAwesomeSir Gingerbread Jul 17, 2016

    TheAwesomeSir, Jul 17, 2016 :
    Yeah, WiFi on my OP3 compared to my OPO is slower. OnePlus probably cheaped out on the WiFi chip.
     

    #14
    nousername098 likes this.
  15. Skewby Froyo Jul 17, 2016

    Skewby, Jul 17, 2016 :
    No problem here. They probably have an issue speaking with your router. Try changing encryption, Channel etc.
     

    #15
  16. Pdajah Ice Cream Sandwich Jul 17, 2016

    Pdajah, Jul 17, 2016 :
    I'm achieving the same speed on my LG G5 and OP3 over wifi running at 5ghz. Download speed around 56mbps.
     

    #16
  17. guanyu210379 Jelly Bean Jul 18, 2016

    guanyu210379, Jul 18, 2016 :
    1+1 is having issues connecting to WiFi? I have 1+1 and it is still my daily driver. I do not know if such problem exists.
    I think..your router sucks...
    I am using an old DLink DIR 645.
    No WiFi issue on my 1+1.
     

    #17
    robbiegast likes this.
  18. iuriandre Eclair Jul 18, 2016

    iuriandre, Jul 18, 2016 :
    Oneplus 2 and 3 have mediocre antenas but support on wifi software/enhancement its crappy like hell one of the problems their phones have.
     

    #18
    Zeb101 likes this.
  19. sahirhussain Honeycomb Jul 18, 2016

    sahirhussain, Jul 18, 2016 :
    wow. what a helpful answer there. i should invest in a new router because one device with a weak/cheap wifi chip/software does not play nice with my router while my 2015 macbook pro, my 5 year old desktop (it has wifi via a usb dongle), my 2nd phone (a moto g) my wife's 3 year old HP laptop, my samsung smart tv and even my domestic help's redmi phone connect and work absolutely fine with my router.

    i also use a reliance jio 4g connection in a lyf handset as mobile hotspot and all my other devices work fine with it but for my OP3 which disconnects every 1-2 minutes but i should invest in a new router. yeah right!

    to conclude, i would like part away with a saying "when you cannot contribute to a discussion, stay quiet". i hope you will listen and imbibe this beautiful quality and see how it positively changes your life for good.
     
    Last edited: Jul 18, 2016

    #19
  20. Professorchaos1 Honeycomb Jul 18, 2016

    Professorchaos1, Jul 18, 2016 :
    0 problems on Netgear R7000 and D-Link DIR-868L running AdvancedTomato over 5GHz or 2.4GHz. Also no problems connecting to Linksys WAP-610N 2.4GHz Access Point.

    If you are having issues, it's not just the only phone having issues. Since it uses same hardware as G5,S7,Mi5. Axon 7..you can expect problems with those as well. Good luck. Maybe try another router before bashing the phone.
     

    #20