22
Network/Connectivity oneplus 3 wifi is very sensitive and keeps disconnecting.

  1. Loboj
    Cupcake Jul 23, 2016

    Loboj , Jul 23, 2016 :
    I am facing same issue with my OP3 phone as well.. At the same time other phone that i have moto g4 plus runs seamlessly.. would like to mention that while its connected it is fast as a breeze but it regularly disconnects for some reason
     

    #61
  2. PVRP
    Honeycomb Jul 24, 2016

    PVRP , Jul 24, 2016 :
    In my OP3, a can only complain frome the range, it's inferior to the OPO, and consequently looses connection when the signal is weak/obstacles.
    Regarding to speed I compared to my laptop at the same distance and the OPT is faster.
     

    #62
  3. bertboy
    Donut Jul 24, 2016

    bertboy , Jul 24, 2016 :
    Are you sure you need to switch over the whole of your network? My (old) Chromecast is on 2.4 GHz while my laptop is on 5GHz and they work together flawlesly.
    I remember Wifi-issues with some OPO's. A solution that helped me (and some others) was giving the device a fixed IP.

    The wifi-issue on OP3 in't bothering me enough (seems to disconnect only when idle...), so I haven't tried it yet.
     

    #63
  4. movisman
    Donut Jul 24, 2016

    movisman , Jul 24, 2016 :
    Hi,

    Yeah for me, it causes issues if my Chromecasts are on 5ghz but my Android client is on 2.4ghz, mainly because the 2.4ghz and 5ghz have to broadcast on different SSID's on my Superhub 2AC.
     

    #64
    bertboy likes this.
  5. movisman
    Donut Jul 24, 2016

    movisman , Jul 24, 2016 :
    I have ran a couple of tests and fiddled around a bit but haven't had much time, but will do more. Even though there are no other routers or devices in my neighbourhood using 5ghz (everyone is using 2.4ghz so have it to myself!), I have found the following:

    When my router channel select is set to default, called "auto compatibility", it seems to choose the lower channels in Band A (36, 40, 44, 48) for example, I guess for compatibility. Now, using this setup, my other devices are fine and I get good speeds, but the OP3 doesn't seem to like these and I get poor speed and range.

    Changing the option to "auto performance", prefers the lowest channel in Band B (100, 104, 108, 112 for example). The range and speed are vastly increased on the OP3 in this mode, I believe the other devices are the same but I need to verify. This also applies if I manually select a channel.

    My router 5ghz network is also set to maximum performance (1.3gbps), so it uses 4 channels.

    I find this all a bit odd, so I need to test more to be sure of the behaviour to make sure there isn't another variable at play. A quick test using Speedtest (when on the lower channels in Band A) on the OP3, rarely gives me decent speeds at all. However when on the higher channels, the speed is trebled.

    All very curious. Nothing is interfering in the lower channels because there are no other networks in radius which is using 5ghz. WiFi Analyzer confirms this. And the other devices perform fine whatever channel you use.

    Maybe some people can try the above, and see if they get the same effect. Just to see.

    Need to check now if I still have occasional WiFi disconnects when idle, which I guess is due to Doze (even though WiFi should always be on). I probably will have as I think this is a separate issue, but will verify.

    Static IP didn't make any difference/improvement for me btw, same goes for using legacy DHCP.

    Cheers
     

    #65
  6. MarkusRanz
    Honeycomb Jul 24, 2016

    MarkusRanz , Jul 24, 2016 :
    What bothers me is on some spots I get the WiFi exclamation mark and then sometimes 10 meter more away I get WiFi without ! but very weak signal...

    Sometimes I sit on couch and get exclamation mark and then one minute later without moving I get good signal.
     

    #66
  7. movisman
    Donut Jul 24, 2016

    movisman , Jul 24, 2016 :
    Yes, this was happening to me when I was upstairs in the bedroom - highly irritating. This has improved a lot since changing my channel settings to the different band above because my signal up there is now much improved. It hasn't dropped off yet or done the 'exclamation mark' thing, but as I mention above I need to test for a bit longer.

    I do also think though, that the 'cut off' for WiFi dropping back to LTE on the OP3 is more aggressive than other devices. For example my Nexus 5, in a specific location at work (so on a completely different Aruba wireless network) has an average-ish signal, but it still remains connected to WiFi and the internet is browse-able. The OP3 though, often drops off to LTE, instead of retaining a signal. It seems on the OP3 they removed the option in advanced WiFi to 'avoid poor connections', so perhaps they are using a custom setting. Again, just speculating.
     
    Last edited: Jul 28, 2016

    #67
    sahirhussain likes this.
  8. hasenbein1966
    Froyo Jul 24, 2016

    hasenbein1966 , Jul 24, 2016 :
    I was on vacation and had the OP3 with me. (OOS 3.2.0.)

    Connected to quite a number of different WiFis in hotels, cafes etc.

    Worked all without any problems. Good range and data rate, no sudden disconnects.
     

    #68
  9. stephenboyo
    KitKat Jul 24, 2016

    stephenboyo , Jul 24, 2016 :
    I think you should rename the thread with My wifi keeps disconnecting from OP3" as this is a problem with your wifi or the settings on your phone and not a generic issue with the OP3. I've never been disconnected or lost wifi signals when I'm connected. Your thread gives out the wrong impression and I don't think OO can solve this issue for you either. Sorry..
     

    #69
  10. hadighattas
    Honeycomb Jul 24, 2016

    hadighattas , Jul 24, 2016 :
    I do have the issue too as well as many users here and on xda forums so the issue is not user specific :)
     

    #70
    jobinmatt likes this.
  11. holti
    Eclair Jul 24, 2016

    holti , Jul 24, 2016 :
    This definitely isn't a WiFi issue and is a device issue.
    I'm having the exact same problem. I've turned mobile data off and it seems to have stopped disconnecting but it's a pain having to remember to turn it on every time I am not in a WiFi area
     

    #71
  12. stephenboyo
    KitKat Jul 24, 2016

    stephenboyo , Jul 24, 2016 :
    It's a strange one then, most phones will react differently to LTE signals but with wifi it should always be stable and not drop off unless the signal is too erratic maybe you need to toggle your wifi signs to align it. It may be a regional issue too
     

    #72
  13. sahirhussain
    Honeycomb Jul 25, 2016

    sahirhussain , Jul 25, 2016 :
    did you even go through the thread before posting? a lot of people have posted similar experience as mine with regard to their OP3s wifi. next time, before giving out an unsolicited advice, read!
     

    #73
    hadighattas likes this.
  14. espinozaja
    Eclair Jul 26, 2016

    espinozaja , Jul 26, 2016 :
    Went to work this morning and was having the same issue. I reset to factory defaults and reconnected to the work WIFI and it was stable all day. Came home and reconnected to my home wifi. Unfortunately, I have the issue again. I've tried turning off the cellular mobile, and I've changed the channels, but no luck.
     

    #74
  15. MarkusRanz
    Honeycomb Jul 26, 2016

    MarkusRanz , Jul 26, 2016 :
    Definitely has something to do with the position of phone and router.
    I have zero problems in bedroom which is directly under the router(just the floor/ceiling in between. But in living room signal is often weak...
    There are dozens of other devices around including a fire TV which can stream perfectly in HD.
    I will try to position the antennas more horizontal in the next days and see if that makes the situation better.
    Looks like the OP3 needs a higher signal to connect to fast internet compared to other devices...
    I am perfectly fine with a few MBit and a short ping but I understand that the speed junkies here which need 50mbitt hate that circumstances.
     

    #75
  16. loijancours
    Froyo Jul 31, 2016

    loijancours , Jul 31, 2016 :
    Still have this issue! I did a factory reset of my phone for nothing! I contacted the oneplus support and they give no shit about this issue. Tired of this f*cking company. I'm going to sell the phone this week. No more oneplus devices!
     

    #76
  17. cmanon
    Cupcake Aug 1, 2016

    cmanon , Aug 1, 2016 :
    Same issue here, I've tried a factory reset, I have two routers and seem that just one is giving issues, the weird thing here is no other device in my home network has this type of issues.
     

    #77
  18. SimonFullerImagery
    Jelly Bean Aug 1, 2016

    SimonFullerImagery , Aug 1, 2016 :
    I could get halfway down the street before my WiFi disconnected with my op2. I can barely get down the stairs of my apartment with the op3.. As somebody else pointed out, the smallest fluctuations can disconnect the phone. Shoddy.
     

    #78
  19. ITonev
    Cupcake Aug 2, 2016

    ITonev , Aug 2, 2016 :
    I have the same frustrating issue with dropping wifi connection with my OP3. Other devices at home are not facing such problems with wifi connection. I have LG Optimus 3 (rather ancient and low end device), Mobiwire Telenor SmartPlus and Lenovo K3 Note. All of them are performing much better in wifi without drops and re-connections. No issues with my laptop Lenovo T430 as well. I am using TP-Link TL-WR841N.
    On top of that I have another problem when using wifi for a longer period. For example when I am at home in the evening and go to work in the morning phone is not switching to mobile data. I have to manually switch between preferred network types in order to get mobile data. It is really annoying.
     
    Last edited: Aug 2, 2016

    #79
  20. sahirhussain
    Honeycomb Aug 2, 2016

    sahirhussain , Aug 2, 2016 :
    check aggressive wifi handover settings in developer settings and report back.
     

    #80