22
Network/Connectivity oneplus 3 wifi is very sensitive and keeps disconnecting.

  1. MarkLR
    Jelly Bean Aug 2, 2016

    MarkLR , Aug 2, 2016 :
    I have minor issues with this as well. Sometimes in areas of my house where the signal is weak, the phone loses connection. I think this has to do with the fact that the WiFi antenna is not very good in this device. When the signal is strong, it doesn't disconnect. My previous phone, the Sony Xperia Z3, also had the same issue in those areas of my house but not as bad as this one. Unfortunately sometimes when this happens and I'm not careful, I end up draining my mobile data because the phone switches to LTE and since I'm mostly watching youtube when at home, I can drain all my data in a couple of hours. It happened to me quite a lot with the Z3 so I'm super careful now and I disable LTE as soon as I get home.

    Bottom line, I fear this might be a hardware related problem. The phone has an inferior WiFi antenna and it is more suceptible to dropping weaker connections.
     

    #81
  2. wii747
    Eclair Aug 2, 2016

    wii747 , Aug 2, 2016 :
    I am finding WiFi handover from one access point to another access point slow, It does not automatically connect to the strongest signal.
     

    #82
  3. ITonev
    Cupcake Aug 2, 2016

    ITonev , Aug 2, 2016 :
    Just checked it. "Aggressive Wi-Fi to Cellular handover" is switched off.
     

    #83
  4. sahirhussain
    Honeycomb Aug 2, 2016

    sahirhussain , Aug 2, 2016 :
    switch it on and see if it makes any difference. this sounds like 'avoid slow/weak wifi' setting that could be found in wifi advanced settings and could have a bearing on wifi disconnections on op3.
     

    #84
  5. ITonev
    Cupcake Aug 2, 2016

    ITonev , Aug 2, 2016 :
    OK, I will try it. I suppose it will affect a little bit battery life, right?
    Just to be clear...switching it on could affect wi-fi disconnections or the problem with switching from wi-fi to cellular data after long usage of wi-fi?
     
    Last edited: Aug 2, 2016

    #85
  6. daninantro
    Ice Cream Sandwich Aug 2, 2016

    daninantro , Aug 2, 2016 :
    Did u guys try enabling use legacy client from lollipop through developer settings? that can help. :)
     

    #86
  7. ITonev
    Cupcake Aug 4, 2016

    ITonev , Aug 4, 2016 :
    I switched on "Aggressive Wi-Fi to Cellular handover". Now there are no so many drops in connection but still time to time exclamation mark appears on wi-fi icon and cellular data is switching on.
     

    #87
  8. sahirhussain
    Honeycomb Aug 4, 2016

    sahirhussain , Aug 4, 2016 :
    hmm. looks like we have no other option but to wait for a software fix (if its a software bug).
     

    #88
  9. pranaymaheshwari
    Donut Aug 4, 2016

    pranaymaheshwari , Aug 4, 2016 :
    My wifi seems to work fine...
     

    #89
  10. theiNaD
    Donut Aug 4, 2016

    theiNaD , Aug 4, 2016 :
    Having the 1+3 since yesterday, my WiFi worked fine for me. Until I inserted my sim card, being on LTE connection. The WiFi disonnected several times. Switching to 3G only (or max), my WiFi didn't disconnect anymore and the strength seems to be better like yesterday, where my sim wasn't inserted. Maybe like GPS a problem related to LTE (hopefully only SW wise not HW...)
     

    #90
  11. ITonev
    Cupcake Aug 5, 2016

    ITonev , Aug 5, 2016 :
    I experience the problem in both 3G and 2G. No difference between them. But I didn't try without sim card. When I have time I will check this.
    Let's hope that problem is software and OP team will pay attention on it asap.
     

    #91
  12. mrambriz
    Honeycomb Aug 5, 2016


    #92
  13. sahirhussain
    Honeycomb Aug 5, 2016

    sahirhussain , Aug 5, 2016 :
    i would try it if it were available in my country.
     

    #93
  14. Shocky
    Honeycomb Aug 5, 2016

    Shocky , Aug 5, 2016 :
    WiFi is not as good with recent updates, I used to be able to sit at the top of my garden and get a signal, now nothing.

    My Pixel C gets a signal there just fine though.
     

    #94
  15. Shocky
    Honeycomb Aug 5, 2016

    Shocky , Aug 5, 2016 :
    LTE drains your battery faster so it's best to use WiFi where possible.
     

    #95
  16. loijancours
    Froyo Aug 5, 2016


    #96
  17. carlward71
    Gingerbread Aug 10, 2016

    carlward71 , Aug 10, 2016 :
    Yep same here. Could be sitting just a few meters from the router but with all of a sudden, wham, no signal. Playing games is a nightmare as it disconnects as I'm playing. I hope it can be fixed via software as can't go through the pain of RMA like I did with my OPO
     

    #97
  18. Dominique57350
    Ice Cream Sandwich Aug 10, 2016


    #98
  19. Hatha807
    Honeycomb Aug 11, 2016

    Hatha807 , Aug 11, 2016 :
    I have that issue on my OPO - and generally it's not a big deal to me. Kindof annoying when I'm playing Holdem Poker and I occasionally lose a random hand. :mad: I still use it on WIFI all the time, mostly not noticing the issue.
     

    #99
  20. Andrew2437
    Gingerbread Aug 11, 2016