0
OxygenOS OnePlus 3t won't update to Pie?

  1. PenguinColada
    Eclair Jun 14, 2019

    PenguinColada , Jun 14, 2019 :
    Hello, all!

    Yesterday I got the update notification. Yay, we finally get Pie! But I've tried about three times now. It will download, reboot, go into the update screen, then it will say that it failed and prompt me to reboot. I will then have a notification that says "System update failed. Update failed, tap to enter repair mode to try again". Upon doing this, it will check for updates and then come back with a message. "OEM unlock is detected. System will begin downloading the full upgrade package."

    I don't remember unlocking my phone. My husband did some maintenance on it, and perhaps he did that. Is there any way I can correct this? I would really like to update.

    Thank you for your help.

     

    #1
  2. ArxXx
    Froyo Jun 15, 2019

    ArxXx , Jun 15, 2019 :
    hi


    have you ever tried to root your device or anything like unlocking oem...basically anything that would void your warranty? if your bootloader is unlocked you will.most likely have a failed upgrade.
     

    #2
  3. PenguinColada
    Eclair Jun 15, 2019

    PenguinColada , Jun 15, 2019 :
    I have no idea if my device was rooted. If it was, my husband would have been the culprit. He's the one who does any major maintenance on my phone. I'm guessing the OEM is unlocked, judging by the message I received. I know it's a long shot, but do you know if this is repairable?
     

    #3
  4. ArxXx
    Froyo Jun 15, 2019

    Best Answer
    ArxXx , Jun 15, 2019 :
    ok,

    sorry for not reading the entire post the first time.

    your device was tampered with...idk by who, anyways since the bootloader is unlocked

    you need to connect your device to a PC
    download/install op drivers

    download the latest adb and fastboot ( https://forum.xda-developers.com/oneplus-3t/how-to/adb-fastboot-1-0-39-t3599008 )

    download and extract the platform tools to C drive
    enter the platform tools folder, you'll see an application called "adb"

    open command prompt in that folder by holding down shift and right clicking any empty area or open the prompt any other way and navigate to the extracted folder

    now to verify your device is getting detected type in:
    adb devices

    if you see a device listed type in the following:
    adb reboot bootloader

    the device will restart in bootloader
    type in the prompt the following:
    fastboot oem lock


    wait a couple of seconds, the phone will prompt you whether you really want to lock the oem, navigate to yes with the volume buttons and press the power button to confirm...


    Relocking the bootloader will WIPE ALL YOUR PHONES DATA.
    please have a backup in place or if you have everything on the cloud proceed with the steps above.

    once booted, you should have again a notification about the OTA update...download it and install.

    in order to get rid of one portion of the lagging, I did a factory reset after upgrading.
     

    #4
    PenguinColada likes this.
  5. PenguinColada
    Eclair Jun 15, 2019

    PenguinColada , Jun 15, 2019 :
    Thank you. Your instructions are clear. I will do this tonight and see if it fixes my device. Fingers crossed for me, friend!
     

    #5
    ArxXx likes this.
  6. ArxXx
    Froyo Jun 15, 2019

    ArxXx , Jun 15, 2019 :
    let me know how it runs after you're finished.
    and don't freak out if in some cases the loading/spash screen takes forever...it's a major change so it could take a few mins
     

    #6
  7. PenguinColada
    Eclair Jun 15, 2019

    PenguinColada , Jun 15, 2019 :
    Thanks again! I followed your steps and now my phone is rebooting. I didn't have anything important that I haven't already uploaded to a cloud server (I always do this because I've had devices crash and burn on me). We shall see if it updates to Pie.

    Thank you again. I will return with the result. :D
     

    #7
    ArxXx likes this.
  8. PenguinColada
    Eclair Jun 15, 2019

    PenguinColada , Jun 15, 2019 :
    Well, my friend, it worked! I was able to update and my phone seems to be running fine.

    Thank you for all of your assistance. :D <3
     

    #8
    ArxXx likes this.
  9. ArxXx
    Froyo Jun 15, 2019

    ArxXx , Jun 15, 2019 :
    glad I was able to help.
    tell your husband to play on his own phone next time or at least to close all the doors behind him next time when he repairs something :)
     

    #9
    PenguinColada likes this.
  10. PenguinColada
    Eclair Jun 15, 2019

    PenguinColada , Jun 15, 2019 :
    I'll slap his hand away the next time he reaches for the thing. LOL
     

    #10
  11. Paschfire
    KitKat Jun 15, 2019

    Paschfire , Jun 15, 2019 :
    Sorry for the slight OT.

    I'm happy you were able to assist the OP in successfully install OOS 9.0.3, though just a note towards this previous comment.

    Unlocking the bootloader on a OnePlus device does not void the warranty.
     

    #11
  12. antrouss
    Cupcake Aug 25, 2019

    antrouss , Aug 25, 2019 :
    Hello! I have exactly the same issue.
    I have done all the steps, my device is on the bootloader, but I run the command
    fastboot oem lock
    and nothing happens. Nothing is prompt on the phone.
    Have you got any idea why is this happening?
    Thank you in advance!
     

    #12
  13. antrouss
    Cupcake Aug 25, 2019

    antrouss , Aug 25, 2019 :
    Sorry, false alarm, I run fastboot from linux, and I realized that it needs to run as a superuser.
    Thank you very much for the instructions. My issue is fixed.
     

    #13
  14. Saginissim
    Cupcake Dec 2, 2019

    Saginissim , Dec 2, 2019 :
    Hey, I have the exact same problem, only that my phone decided not to connect to the pc anymore...
    Do you guys knows any solution that can help here?
    Btw, it will probably takes to replace the motherin order to connect to the pc
     

    #14
  15. Y1579482445495
    Cupcake Jan 20, 2020


    #15