4
OxygenOS OnePlus 5 bootloop after oreo update

  1. fahmin.ahmed
    Donut Dec 24, 2017

    fahmin.ahmed , Dec 24, 2017 :
    hi, im sorry if there is another thread on this but i am unable to find it. i basically downloaded the oreo update on my oneplus 5 and proceeded to update the phone after the update completed and the phone restarted it went into the oneplus boot animation but was then stuck on that boot animation for 20mins. now my phone keeps getting stuck on that boot and wont start. i can still access fastboot and recovery and my phone has an unlocked bootloader.

    please help!
     

    #1
  2. amicitas
    Cupcake Dec 24, 2017

    amicitas , Dec 24, 2017 :
    I am having the same problem. After receiving the OTA update, my phone has been stuck in the boot animation for about three hours. I finally tried holding the power until my phone turned off, then restarting my phone. It went right back to being stuck in the boot animation. I am unsure how to proceed.
     

    #2
  3. surindergill123
    Cupcake Dec 24, 2017


    #3
    G_Nirmal.K_Menon_NaDh likes this.
  4. Android-Andi
    Jelly Bean Dec 24, 2017

    Android-Andi , Dec 24, 2017 :
    maybe you should mention what version of you have been on previously?
    locked bootloader?
    custom recovery installed?
    rooted?
     

    #4
  5. amicitas
    Cupcake Dec 24, 2017

    amicitas , Dec 24, 2017 :
    I was on the previous OTA update (from a week or two ago). Unlocked bootloader, no custom recovery, not rooted.

    I have tried wiping system settings and cache, which did not resolve the issue.
     

    #5
  6. fahmin.ahmed
    Donut Dec 24, 2017

    fahmin.ahmed , Dec 24, 2017 :
    i fixed the problem. all i had to do was sideload the oreo update again using adb and it fixed it. somewhere during the process the files must of corrupted which i dont understand how it could have happened.
     

    #6
    Hydra Bob likes this.
  7. suyang74
    Cupcake Dec 24, 2017


    #7
  8. Arlaine
    Cupcake Dec 24, 2017

    Arlaine , Dec 24, 2017 :
    Same problem here, lost everything, tried to recover. Couldn't even sideload through the official recovery, I had to "fastboot boot twrp.img" then sideload from within twrp, was able to get back to oxygenOS 4, got the OTA update, let it do its thing, and now its still stuck in a boot animation after updating
     

    #8
  9. Slovaku
    Cupcake Dec 24, 2017

    Slovaku , Dec 24, 2017 :
    Okay,i just updated my OP5 and ...surprise, stuck at loading "dots" ... i'm downloading OnePlus5Oxygen.zip to recover somehow my phone,but its dead from what i see now...
     

    #9
  10. vivald
    Cupcake Dec 24, 2017

    vivald , Dec 24, 2017 :
    same issue here: had before the latest nougat version with open bootloader. also tried to flash via adb but still the same. also cannot flash any other rom I think. So maybe this update bricked my phone...
     

    #10
  11. amicitas
    Cupcake Dec 24, 2017

    amicitas , Dec 24, 2017 :
    I tried sideloading the newest OTA. The installation showed as successful, but went right back to the stuck bootloop. I then tried sideloading an older version of OxygenOS 4.5.15, however this fails at about 47%.
     

    #11
  12. amicitas
    Cupcake Dec 24, 2017

    amicitas , Dec 24, 2017 :
    I was eventually able to load 4.5.15. My phone now gets past the boot loop, but gives me an "Encryption unsuccessful" screen. This has me worried that I may have lost all the data on my phone. Unfortunately (and stupidly) I did not make a backup of anything before allowing the OTA update.
     
    Last edited: Dec 24, 2017

    #12
  13. apu2009
    Cupcake Dec 24, 2017

    apu2009 , Dec 24, 2017 :
    I'm in the same situation as @amicitas. Had the most recent OTA update, with an unlocked bootloader but no custom recovery or rooting. Stuck in the spinning atom animation with red/white circles. Very disappointed that this happened, going to try and sideload and will post back.
     

    #13
  14. Slovaku
    Cupcake Dec 24, 2017

    Slovaku , Dec 24, 2017 :
    I'm lucky...i managed to recover my dear phone.
    So you have to do something like this (worked for me)

    Put your Oneplus 5 in SIDELOAD (to transfer flash file from PC to OP5)
    you need to download ADB driver
    I downloaded OnePlus5Oxygen_23_OTA_019_all_1710311604_e278653ff79644a5 and moved it to C:/adb folder
    (When you install adb driver,you will have C:\ADB\ , open command prompt (Using SHIFT + right mouse click -> Open command promt window here)
    Rename OnePlus5Oxygen_23_OTA_019_all_1710311604_e278653ff79644a5 to ONE
    In command prompt (with your phone in SIDELOAD MODE type this:
    ADB SIDELOAD ONE.ZIP
    and wait.
     

    #14
    YasinSuzon and Jeet77 like this.
  15. 3p1phany
    Donut Dec 25, 2017

    3p1phany , Dec 25, 2017 :
    There's a thread on this over on XDA that might help some of you. Read the thread, don't just follow the instructions at the top as it may not work. There are some solutions depending on your situation deeper in the thread.

    https://forum.xda-developers.com/oneplus-5/how-to/official-stable-oxygen-os-5-0-update-t3724247

    Best of luck. Since I held off to see if there were issues I think I'll just wipe and lock my bootloader then do a stock update and worry about twrp/root later.
     

    #15
  16. apu2009
    Cupcake Dec 25, 2017

    apu2009 , Dec 25, 2017 :
    Just finished sideloading on OSX. It's not booting so far, still stuck in the spinning circles.

    What I started with: Latest OTA, unlocked bootloader, no rooting. Tried updating via OTA while connected to the dash charger, got stuck in the spinning circles after the update "completed". Decided to sideload...

    What I did:
    Downloaded the update file to the desktop
    Opened up my terminal
    Booted the OP5 into recovery
    Selected the option to install an update from ADB
    Back in the terminal, I typed:
    adb sideload ~/Desktop/OnePlus5Oxygen_23_OTA_027_all_1712231851_8d16de8.zip
    Once it finished, I selected the option to reboot on the phone.

    Been waiting for 10 minutes now, still stuck. Beware and do your backups.

    @3p1phany I'll check that thread now, thanks for posting it.
     

    #16
  17. asch99
    Cupcake Dec 25, 2017

    asch99 , Dec 25, 2017 :
    @Slovaku what version of OxygenOS were you running prior to you attempted upgrade to Oreo? 4.5.14 or 4.5.15?
     

    #17
  18. apu2009
    Cupcake Dec 25, 2017

    apu2009 , Dec 25, 2017 :
    Well, the sideload didn't work so I had to do a complete factory reset. What a load of BS. On the plus side I have a nice clean install now, but got damn it what a waste of time. If you haven't updated already, I'd say wait to have the issues resolved.
     

    #18
  19. smok3y
    Ice Cream Sandwich Dec 25, 2017

    smok3y , Dec 25, 2017 :
    Just another day of pure BS by OnePlus coders and I wasted 6 hours trying everything to resolve this bootloop. And I lost all my data in the process. What was to be a simple 2 minute update, turned out to be a nightmare.

    Was on latest official build, then came this update so decided to go get Oreo. Installed and guess what boots into BootLoop with those red dots making circles around the white box forever. Waited for 20 minutes, nothing.

    So decided to reboot, nothing, same BootLoop. Went into recovery, nothing showing there. Can't browse my directory as everything shows in encrypted text keys. That is when I realised I've lost my data and pretty much everything.

    No I didn't do anything fancy. When I was in BootLoop all I did was go back to recovery to see if I can maybe flash the update file which I had kept in phone for safety. My bad I forgot this was OP developers we were trusting and should have not even tried to get this update till everyone went through their share of pains and bugs.

    Oh well, out I had to bring the OP 5 unbrick software. I knew that would wipe everything, if there was anything left, but had no choice. So wipe, and reboot and awesome sauce the recovery software got me into Hydrogen OS and loads of Chinese BS. I guess OP can't make an update to that software either, just lift and shift would work with a little tweaks.

    Anyway, so I figure out that now I'm all stock and on Hydrogen OS I should flash the Oreo Official update through ZIP and recovery method. Phone is all clean right, nothing there to bother a fresh install. So off I go to download Oreo offical full ZIP from OP guys. Flash and wait, and guess what now I get a black screen and a blue LED and nothing else. No more red circles, atleast watching them was fun going round and round. Now I'm staring at a black screen, which didn't even get to red circles.

    Guess that's another BootLoop or maybe a dead phone. What did I do this time. Nothing wrong, I walk all steps again in my mind, clean phone, HOS, stock and it had to be stock because I used OP 5 recovery software. So everything was clean and stock and still the Oreo update landed me in a BootLoop.

    By this time I had gone into a Frenzy mode and 6 hours down trying to find solutions. So back to OP 5 software recovery. And I again got HOS installed and stock. Phone boots fine with Chinese BS. So I think maybe I flashed incorrectly. So I download Oreo update file again, all 1.6 GB or whatever it was. Put it in phone and go to recovery and flash.

    Guess what, same dead screen all black with just a blue LED, nothing happening. I'm tired by now. Back to OP 5 recovery software. Installs Hydrogen OS all over again. Same Chinese BS. This time around I decide to flash Nougat offical zip, the one update prior to Oreo, which I was on when all this BS started. So back to recovery, download OS 4.5.15 and flash.

    And God be almighty the phone boots absolutely fine into OS 4.5.15. but the trouble isn't over, now Play services won't go past Checking Info screen. That's an issue with Chinese OS flashes, which apparently OP5 recovery software does and leaves traces for Google to get stuck. So this time I had to do a factory reset to get Google working.

    I guess that was just the adventure I needed before X-Mas day. Some Noobs at OP research labs can't replicate the software to do the same thing on each and every OP phone. The phones have a mind of their own and so does the software. Apparently every user faces a different situation with these phones and softwares. Wonder what these guys are smoking at OP Labs.
     

    #19
  20. otk
    Cupcake Dec 25, 2017

    otk , Dec 25, 2017 :
    I am in the same situation: unlocked bootloader, no root, was on previous stock ROM (4.5.14). After installing 5.0 OTA the phone is stuck in the boot animation (for about 6 hours). Unfortunately I was so dumb that I did not backup my data, so I'm still looking for solutions which might let me salvage anything. I've tried redownloading OTA manually and doing "adb sideload OnePlus5Oxygen_23_OTA_027_all_1712231851_8d16de8.zip", but nothing changed much, still those rotating dots again.
     

    #20