OxygenOS OnePlus 5 bootloop after oreo update

  1. wm0304
    Cupcake Dec 26, 2017

    wm0304 , Dec 26, 2017 :
    Further above I asked for a dummy explanation to get the phone flashed. Working on it all day, I finally found a way to do it. For reasons unknown to me I cannot flash any ROM via the "standard" ADB mode. But I found that updating the ROM via TWRP does work. Here is the path that worked for me:

    1) PREP: Install ADB on your PC if not yet available and get all the files (TWRP and the ROM) onto your pc. Use directories without blanks or you must put all paths listed below in quotes.
    2) Go to Fastboot: Switch off phone. Then press volume down and power button until the logo is gone. In the menu choose "Fastboot". The phone resets and boots to fastboot. In Fastboot mode, choose "English" and then "Install from ADB" then connect the phone to your pc via usb cable.
    3) In Win10 press the Windows key + "R" and insert "CMD", press enter.
    4) You can test if your phone is correctly connected by entering "fastboot devices". If you see a serial number, your connection is good.
    5) install TRWP. to do so enter "fastboot flash recovery twrp-3.2.1-x_blu_spark_v8.61-op5_op5t.img" to your cmd prompt. Replace the filename and location by the file you use. But as of now, this file works and seems to be up to date.
    6) Switch off phone. Then press volume down and power button again until the logo is gone. In the menu choose "Advanced" - "Recovery". Phone boots to recovery mode.
    7) Install new ROM. To do so, enter "adb sideload OnePlus5Oxygen_23_OTA_019_all_1710311604_e278653ff79644a5.zip" in your cmd prompt. Replace file name with the one in your pc. The one quoted here is the last available ROM from the OP website.
    8) ATTENTION! you loose all data since with the flash your phone looses the encryption key. !!!
    9) you must reset the phone to factory: Switch off phone. Then press volume down and power button until the logo is gone. In the menu choose "Recovery". Then choose "English" and then "Wipe data and cache", then "Erase everything" (in TWRP there is a similar option)

    That does it. The phone boots again. I currently only face wifi issues with that ROM. Not sure why since that phone ran on this update without issues when it was the current one...

  2. D1514302671704
    Cupcake Dec 26, 2017

    D1514302671704 , Dec 26, 2017 :
    I'm stuck at boot after OTA Oreo update failed. Tried to adb sideload the official OP5 ROM (23_OTA_19) downloaded from OnePlus website, but I get installation failed after transfer is complete. I'm due to work and I'm on call tomorrow and need my phone. This is my second day wasting time on this bullshit. Anyone got any suggestions?

  3. ernestolefebre
    Donut Dec 26, 2017

    ernestolefebre , Dec 26, 2017 :
    Go and read the comments before I posted how I got it working for me. Since you are already in bootloop go into recovery and just wipe everything it should boot that is what other people said it worked for them,but you will lose all your data and stuff.

  4. D1514302671704
    Cupcake Dec 26, 2017

    D1514302671704 , Dec 26, 2017 :
    The instructions by wm0304 worked fine. Just wiping the data and cache did not work for me. The phone is reset now and it suggests to download the Oreo update again. I'm curious how to do this right this time. I wonder if I should lock the bootloader first and then download the update ...

  5. ernestolefebre
    Donut Dec 26, 2017

    ernestolefebre , Dec 26, 2017 :
    I wasn't referring to the instructions of wm0304, I was referring to the instructions I gave on my comments:
    How to update to oreo guide.
    Since so many are having the bootloop issue including me, here you have how I got it working fine.
    I tried the update in several ways, from within the rom, using twrp and sideload. All the time I got the bootloop. Appears to be the issue is when the bootloader is unlocked.
    1. Backup your data in your pc.
    2. Lock the bootloader.
    3. Install the update from within the rom either from internal storage or downloading it. It will boot perfectly.
    4. Unlocked the bootloader.
    5. Flash the twrp(I suggest using the latest blu_spark version since the regular version didn't decrypt the internal storage for me)
    6. Finally, flash magisk, use the beta version 14.6 or 15 since the stable 14 will lead you to no booting at all. (if you installed the regular twrp you will have to use the adb sideload option to flash magisk, if you flashed the blu_spark you can put it in the internal storage and flash it regularly with twrp)

    Enjoy oreo :)

  6. Bronx.sbt
    Froyo Dec 26, 2017

    Bronx.sbt , Dec 26, 2017 :
    the same for me... Put the twrp and then FORMAT DATA to be able to access again to local memory. Then restore the old rom with nougat with adb sideload. It's the only way!! 635398906385359246.jpg

  7. K0nne
    Cupcake Dec 27, 2017

    K0nne , Dec 27, 2017 :
    I had the same problem. Even in fastboot mode my OP5 was not reachable via ADB anymore.
    After a few hours of frustration and complete factory reset the phone finally boots up with OxygenOS 5.0 as if nothing was wrong. OP has completely fu*ked up with this release -.- Thanks for the christmas present ...

  8. FTAFreedom
    Gingerbread Dec 27, 2017

    FTAFreedom , Dec 27, 2017 :
    Unlocked Bootloader shouldn't be an issue as I was able to get Oreo working without re-locking bootloader. Don't ask me how I did it because I have no idea.........Tried so many things that it just decided to boot up and work with the locked bootloader after about 6 hours of frustration.........

  9. erikaebers
    Cupcake Dec 27, 2017

    erikaebers , Dec 27, 2017 :
    I'm having the same issue. A factory reset did not solve it, actually, for me. Bummer that I am travelling and had no idea the upgrade would make my phone totally unable to operate after that.

  10. fschmieg
    Cupcake Dec 27, 2017

    fschmieg , Dec 27, 2017 :
    Same here. OP5 could brought back to work with format data partition only. Encryption key was gone. So best intention of nandroid backup done before OREO update was completely useless. Hope now to get most back from titanium backup after re-rooting and my cloud storage. Who guarantees that this doesn't happen again with next OTA update which is comming soon?

  11. amicitas
    Cupcake Dec 27, 2017

    amicitas , Dec 27, 2017 :
    I finally ended up just having to wipe everything, including internal storage and all data, and starting over. My phone is working now, but I lost everything on the phone, including many months of personal and professional photographs, plus a bunch of other media files. I realize now I should treat all Oneplus OTA updates as potentially broken, and always back everything up before an update. To say the least, this was the worst christmas present ever from OnePlus.

  12. fschmieg
    Cupcake Dec 27, 2017

  13. dragancla
    Cupcake Dec 28, 2017

    Hydra Bob likes this.
  14. Hydra Bob
    Marshmallow Dec 28, 2017

    Hydra Bob , Dec 28, 2017 :
    Have you tried making adb large address aware? That issue seems to crop up with larger updates like this

  15. fschmieg
    Cupcake Dec 28, 2017

    fschmieg , Dec 28, 2017 :
    I'm back on 4.5.15. Flashing recovery twrp-3.2.1-x_blu_spark_v8.61-op5_op5t.img was never persistent and always replaced by factory recovery after reboot. Flashing SuperSU-v2.82-SR5 stopped booting OP5. - >> 4.5.15 + recovery twrp-3.2.1-0-cheeseburger.img + SuperSU-v2.82 works perfekt. After 1,5 day I'm now at same point as before but learned a lot and improved my automated backup.

  16. kaares
    Cupcake Dec 29, 2017

    kaares , Dec 29, 2017 :
    I have a locked bootloader.
    Flashed the oreo update(ota_027). It boots up to homescreen but reboots almost immediately. Usually locks up at pin screen, but sometimes I'll make it to my desktop. No way to enable developer mode before it reboots.
    Flashing any other older ota fails. Tried ota 8, 19, 20 so far.
    Flashing oreo beta 1 and 2 will install, but same problem as the finished release.
    I tried wiping everything in recovery mode.
    I can't see any way forward. Any tips?

  17. Hydra Bob
    Marshmallow Dec 29, 2017

    Hydra Bob , Dec 29, 2017 :
    Did you use the roll back build when you tried flashing the older OTAs? Flashing an Android 7.1 based build will fail unless you use that build first.


    steakhouse and kaares like this.
  18. kaares
    Cupcake Dec 29, 2017

    steakhouse and Hydra Bob like this.
  19. Holkeen
    Eclair Jan 2, 2018

    Holkeen , Jan 2, 2018 :
    Hey, guys. For anyone willing to get it to work. Just lock bootloader. Worked for me.

    ymicky likes this.
  20. greylee
    Donut Jan 2, 2018

    greylee , Jan 2, 2018 :
    how to lock bootloader, may you share the steps detail? many thanks