OxygenOS OnePlus 5 bootloop after oreo update

  1. Hydra Bob
    Marshmallow Jan 2, 2018

    Hydra Bob , Jan 2, 2018 :
    The same way you unlocked it. Just use fastboot.

    The command is

    fastboot oem lock

    greylee likes this.
  2. steakhouse
    Cupcake Jan 3, 2018

    greylee likes this.
  3. felipemendes
    Jelly Bean Jan 3, 2018

    felipemendes , Jan 3, 2018 :
    When I had this problem (already solved), this didn't help. What helped was to download a newer adb from Google, as the one provided by OP seems not to address large files.

    Hydra Bob likes this.
  4. felipemendes
    Jelly Bean Jan 3, 2018

    felipemendes , Jan 3, 2018 :
    Absolutely no. Locking the bootloader on an unstable ROM may definitely brick the device.

    If things go wrong, flash the rollback 7.1 (latest adb from Google may be needed) and stock recovery, and go from there.

  5. steakhouse
    Cupcake Jan 3, 2018

    steakhouse , Jan 3, 2018 :
    To solve this problem, i used that : https://www.asus.com/zentalk/thread-119788-1-1.html
    It's a 64b version of fastboot and it was advised on several topics

  6. felipemendes
    Jelly Bean Jan 3, 2018

  7. steakhouse
    Cupcake Jan 3, 2018

  8. steakhouse
    Cupcake Jan 3, 2018

    steakhouse , Jan 3, 2018 :
    **** **** **** ! It doesn't help me ! Don't want to format /data :(

  9. ymicky
    Honeycomb Jan 5, 2018

    ymicky , Jan 5, 2018 :
    Has worked for me too. Anyone know if I have to lock the bootloader for the 5.0.1 Update? I am on 5.0.0

  10. Miracle14
    Cupcake Jan 12, 2018

    Miracle14 , Jan 12, 2018 :
    Hello Friends, im from indonesian user. My phone have same problem with you guys. I never doing this like flashing or something. I will tell my op5 situation

    After the update, my op5 bootloop just a minute after booting, again and again. Frustrating because of it. I've read all from this forum. But i dont know how guide is works well. So what is the best way to clear this problem ? Thank you guys

  11. takysoft2
    Cupcake Jan 24, 2018

    takysoft2 , Jan 24, 2018 :
    For me, this file worked:
    (this is one version of the Open Beta 3... currently harder to find... )

    these did not: (bootloop)

    Same bootloop with 5.0.1 stable.

    With the 003 beta all works well. Recovery ASKS for the password. Even custom recovery does (twrp blu sparks)

    All the rest: drive doesn't get decrypted. Recovery shows jibberish directories.

    Does anyone know what I do wrong? I tried it several times...

    Do the newer files use some other kind of encryption? do I need to reset the phone somehow?

    OP5, Currently the 003 ROM.
    Unlocked bootloader, root with Magisk. (I've used to use SuperSu before Oreo)
    No other serious stuff, I only use root for AdAway, GameGuardian and Lucky Patcher.
    (Oh, and Titanium Backup...)
    Last edited: Jan 24, 2018

  12. aenews
    KitKat Dec 20, 2018

    aenews , Dec 20, 2018 :
    I wiped system settings plus cache and sideloaded Oreo. It booted finally instead of getting stuck at the logo, but all the internal storage had been wiped.

  13. jorgeluisoblitas23
    Cupcake Feb 6, 2019