OxygenOS OnePlus 5 stuck at boot loop with vanilla, non-rooted OxygenOS 5 (Oreo)

  1. jospeh Cupcake Dec 30, 2017

    jospeh, Dec 30, 2017 :
    Hey guys, so I was updating my phone to Android Oreo (sorry I don't remember the exact OygenOS version from before or after the update [Android Security Patch Level 1. December 2017 I believe]) around December, 24th. I read in a blog that it is supposed to be published and checked my updater, surprise it was already available to me. I don't participate in any beta channels, so it should be the stable release. It worked fine until today and I believe I also rebooted it in the last couple of days besides the reboot from the update.

    After an exhausting shopping trip I checked on my phone and it didn't react to my fingerprint unlock properly. Which means, the screen was frozen and the phone didn't unlock. I though, "Ok, I have seen this situation before", powered the screen off, and waited a couple of minutes. The next time I checked my phone I was greated by the boot encryption screen (the phone is secured with a finger print and a password). I thought, "Shit, it seems there was some kind of a software hickup and it rebooted itself". I entered my password and the password field vanished a bit, it was still half-transparent in the background. The phone was stuck at that screen for around 1 minute until I saw the OnePlus loading animation and was asked to unlock my phone with the encryption password again. I held down the power button and shut it off. The next boot asked me for the PIN of my SIM card as well as the encryption password, but the same situation I just described happend again. However after a couple of tries I accepted the fact, that I currently cannot unlock my phone. I desperately booted into "recovery" - as far as I understand (holding down the key "Volume Down" while powering on the phone) - but the problem here is that my encryption password is not accepted. It only vibrates after hitting OK and presents the password field again. The same happens if I deliberately enter a wrong password.

    While tipping this I tried entering a bad password on the normal boot encryption screen and it immediately says "Wrong Password". So the password that I use is correct. While I am stuck at the Enter-Password screen I can also see in the background that the phone is connected to the Wifi and GMS network and that I received a message but the content is, of course, not available. (Which is good, if I would loose my phone I don't want anyone to be able to read my stuff.)

    I probably have some data backed up in this "Google-Backup-Cloud-Thing" but I don't have everything that I need. So wiping the phone is not an option that I really consider.

    I read somewhere that the current and stable TWRP (I don't even know what it is, but I believe it is some kind of a minimal-system to access phone data before the proper OS boots) is not able to mount encrypted partitions. The guy advised to "side load" the current chinese TWRP - which supports encrypted partitions - to backup the necesary data.

    I think myself fully capable of doing stuff like that, however I have never done that and... well any advise would be really appreciated.

    noahfung likes this.
  2. noahfung Eclair Dec 31, 2017

    noahfung, Dec 31, 2017 :
    My experience is very similar. Do you have any enterprise software installed?

    I've tried wiping 3 times, reinstalling etc. It always works fine right up to the point where I re-install Airwatch which creates a work profile in Android for my corporate email.

    That is always what triggers what you describe for me. I'm on my 3rd wipe at the moment and am not installing my work email again until it gets sorted out, back to lugging 2 phones around everywhere. :(

    jospeh likes this.
  3. jospeh Cupcake Jan 1, 2018

    jospeh, Jan 1, 2018 :
    "Oh shit!" is actually the first thing that pops into my mind. Yes, we are using Airwatch at work with a separate "Android for Work" profile. Does that mean, even if I completely wipe the phone, that it will still reboot into the same error as long as I set up my work profile? Are you using a password instead of a swipe gesture / pin code as well for encrypting your data?

  4. noahfung Eclair Jan 1, 2018

    noahfung, Jan 1, 2018 :
    Yup. The first wipe i tried setting it up like usual again (password with specific requirements plus work fingerprints) and then it boot-looped again.

    Then I did my second wipe keeping my device and airwatch/boxer single sign-on password the same without doing any fingerprints thinking that I was doing something to confuse the android encryption but it still triggered a boot-loop.

    I've been running days now flawlessly after wipe 3 without reinstalling Airwatch.

    Unfortunately I'm not sure how you're gonna get back into your phone without data loss since you can't even get into recovery as the phone won't decrypt at all (to remove Airwatch or update software) once it's stuck in the boot loop but let me know if you think of something.

  5. jospeh Cupcake Jan 3, 2018

    jospeh, Jan 3, 2018 :
    I gave up, threw my data away and started from scratch without work emails on my phone. It really sucks loosing all the data but I will survive.

  6. noahfung Eclair Jan 6, 2018

    noahfung, Jan 6, 2018 :
    Oneplus responded to my bug report so at least there's hope for the future, I'll respond here if anything helpful comes up.

  7. Raul.persa Cupcake Jan 11, 2018

  8. jospeh Cupcake Feb 4, 2018

    jospeh, Feb 4, 2018 :
    I can't believe it but Updating to OxygenOS 5.0.2 results in the same error. I'm stuck in a boot loop again! :mad:

  9. noahfung Eclair Feb 4, 2018

    noahfung, Feb 4, 2018 :
    Did 5.0.1 work? I haven't tried to reinstall Airwatch since 5.0.0.

    Unfortunately i got a response on my bug report today and all it said was for me to call after-sales service. Talk about useless.

  10. jospeh Cupcake Feb 4, 2018

    jospeh, Feb 4, 2018 :
    I used 5.0.1 without Airwatch so I can't really say. I simply thought that 5.0.2 is a new version that "probably" doesn't have the old error. But I was wrong. This time I do have a backup but the todays stuff is gone. Well, better then nothing I guess.

  11. noahfung Eclair Apr 16, 2018

    noahfung, Apr 16, 2018 :
    FYI after getting the 8.1 update today I tried reinstalling airwatch & boxer and it seems to be working fine.