8
Other Oneplus 5 - Windows 10 - No USB connections -

  1. coldzage
    Froyo Jun 23, 2017

    coldzage , Jun 23, 2017 :
    When I connect my OP5 to my Windows 10 (Original and up to date), I get the message on the attached picture.

    I don't get a prompt to install drivers and I don't get the driver install drive under "My Computer".

    I tried in a total of 3 computers. Only one managed to show and install drivers. That one computer can transfer files but the warning is always up.

    In all 3 computers, after plugging my OP5 into the USB port, certain aspects of the computer freeze. I can't install or uninstall program nor can i reboot/shutdown pc, it always freezes.

    Tried all ports (and tried with other devices, they all work.
    Tried with 3 different dash cables.

    Live chat summed up help was the statement: Your computer has issue


    Is this a problem? Is it normal? Can it be driver compatibility/support issue because this was an early drop? Am I in for a RMA?

    Discuss


    DDBHZuEXoAAvhP8.jpg .
     

    #1
  2. coldzage
    Froyo Jun 23, 2017

    Best Answer
    coldzage , Jun 23, 2017 :
    Well the person who first helped me was asleep and gave me wrong directions/solution.

    Apparently just need to manually turn on debugging mode:

    Step 1 Unlock your OnePlus phone and go to Settings.
    Step 2 Under Settings, scroll down and open About Phone.
    Step 3 Find Build Number and tap 7 times on it.
    You will get a message on your screen that you are now a developer. That’s it you have successfully enabled developer option on your OnePlus Phone.
    Step 4 Go back to Settings, Scroll down and tap on Developer option.
    Step 5 Under developer option, tap on USB debugging, select USB Debugging to enable it.

    I'll leave this here in case anyone needs it.

    Regards
     

    #2
    Mr_Regi, ariondenis, 593jim and 11 others like this.
  3. ile95
    Honeycomb Jun 23, 2017

    ile95 , Jun 23, 2017 :
    Okay, problem solved. It seems that my compoter tried to install drivers instantly when I plugged my phone in, and because it goes to charge mode automatically my computer was unable to install drivers properly. When I changed from charge mode to transfer mode the computer didn't try to install the drivers anymore, because it had already classified my OP5 as malfunctioning device.

    Solution:
    1. Go to developers options (unplugged)
    2. Change default USB configurations from charging to media transfer, you might need to click it a few times.
    3. Plug OP5 to computer, now it should instantly use media transfer mode and the drivers are properly installed.
    4. Evertything is working, when transferring files in the future the same steps must be followed.

    Hope this helps people having similar problems too  Worked for me
     

    #3
    Mr_Regi, Surfdude82, IlonV. and 5 others like this.
  4. irvco605
    Cupcake Jun 23, 2017

    irvco605 , Jun 23, 2017 :
    both these solutions dont work for me. When i change it to transfer file mode, it reverts back to charging.
     

    #4
    ysf01, G_Kalaidos and sycshk like this.
  5. Burritch
    Cupcake Jun 23, 2017

    Burritch , Jun 23, 2017 :
    Hi all,
    below is what i have tried so far ... but unsuccessfuly

    Step 1: Unlock your OnePlus phone and go to Settings.
    Step 2: Under Settings, scroll down and open About Phone.
    Step 3: Find Build Number and tap 7 times on it.
    You will get a message on your screen that you are now a developer. That’s it you have successfully enabled developer option on your OnePlus Phone.
    Step 4: Go back to Settings, Scroll down and tap on Developer option.
    Step 5: Under developer option, tap on USB configuration
    Step 6: Choose MTP transfert (Media Transfert Protocol)

    Win 10 still doesn't want to install drivers and give me that same message. Is ther any way to install drivers manually ?
     

    #5
    IlonV. and G_Kalaidos like this.
  6. dragonmost
    Cupcake Jun 23, 2017

    dragonmost , Jun 23, 2017 :
    Hey,

    Same probleme here with Win 10. Changing "Select USB Configuration" doesn't work 9 times out of 10 and as soon as you plug or unplug it, it reverts back to "charging". USB debugging seems to make it worse.
     

    #6
  7. Dre4mPT
    Gingerbread Jun 24, 2017


    #7
  8. andiii
    Cupcake Jun 24, 2017


    #8
  9. sycshk
    Eclair Jun 24, 2017

    sycshk , Jun 24, 2017 :
    does not work.
     

    #9
    MatG-DK likes this.
  10. Tobus0
    Cupcake Jun 24, 2017


    #10
  11. DeutschAllan
    Cupcake Jun 24, 2017


    #11
  12. mathur.rajeev
    Cupcake Jun 24, 2017

    mathur.rajeev , Jun 24, 2017 :
    The only solution available is: TRY CHANGING YOUR pc/laptop
    Believe me, if it connects, it will connect on very first instance without asking for any installation.

    Other solution can be: Format your pc/laptop
     

    #12
  13. Stormrider NL
    Cupcake Jun 24, 2017


    #13
    ilcasalino likes this.
  14. vibha_ramp
    Cupcake Jun 24, 2017


    #14
  15. Stormrider NL
    Cupcake Jun 24, 2017

    Stormrider NL , Jun 24, 2017 :
    Okay this worked for me. Turn off the pc. Then boot the pc with the one plus 5 connected. during boot set the one plus 5 too file transfer. Now i can access the phone . let me know if this works fir u as well.
     

    #15
    MartinGregor likes this.
  16. CJK94
    Cupcake Jun 24, 2017

    CJK94 , Jun 24, 2017 :
    I was trying every iteration of the above instructions and constantly re-reading this thread attempting to solve the problem and finally managed to get it to work. I'll put this in caps as for idiots like me who don't do things properly YOU NEED TO RESTART YOUR COMPUTER (apologies for shouting):

    1. Restart your computer.
    2. With your phone unplugged follow the above posts regarding turning on debugging and MTP in the developer options.
    3. Now plug in your phone and this should allow it to connect to your PC.
     

    #16
    MatG-DK, SoloJazzCup and yp246 like this.
  17. yp246
    Cupcake Jun 24, 2017

    yp246 , Jun 24, 2017 :
    Reboot worked for me too, cheers
     

    #17
  18. Seikouki
    Cupcake Jun 24, 2017


    #18
    MatG-DK and ilcasalino like this.
  19. F_Goodluck_Jeffery_Ijezi
    Cupcake Jun 24, 2017


    #19
  20. pablofg1978
    Spanish POC Assistant Head Moderator Jun 24, 2017

    pablofg1978 , Jun 24, 2017 :
    Thread merged
    Check the second post
     

    #20