0
OnePlus 5T issue with internet connection on 4G - works with 4G+ (Telstra)

  1. ozgyrex
    Donut May 31, 2019

    ozgyrex , May 31, 2019 :
    I have a strange issue with my OnePlus 5T (Oxygen 9.0.5). I'm on the Telstra network in Australia.

    My phone was running fine on earlier versions of Android but over the past 6-12 months I've been having some strange issues with maintaining a stable internet connection. If the phone shows 4G+ I get internet but after some time, the phone drops down to just 4G and I can't access the internet. I can re-establish an internet connection by turning on/off airplane mode.

    In *#*#4636#*#* the default preferred network type was TD-SCDMA/LTE/UMTS and I've tried LTE/UMTS (PRL) and various other options but the same issue happens where I get internet access for some time on 4G+ but then the phone drops down to 4G and I can't access the internet.

    Edit: If I select LTE only, my phone works without issue so it seems like it's some kind of issue relating to the phone being unable to switch bands properly? But if I use LTE only, I won't be able to make or receive calls and it won't switch to 3G/HSDPA in non-LTE or remote areas so this is not a permanent fix.

    Does anyone have any ideas?
     
    Last edited: May 31, 2019

    #1
  2. ozgyrex
    Donut Jun 1, 2019

    ozgyrex , Jun 1, 2019 :
    I think I fixed this. In *#*#4636#*#* I set my connection type to LTE/UMTS (PRL) and restarted my phone and now my phone is working like its never worked before - strong and stable mobile connection all day. I think the phone needs to be restarted after making this change because it didn't seem to work on the fly without a reboot.

    I hope this helps someone else in the future.
     

    #2
    kramo123 likes this.
  3. kramo123
    Cupcake Nov 19, 2019

    kramo123 , Nov 19, 2019 :
    Was in a very similar situation and this solved my problem. OnePlus 5 on Android 9, Telstra network in Australia.
    Constantly had to activate and deactivate airplane mode to get data back after network changed from 4G+ to 4G or H+. Also tried moving Sim from slot 1 to 2 with no help.
    Thanks ozgyrex!

    Edit: the setting does seem to reset itself after a period of time, so I find myself changing it every few days to keep the fix
     
    Last edited: Nov 26, 2019

    #3