7
Display OnePlus 5T screen not responding to touch

  1. jaimejimegon Honeycomb Mar 8, 2018

    jaimejimegon, Mar 8, 2018 :
    Yeah, I know, but if you have a pattern it ask you for a pattern?? that is what I've never seen
     

    #21
    G_Vaibhav_Sharma_EhyZ likes this.
  2. chicorebelo Froyo Mar 8, 2018


    #22
    Razzlesama and Sri krupa like this.
  3. Sri krupa Donut Mar 9, 2018

    Sri krupa, Mar 9, 2018 :
    hey guys i went to the one plus service center today, they said there is a problem (short circuit) in the main board i asked what caused?..they said it may be due to bug in software update.


    one question to all can i ask for a replacement?
     

    #23
    Razzlesama likes this.
  4. jaimejimegon Honeycomb Mar 9, 2018

    jaimejimegon, Mar 9, 2018 :
    Depending on the laws on your country, but I think you can, you haven't done anything, is OnePlus fault.
     

    #24
    Razzlesama and Sri krupa like this.
  5. Sri krupa Donut Mar 9, 2018

    Sri krupa, Mar 9, 2018 :
    actually this is third time i am facing and every time i have different issues firstly it was finger print sensor so i had to change my back panel then the software bug which made my phone dead silent and finally main board issue. what did i even pay for ?? is one plus is selling their defect products to India??
    And in India will one plus replace the handsets?
     

    #25
  6. jaimejimegon Honeycomb Mar 9, 2018

    jaimejimegon, Mar 9, 2018 :
    I think it's just about probability, I live in my country main city and I've seen about 7 OnePlus devices since OPO. I think the brand is more common in India and there they sell many devices
     

    #26
    Sri krupa likes this.
  7. PeKKeR Cupcake Mar 9, 2018

    PeKKeR, Mar 9, 2018 :
    3 months old oneplus 5t running 5.0.4 and today touch screen stopped responding whilst it was updating some apps from appstore. naturally i rebooted (wish i wouldnt) and now i cannot get into the phone:

    1. normal boot needs my unlock password and since i cannot type - doesnt work
    2. recovery mode (power and V-) asks for password again
    3. power and V+ i can select fast boot only using V+ V- and power button
    4. safe mode cannot enter because i cannot long press the power button because touch doesnt work.

    i then contacted support suggested 3 solutions:
    1.asked me to use adb sdk to send keyboard strings to the phone but my USB debbuging is off and therefore cannot use adb method -the device is detected as MTP USB . if usb debbugging was on maybe i could login the phone and be able to backup my data and do other stuff too. doesnt work.

    2. asked me to perform a full factory reset- i cannot do that since recovery mode asks for password and touchscreen doesnt work / cannot type.

    3. if everything else fails , perform RMA and send the phone back to oneplus for repair. A guy in this forum said that he got it repaired and then it happened again !! how can i trust this phone again with my data?

    Not only i have been locked out of my phone , i also lost my data, and i cannot even wipe it before sending it back for repair ,meaning that my data could get compromised.

    -->oneplus this is not flagship phone mentality . this is disaster

    A.
     

    #27
  8. Razzlesama Ice Cream Sandwich Mar 12, 2018

    Razzlesama, Mar 12, 2018 :
    I don't care if i purchased the phone through a third party vendor. IF this was caused by software updates, OnePlus HAS to compensate. This is MAJOR.
     

    #28
    G_Vaibhav_Sharma_EhyZ likes this.
  9. Razzlesama Ice Cream Sandwich Mar 12, 2018

    Razzlesama, Mar 12, 2018 :
    Also, i've returned the phone to my vendor for repairs and they say the display should be replaced, which would set me back by almost TWO HUNDRED DOLLARS!!!!
     

    #29
  10. R_Manoj.R.Reddy_ Cupcake Mar 13, 2018

    R_Manoj.R.Reddy_, Mar 13, 2018 :
    i made big mistake buying oneplus ,while watching youtube video tried to pause but i couldn't and i tried rebooting the device nothing worked
     
    Last edited: Mar 13, 2018

    #30
  11. F_Kayes_Ahmed Cupcake Mar 23, 2018

    F_Kayes_Ahmed, Mar 23, 2018 :
    have u solved the problem..??
     

    #31
    G_Vaibhav_Sharma_EhyZ likes this.
  12. Razzlesama Ice Cream Sandwich Mar 27, 2018

    Razzlesama, Mar 27, 2018 :
    Nope. The phone is in a cupboard somewhere. I use a ALCATEL ONETOUCH because i can't afford to repair the phone or buy a new one.
     
    Last edited: Apr 7, 2018

    #32
  13. dkudriavtsev Cupcake Mar 28, 2018

    dkudriavtsev, Mar 28, 2018 :
    Found a way to take backups through TWRP if you have this problem:
    1. You must have bootloader unlocked.
    2. Force reboot the phone and press volume up key while starting, to get to the fastboot screen.
    3. Download latest blu_spark TWRP .img file. It has to be the latest version. 8.72 worked for me.
    4. Plug your 5T into your computer while it is on the fastboot screen.
    5. Use the command "fastboot boot [filename]" (without quotes) where [filename] is the name of the blu_spark TWRP image.
    6. Wait for the TWRP to start up.
    7. Using an OTG cable or adapter, plug in a USB mouse. Perform your tasks in recovery using the mouse pointer.
    8. If you need to take a backup to an external medium, use a USB hub.
    I personally have this issue. It persisted for about two days, then inexplicably fixed itself. Now it's happening again - the phone was behaving very slow and laggy so I rebooted it, and the touchscreen did not respond at startup.

    I've reflashed the latest OxygenOS open beta image, cleared cache/dalvik, reflashed Magisk/TWRP, and plugged it in while off. I'm going to let it just sit there, charging, for a day or so before I try to use it again. I will be RMAing the device if this problem persists.
     

    #33
    Razzlesama likes this.
  14. ix3coco Froyo Mar 31, 2018

    ix3coco, Mar 31, 2018 :
    I also have the same problem but on the OnePlus 5... I found that I was able to get a mouse plugged into OTG cable to work in TWRP mode (even though it didn't work in regular mode). I was able to access my files in twrp and then I followed a guide online to delete the password files that will bypass the lockscreen. After doing so and rebooting, the touchscreen miraculously worked!! But now my problem is that the phone is still encrypted even though I don't have a lockscreen anymore. I can't create a new pin/pattern lock because it won't save.

    When I boot back into TWRP, it asks me for a password but I never had one. Any idea how I can get this to work without performing a factory reset? :(
     

    #34
  15. enorma29 Cupcake Apr 10, 2018

    enorma29, Apr 10, 2018 :
    SOLVED IT.

    Had the same problem.
    Removed the screen protector.
    Tried again.
    It works.

    ...LOL.
     

    #35
  16. Big P Eclair Apr 12, 2018

    Big P, Apr 12, 2018 :
    In India they do replace the mother board & if that's not in stock & u escalate the complaint they do replace the device
     

    #36
  17. R_Manoj.R.Reddy_ Cupcake Apr 13, 2018

    R_Manoj.R.Reddy_, Apr 13, 2018 :
    with in 10 days they will replace , otherwise they claim from manufacturing warranty of there is no physical damage only .
     

    #37
  18. dkudriavtsev Cupcake May 5, 2018

    dkudriavtsev, May 5, 2018 :
    I have contacted customer support and RMA'd my phone. It was in warranty (1 year factory warranty) and the repair was free. They have completely resolved the issue. The RMA process was mostly painless with Acer service center in Texas.

    The tech notes sent back with the phone said that there was an issue with the LCD FPC connector on the device. They replaced the cable and the problem was resolved, the phone passed factory inspection.

    I restored the backup I had and the phone works perfectly.

    Try an RMA, it works.
     

    #38
    Richard Dike and Kytharsis like this.
  19. Adam Pilborough Donut Jun 26, 2018

    Adam Pilborough, Jun 26, 2018 :
    Ok, this looks to me to be a very nasty software/firmware problem... I have come to this conclusion because I have found a way to get the screen working again on my OnePlus 5 by doing the following.

    Bad news. Your data is gone. say goodbye and follow along.

    1. flash the phone with the OnePlus MSM download tool unbrick method. (This is done to get the password off the bootloader and start as if you're out of the factory)
    2. Boot into recovery and ADB sideload the oxygen open beta for your device. (i used OB 12 on my OP5, For the OP5T it would be OB 10 at the time of writing.)
    3. let oxygen boot. (your screen may still not work at this point.)
    4. shut the phone down and boot into recovery again.
    5. Go to wipe data and cache and wipe in the following order. erase everything, wipe cache, reset system settings.
    6. restart and boot into oxygen. this boot will take longer than normal.

    Your touch screen should now be working as normal. If not, Try one last reboot, if this fails do steps 4 - 6 again. If that fails, Try all steps one more time.

    OnePlus really needs to find out what software package is causing touch to lock up like this. it is behaving like a bad file is triggering some kind of hardware switch that is not reset until your reload fresh firmware and flush the cache so it can be rebuilt.
    I'm not a programmer or developer so I can't dig any deeper I'm afraid...
     
    Last edited: Jun 26, 2018

    #39
    Kytharsis likes this.
  20. Adam Pilborough Donut Jun 29, 2018

    Adam Pilborough, Jun 29, 2018 :
    Update: this method just helped someone over on the XDA forums.

    https://forum.xda-developers.com/on...touch-screen-stop-t3757724/page5#post76944789

    Looking more like a firmware problem that the open beta is helping with. He tried doing it with OTA 5.1.3 but got nowhere. Tried again using my method with the open beta and his screen has come back to life.

    This recovery method has also restored touch on my phone 3 times. It has settled down now with no problems for 4 days.
     

    #40