72
OnePlus 5T: Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS !!

  1. Poetepoet
    Cupcake Feb 7, 2018

    Poetepoet , Feb 7, 2018 :
    Hi everyone! I am currently at the step where I need to locate SuperSU and install the ZIP in TWRP. However, I can't seem to find the .zip when looking for it in TWRP as I cannot find the "Downloads" folder in "Shared Internal Storage" where I put it. Where can I find the folder?
     

  2. Ymer_G
    Cupcake Feb 8, 2018

    Ymer_G , Feb 8, 2018 :
    Concerning my issue I used a terminal Android and I used this command :
    su
    pm remove-user 999
    exit
    Everything was fine after that..but Someone can explain to me what I just did because I don't know what user 999... Why user 999 impacts the backup twrp.
    Thank you.
     

  3. dbareis
    Eclair Feb 8, 2018

    dbareis , Feb 8, 2018 :
    I'm also getting that, if you click the action bar item that looks like lines of text, that will show the log I am seeing many red lines such as: Could not mount /data and unable to find crypto footer

    This is on "twrp-3.2.1-1-dumpling.img" (the latest)? I haven't had this issue before on Android 7.1.1 but just updated to Oreo.

    I'm going to try: https://github.com/TeamWin/android_device_oneplus_dumpling/issues/1 (https://sourceforge.net/projects/cheeseburgerdumplings/files/15.1/dumpling/recovery/).
    UPDATE: WORKED FOR ME: twrp-3.2.1-0-universal-codeworkx-dumpling.img
     
    Last edited: Feb 8, 2018

    Ymer_G likes this.
  4. AidenBae
    Cupcake Feb 8, 2018

    AidenBae , Feb 8, 2018 :
    any suggestions for some useful apps after the phone rooted ? Like custom themes or icon changer,visual affect on lock screen,etc...
     

  5. zetapulse
    Froyo Feb 8, 2018

    zetapulse , Feb 8, 2018 :
    I could use some help... I followed these instructions well but when my OP5T tries to boot in the end it just stays booting forever (20+ minutes).
    I'd recently updated to the latest Oxygen OS based on Oreo, then started rooting using Blu Spark & SuperSU. When that failed I found instructions online & managed to switch to the official TWRP & Magisk, but same problem.
    Now I'm downloading the original OOS rom & will try that, but if there are any solutions or reasons I failed I'd appreciate hearing it.
    EDIT: Nevermind, I flashed OOS with SuperSU & eveything's back to normal now. Too bad I couldn't get neither Liquid nor Lineage to work.
     
    Last edited: Feb 9, 2018

    Ymer_G likes this.
  6. N1513546706957
    Cupcake Feb 8, 2018

    N1513546706957 , Feb 8, 2018 :
    Does that mean I'll need to wipe everything?

    I regret updating now, don't want to wipe the phone to re-gain root :(

    Thank you.
     

    Hydra Bob likes this.
  7. Hydra Bob
    Marshmallow Feb 8, 2018

    Hydra Bob , Feb 8, 2018 :
    No you shouldn't have to wipe everything. A dirty flash should be possible, a clean install is still recommended though. At least back up your data first just in case.
     

    N1513546706957 likes this.
  8. AidenBae
    Cupcake Feb 9, 2018


  9. RK_Eradath
    Cupcake Feb 9, 2018

    RK_Eradath , Feb 9, 2018 :
    i have successfullly unlocked the bootloader. flashed the TWRP. there was a option of swipe for allowing modifications... did it. next i pressed the install button. but the device memory files are not shown. so couldnt flash Supersu. after rebooting into system, when i try to reboot into recovery, its opening the stock recovery, not the TWRP. any guesses where i faulted ???
     

  10. lvleow
    Cupcake Feb 9, 2018

    lvleow , Feb 9, 2018 :
    I see online that there's a fairly big update coming out. My gf has already received her update (not rooted), I haven't powered on my phone yet (just got it). I want to unlock bootloader and root the phone (skipping custom rom install)

    First question, root on oem firmware should be fine, right? Last phone I rooted was a Galaxy S4, so I don't know if things have changed since. Second question, will the above root method work post-update or do I need to do it before updating?

    Also, I'm sure this is a noob question but if I receive future oem updates I'm guessing I lose root. Will I lose root on all apps (even the ones I already gave root access to), or just any future apps that I install? I disabled updates on my S4.
     

  11. Hydra Bob
    Marshmallow Feb 9, 2018

    Hydra Bob , Feb 9, 2018 :
    Yes root on OEM firmware works just fine. I recommend Magisk, SuperSu support is iffy on Oreo so far. And yes you'll still receive OTA updates but you will lose root access if you take them, so you might as well update before you root. And no root access is not app specific, the permissions are but not the underlying processes so it will be gone for all of them. I think you'll find quite a bit has changed since the S4 days but OnePlus is much friendlier to customization so it shouldn't take you too long to get up to speed.
     

  12. LUKITO
    Froyo Feb 9, 2018

    LUKITO , Feb 9, 2018 :
    Hello guys. I have successfully unlocked bootloader and installed TWRP through ADB and should copy Magisk to internal storage but I forgot to do it. Went straight to TWRP after unlocking bootloader as per tutorial and was looking for Magisk.zip file but couldn't found it. Rebooted to system then, copied Magisk to a folder and now when I go in to Recovery, TWRP disappeared and has been changed back to stock Recovery (I think it's stock). Is it possible? When I go to Recovery now, the only one thing I see is to type a password for decrypting device and then language change and some simple menu with OnePlus logo, not like TWRP. Couldn't install Magisk through it, something is always failing. Then I read about "not booting to OS yet" as quoted in this post... well, I forgot to copy Magisk so I did that. The question now is how to install TWRP again? The same way through ADB or is there any other way to flashing it through OS?
     

  13. Hydra Bob
    Marshmallow Feb 9, 2018

    Hydra Bob , Feb 9, 2018 :
    Yeah, the same way. Just pick back up in the guide at that step.
     

  14. lvleow
    Cupcake Feb 9, 2018

    lvleow , Feb 9, 2018 :
    Thank you so much for the confirmation and the recommendation. So far I see quite a bit has changed, I'm excited to start using my phone. :)
     

    Hydra Bob likes this.
  15. Twof7
    Cupcake Feb 10, 2018

    Twof7 , Feb 10, 2018 :
    Will this work on android 8.0? Trying to figure this all out sorry if that's a dumb question haha
     

  16. skordilisR
    Donut Feb 11, 2018

    skordilisR , Feb 11, 2018 :
    i'm on the stage when i need to install supersu. i navigate with twrp but the storage is empty. what happens here?
     

  17. Hydra Bob
    Marshmallow Feb 11, 2018

    Hydra Bob , Feb 11, 2018 :
    Yep same process.

    Are you using the linked to TWRP versions? Bluespark and codeworkx are the only ones capable of mounting and decrypting user data on Oreo that I know of. I recommend codeworkx. Also try using Magisk instead, SuperSu seems to have compatibility issues with Oreo for right now.
     

  18. skordilisR
    Donut Feb 11, 2018

    skordilisR , Feb 11, 2018 :
    you have right. before i edit my post you answer me. with bluespark all works fine. thank you
     

    Hydra Bob likes this.
  19. Elaaps
    Froyo Feb 12, 2018

    Elaaps , Feb 12, 2018 :
    I just tried with my OnePlus 5T on Oreo with TWRP of Blu_spark (TWRP Official can't access to my repertory) and SuperSU, but when I rebooted, my phone get stuck on the screen of OnePlus and "powered by Android", I just tried to reboot, after waited 1 hour, I tried to flash again SuperSU, but same result, so I flashed OxygenOS with Oxygen Recovery to have my phone for today. I just saw that there is a alternative for SuperSU, will that work with magisk?
     

    Ymer_G likes this.
  20. Ymer_G
    Cupcake Feb 14, 2018

    Ymer_G , Feb 14, 2018 :
    I have same problem with my OnePlus 5T Oreo, can you help us please ? currently I can't use my phone.