73
OnePlus 5T: Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS !!

  1. Hydra Bob
    Marshmallow Apr 1, 2018

    Hydra Bob , Apr 1, 2018 :
    Yes but if your bootloader is unlocked you'll have to download the full ROM instead of just the incremental OTA.
     

    zarnihtun likes this.
  2. m_a_n_i_s_h
    Honeycomb Apr 1, 2018


  3. zarnihtun
    Cupcake Apr 11, 2018

    zarnihtun , Apr 11, 2018 :
    1650mb full rom open beta6 it say after update bootloader will lock and unroot the phone again. it's true? what can I do for update without any change in phone?
     

  4. Hydra Bob
    Marshmallow Apr 11, 2018

    Hydra Bob , Apr 11, 2018 :
    The bootloader won't lock but it will unroot your phone. There's no way around it but all you have to do is reflash TWRP and root again after.
     

    zarnihtun likes this.
  5. zarnihtun
    Cupcake Apr 12, 2018

    zarnihtun , Apr 12, 2018 :
    what about data?
     

  6. Hydra Bob
    Marshmallow Apr 12, 2018

    Hydra Bob , Apr 12, 2018 :
    Shouldn't be affected but having a current backup to fall back on just in case is always a good idea.
     

    zarnihtun likes this.
  7. P1520770731857
    Honeycomb May 6, 2018

    P1520770731857 , May 6, 2018 :
    Is the EFS backup needed if you're rooted using MAGISK? Or does that only apply to SuperUser?

    How big are the risks of bricking my phone? I just want to root so that I can use the front camera in GCAM
     

  8. Spannaa
    KitKat May 6, 2018

    Spannaa , May 6, 2018 :
    It doesn't matter which root method you use - you should always take an EFS backup, just in case you need it later.

    If you follow the instructions properly, the risk of bricking your phone is negligible.
     

  9. Spannaa
    KitKat May 7, 2018

    Spannaa , May 7, 2018 :
    Have you tried this modified Google Camera?

    Everything works, including the front camera and there's need to root to use it.
     

  10. Mapletrout
    Eclair May 31, 2018

    Mapletrout , May 31, 2018 :
    I have an issue where every update I try fails, and boots me into TWRP instead. There's not errors in the logs, but I can't install any zips or images because the /sdcard directory is filled with nonsensical directories. The only way I can update is by logging on my computer, plugging it in, and using adb to push the zips onto the device and commit the update. Any ideas on how I can fix?
     

  11. Artemus.
    Nougat May 31, 2018

    Artemus. , May 31, 2018 :
    Do you get a "System UI has stopped" error before kicking you back to TWRP?
     

  12. Mapletrout
    Eclair May 31, 2018

    Mapletrout , May 31, 2018 :
    You're going to laugh; the problem was when the TWRP opened, it would ask me for a password. I thought this was to add a password, but really it was telling me to put my password in to decrypt the data. Everything is all fixed now, thanks for your help
     

    kaushaldevy and Artemus. like this.
  13. Artemus.
    Nougat May 31, 2018

    Artemus. , May 31, 2018 :
    [​IMG]
     

    kaushaldevy likes this.
  14. OvidiuIurciuc
    Cupcake Jun 1, 2018

    OvidiuIurciuc , Jun 1, 2018 :
    Hello guys!
    It may be a dumb question or a question not for this thread, but here I go.
    My 5t got Factory reset by mistake, and I seemed to have lost all my files, apps, etc...
    I've done some research and found a bunch of apps to recover some of these files (the photos are the one I'm looking for), but all of these apps seem to need the device to be rooted in order to have full access to the device's storage.
    And this is how I got to this thread.
    As I was reading the steps to follow, I have noticed that at some point, it says that it will wipe everything from my phone.
    I would do a backup, but the thing is I cannot backup the deleted files I want to restore.
    So, question: by rooting my device, will the process wipe everything off of my phone and won't be able to recover the files using the recovery apps out there?
    I would really appreciate a reply!
    I am getting quite desperate now...
    Thank you in advance!
     

  15. Spannaa
    KitKat Jun 1, 2018

    Spannaa , Jun 1, 2018 :
    I suspect you're out of luck...

    DiskDigger photo recovery can recover deleted photos but it needs root to recover the full sized photos rather than just the cached thumbnails.

    To root, you need to unlock your bootloader first, which will wipe your device like a factory reset does.

    I don't know if this second wipe will make it more difficult to recover your photos but I don't think you have any other option but to try it.

    Good luck
     

  16. OvidiuIurciuc
    Cupcake Jun 1, 2018

    OvidiuIurciuc , Jun 1, 2018 :


    Thanks!
    Than I guess, as you said, I have nothing left but to try it.

    Cheers
     

  17. Omarh
    Cupcake Jun 10, 2018


    elwholo likes this.
  18. K1524907755038
    Cupcake Jun 15, 2018

    K1524907755038 , Jun 15, 2018 :
    Hi Funk.. Hope you're doing well.. Could you please share the theme used on oneplus 5t which looks beautiful in the screenshot. Those statusbar and nav bar colour ful bars looks rocking. Kindly provide us with the customization you've used.
     

    elwholo likes this.
  19. lucasrubeng@gmai
    Cupcake Jun 25, 2018

    lucasrubeng@gmai , Jun 25, 2018 :
    Hey awesome post ! i was wondering is that a custom rom or theme you are using ? (on the screenshots ) its looks awesome whats its name ?
     

  20. Kitsune302
    Cupcake Jul 16, 2018

    Kitsune302 , Jul 16, 2018 :
    So ive unlocked the bootloader and downloaded Magisk and TWRP by Codeworkx, but i dont know where exactly these things should be. I moved the zip'd Magisk file onto the internal shared storage on the phone by dragging it and the TWRP file is on my desktop, so i tried using the fastboot flash recovery command but it said it could not load my TWRP file. Where should the file be, or what am i doing wrong?