0
OnePlus 5T WiFi Issue

  1. ihanson
    Cupcake Aug 23, 2019

    ihanson , Aug 23, 2019 :
    So just starting in the last day or two I am having a WiFi issue that is capping my speeds at about 300 kbps. I checked that the metering settings were set to unmetered and I also tried a reset of the network settings and a cache reset using the Android recovery menu to no avail.

    Software is up to date for the OnePlus device, no other issues.

    Thanks for your help.
     

    #1
  2. CalebAnzer
    Donut Aug 23, 2019

    CalebAnzer , Aug 23, 2019 :
    Currently having the same issue, out of nowhere both my WiFi and Data connections will throttle so low to the point that nothing loads (even a simple webpage). This happens at least daily and the only fix I have found is by completely restarting the phone.
     

    #2
  3. ihanson
    Cupcake Aug 24, 2019

    ihanson , Aug 24, 2019 :
    I have noticed it happens to limit the download of any content to 250 kbps, it almost seems like an error in the software that is treating the connection like a metered connection even though it's an unlimited WiFi connection.
     

    #3
  4. stark2991_PL
    KitKat Aug 24, 2019


    #4
  5. ihanson
    Cupcake Aug 24, 2019


    #5
  6. ihanson
    Cupcake Aug 24, 2019

    ihanson , Aug 24, 2019 :
    So just to follow up, I ended up updating my router firmware and after it booted up again the problem was resolved! The router setup is an Amplifi Mesh network and now it's working as expected again, so happy! So nothing to do with the phone. Really glad I didn't do a full wipe or anything drastic
     

    #6
  7. CalebAnzer
    Donut Aug 25, 2019

    CalebAnzer , Aug 25, 2019 :
    Im currently running Oxygen OS version: OP5T_O2_BETA_33.
     

    #7
  8. CalebAnzer
    Donut Aug 25, 2019

    CalebAnzer , Aug 25, 2019 :
    Not the case for me this randomly happens anywhere I'm at.
     

    #8
  9. Jontalk5
    Froyo Aug 26, 2019

    Jontalk5 , Aug 26, 2019 :
    I'm having a different issue. Speed is fine, but in the past few days, I'm noticing the auto-enabling feature hasn't been working like it did in the past. In other words, when I get home and unlock the phone, the saved home Wifi network would turn on immediately. Now I have to tap WiFi in the notification bar manually. Running the latest 9.0.8 firmware, no games and the only new app that was added was Venmo, which I've removed. Also did a cache clearing which I do frequently. The only saved network in settings is at home. Any ideas?
     

    #9
  10. stark2991_PL
    KitKat Aug 26, 2019

    stark2991_PL , Aug 26, 2019 :
    You have to enable wi-fi manually or you have to manually connect to your home network? Clarify this for me.
     

    #10
  11. Jontalk5
    Froyo Aug 26, 2019

    Jontalk5 , Aug 26, 2019 :
    Yes, tapping the WiFi icon in the notification bar immediately connects to my network. As I said, up until recently when I'd arrive home, it would connect automatically once in range of the signal. Now for some reason, it doesn't. Its not a big deal, but its new behavior. As you know, apps are updated very often especially those from Google which is why I do a cache clearing regularly but in this case, it doesn't seem to help.
     

    #11
  12. stark2991_PL
    KitKat Aug 26, 2019

    stark2991_PL , Aug 26, 2019 :
    Were you using this:
    aVn7YdHHVRNPBKdAX2uHd7-650-80.jpg
    feature?

    Because I don't understand. Without this feature wi-fi won't turn on automatically, and when it is turned on, it is supposed to automatically connect to the saved network.
     

    #12
  13. Jontalk5
    Froyo Aug 26, 2019

    Jontalk5 , Aug 26, 2019 :
    Yes both features are turned on..Just went through a long OP support chat session which resulted in doing a hard reset..and it didn't fix the problem. Now I have to do all the work of setting up my phone again..very frustrating. It's hard to think the problem is somehow connected with the 9.0.8 update even though they haven't had any similar bugs reported
     

    #13
  14. dbareis
    Eclair Aug 27, 2019

    dbareis , Aug 27, 2019 :
    I hope you have confirmed that you are connecting with 5ghz and also have a good signal. Hopefully, you have also checked your router for QOS or other possible limiting settings.
     

    #14
  15. Jontalk5
    Froyo Aug 27, 2019

    Jontalk5 , Aug 27, 2019 :
    As I said earlier I have no problem connecting to the network manually. Nothing has changed in router settings with the exception of enabling AI security protection. The smart Wi-Fi features always worked before. I removed the Aquamail app and installed a different one. As far as QoS is concerned what do you recommend?
     

    #15
  16. Jontalk5
    Froyo Aug 29, 2019

    Jontalk5 , Aug 29, 2019 :
    Frustrated since my 5T has always worked perfectly, after the hard reset/set up of the device, I used common logic. With no social media or gaming apps that continually ping a data network, I removed the email app (Aquamail) and installed Edison mail in its place...BINGO! Works like a charm and the new email app is superior in all ways.
     

    #16