26
[Submitted] OnePlus 6 cannot connect to Tile due to BLE bug

  1. RobJD
    Donut Jan 2, 2019

    RobJD , Jan 2, 2019 :
    @David Y. @Manu J. - Is there an official defect number for this issue that we can track? I have been unable to use Tile devices since my OP6 'upgraded' to Android Pie. Tile are saying it is a problem with the bluetooth drivers in this new OS and there is a growing number of people who are discovering this issue. I purchased my OP6 direct from yourselves so I feel that you have an obligation to me as a consumer to resolve this issue. It worked perfectly on the original OS that was on the device when I purchased it therefore I would like an ETA on when this will be resolved please.

    Is there a different method that users should report bugs through so that they get properly prioritised for development? Or should this post on this forum be good enough to get the process started?

    Has this defect been reviewed by the PO/PLM/Dev Team?
     

    #61
    splunke and Badger2point0 like this.
  2. KN5642
    Cupcake Jan 3, 2019

    KN5642 , Jan 3, 2019 :
    Same issue with a Tile Pro, OnePlus 6 and OOS 9.0.3. this really needs to be solved.
     

    #62
  3. jas282
    Cupcake Jan 4, 2019

    jas282 , Jan 4, 2019 :
    OnePlus: what is your response?
     

    #63
    RobJD likes this.
  4. OP6User
    Cupcake Jan 4, 2019


    #64
  5. splunke
    Cupcake Jan 5, 2019

    splunke , Jan 5, 2019 :
    Also adding myself to the list that see this issue. Has there been any response from OnePlus?
     

    #65
  6. chriselemme
    Donut Jan 5, 2019

    chriselemme , Jan 5, 2019 :
    I found a temp work around that might help some people untill OP fixes the issue. If anyone in your household has a phone that works with tile (any none OP phone will do) have them create a tile account and have them add the tile to their account. Then have them share the tile with you. You will only be able to ring the tile when the other phone is in range but I spend most of the time with my wife anyways. By no means is this a permanent fix, but it will allow you to use the tiles until OP finds it convenient to do something about it
     

    #66
    RobJD likes this.
  7. EmmanuelAlbert
    Cupcake Jan 5, 2019

    EmmanuelAlbert , Jan 5, 2019 :
    I have tried a different device with the same account, as well as a different device with a different account, then share. Both will add the device to my list, but the FIND function isn't available.

    Main device is One+6, secondary is iPhone 6.
     

    #67
  8. dianmao
    Cupcake Jan 5, 2019

    dianmao , Jan 5, 2019 :
    it's a known bug for 3 months now. I've lost 1/4 the lifespan of my tiles. nobody should expect any fix... anyway I love my OnePlus 6...
     

    #68
  9. chriselemme
    Donut Jan 5, 2019

    chriselemme , Jan 5, 2019 :
    I found a temp work around that might help some people untill OP fixes the issue. If anyone in your household has a phone that works with tile (any none OP phone will do) have them create a tile account and have them add the tile to their account. Then have them share the tile with you. You will only be able to ring the tile when the other phone is in range but I spend most of the time with my wife anyways. B
    I works for me. Per the tile website "With both devices on the most up-to-date Tile app version (starting with 2.25), a shared Tile can now be rung by either user's phone as long as one of the users is connected to the Tile"
     

    #69
  10. Iking47
    Cupcake Jan 7, 2019


    #70
  11. MattNob
    Cupcake Jan 7, 2019

    MattNob , Jan 7, 2019 :
    I've just purchased a Tile Pro to find it doesn't work with my OP6, running 9.0.3.

    When will we get a fix for this? Looks like it's been going on a while.
     

    #71
  12. EmmanuelAlbert
    Cupcake Jan 7, 2019

    EmmanuelAlbert , Jan 7, 2019 :
    Might as well return them, at this point...
     

    #72
    dianmao likes this.
  13. H1543501021953
    Cupcake Jan 7, 2019


    #73
  14. Deresnoreau
    Cupcake Jan 7, 2019

    Deresnoreau , Jan 7, 2019 :
    The issue seems to be limited to the Tile Pro. I'm using a first gen Tile mate, and a second gen Tile mate (with replaceable battery) and these run just fine on my OP6. It's the new Tile Pro that seems to be the problem.

    I've sent an e-mail to Tile, reporting this situation and received this reply from Tile:

    "The OnePlus range of smartphones have a compatibility issue which prevents the smartphone from connecting to Tiles. This may include but is not limited to the OnePlus 5, 5T, 6 and 6T which share similar (if not identical) hardware.
    OnePlus is working on the issue on the phone hardware side and we expect a fix to come in future software update to the phone itself."

    So even Tile is aware of the problem, let alone OP.

    Really looking forward to a solid solution from OP and an update.
     

    #74
    simsjc likes this.
  15. hbl123
    Cupcake Jan 8, 2019

    hbl123 , Jan 8, 2019 :
    IIam having same issue. I have looked at all the post regarding this issue, and I cannot find any replies from OnePlus on whether they have acknowledged issue or are working this issue. I am very disappointed in OnePlus.
     

    #75
  16. hagegebenjamin
    Froyo Jan 10, 2019


    #76
  17. Z1540828785818
    Donut Jan 12, 2019


    #77
  18. G_Jesse_Dekker_PyPG
    Cupcake Jan 14, 2019

    G_Jesse_Dekker_PyPG , Jan 14, 2019 :
    Mine started working today!!

    Am on the latest software of Oneplus 9.0.11 and on the developer version of tile. 2.41.2 updated for the last time on 19th of December.

    Last week I turned off battery optimalisation for tile. It didn't fix the problem. A few days later both of my tiles pro work just fine. Don't know for sure if disabling the optimalisation fixed the problem.
     

    #78
  19. G_Jesse_Dekker_PyPG
    Cupcake Jan 14, 2019

    G_Jesse_Dekker_PyPG , Jan 14, 2019 :
    For testing I closed the tile app, disabled my Bluetooth, enabled it again and opened up the app again. As a result both tiles are now in 'connecting' status. They won't connect anymore. If I'm trying to connect to them through Bluetooth settings I get an error: won't connect because of wrong pincode.

    One hour ago they just worked fine..
     

    Attached Files:


    #79
  20. dianmao
    Cupcake Jan 14, 2019

    dianmao , Jan 14, 2019 :
    I did tons of testing when this bug started around October.

    If I connected my tile from my tablet then seconds after that my phone was able to connect. And during my tablet connected to my tile my phone was all right. But without my tablet my phone wasn't able to connect.

    So if you connect from a second device then it changes something so you phone can connect.
     

    #80