2
Network/Connectivity Oneplus 6 loses 4G/H+ Network connection during standby, switches back to 3G but still offline.

  1. chaitanyakhaitan
    Honeycomb Jun 10, 2018

    chaitanyakhaitan , Jun 10, 2018 :
    Yup, we are facing the same issue.

    It seems like a problem when network switches from 4g to 3g/2g , it is not able to latch onto anything and although it shows mobile network, but actually there is none.
     

    #41
    G1528580563269 likes this.
  2. 05dfleming
    Cupcake Jun 10, 2018

    05dfleming , Jun 10, 2018 :
    Hi, I'm having a problem, randomly I lose all signal, even go into settings and the signal strength is 0. It won't come back of its own accord, I have to turn airplane mode on and off for it to reconnect to the network. Has anyone else faced this issue please, as I'm getting worried? Any help would be insanely appreciated, thank you :)

    As aeroplane mode fixes it, I seriously doubt this is a hardware fault
     
    Last edited: Jun 10, 2018

    #42
  3. BigM
    Gingerbread Jun 18, 2018

    BigM , Jun 18, 2018 :
    Just updated to OxygenOS 5.1.8 and it a still have the problem that I lose my network connection despite the display shows 3G or H+.
    It seems like this will not happen, if I deactivate Dual 4G Network support in SIM Settings (don't know how this option is called in english, as I am using a different language).
     

    #43
  4. lsd2k
    Donut Jun 26, 2018

    lsd2k , Jun 26, 2018 :
    OxygenOS 5.1.8 same problem. Network stuck, H+ showing. Helps only switch mobile data, reboot, airplane. Put the same sim in 3T, never facing this issue. Please fix it. Oneplus 6 is useless.
     

    #44
  5. loki7726
    Donut Jul 13, 2018

    loki7726 , Jul 13, 2018 :
    after upgrading to 5.1.8 I am facing the same issue on Vodafone. It keeps losing 4g network, though 4g is available superb in my area
     

    #45
  6. Therenas
    Cupcake Sep 11, 2018

    Therenas , Sep 11, 2018 :
    My friend has the same issue on his OP6.
    I had OP5 with the same issue, but OP didn't fix it for 10 months. I think it's the hardware problem.
    Had to switch to another phone. I wanted to purchase op6, but couldn't, because of such feedbacks.
    Belarus, carrier Velcom. They don't have LTE, just h+.
     

    #46
  7. prashpendu
    Cupcake Dec 20, 2018

    prashpendu , Dec 20, 2018 :
    I have the exact issue...any resolve???
     

    #47
  8. rosco83
    Cupcake Aug 22, 2019

    rosco83 , Aug 22, 2019 :
    Still no resolution for this after the OS update? An absolute joke it's not been resolved.
     

    #48
  9. G_Maaz_Tariq_Abbasi_tTGk
    Cupcake Oct 7, 2019


    #49
  10. dnchakawri
    Froyo Sep 2, 2020

    dnchakawri , Sep 2, 2020 :
    I'm now facing the same problem for a while. It's driving me nuts toggling the airplane modus. Multiple times a day it switches from H+ to E+ (Wich is very slow). An airplane modus toggle solves the problem immediately. Also swapped sims (same carrier) with a samsung A5. The OnePlus 6 was still facing issues. And my own sim worked fine in the A5.

    I tried factory reset and other stuff. Nothing seems to work and I'm out of warranty.

    Anyone has a solution? Seems like a software issues. I'm thinking about rolling it back to a previous android version.
     

    #50
  11. Caomhin
    Marshmallow Sep 2, 2020

    Caomhin , via OnePlus 6T , Sep 2, 2020 :
    ROLL-BACK FROM CURRENT ANDROID 10 Stable TO EARLIER STOCK ANDROID 9 OR 10

    All Downgrades to earlier builds involve wiping the phone.

    So you will need to backup your phone data.

    Thanks to @ironass for putting this together.

    This Link will guide you through the Downgrade process.

    https://forums.oneplus.com/threads/roll-back-to-stock-android-9-or-10.1215079/
     

    #51
    dnchakawri and ironass like this.