OnePlus 6 - no ring or vibration for incoming calls

  1. foo7ji
    Donut Apr 2, 2020

    foo7ji , Apr 2, 2020 :
    I noticed this morning. my phone screen just light up with no ring or vibration. I will miss many incoming calls like this. I tried to reboot it works for a while then problem starts again.

  2. LightningXIII
    Community Veteran Apr 2, 2020

    Caomhin, DrJMun, Artemus. and 3 others like this.
  3. the_o2
    User of the Year 2018 Apr 2, 2020

    the_o2 , Apr 2, 2020 :
    Check for DnD and it's schedule.

    Caomhin, DrJMun and foo7ji like this.
  4. foo7ji
    Donut Apr 2, 2020

    foo7ji , Apr 2, 2020 :
    alert slider is at the right mode. ring.

  5. Sai kiran goud
    Froyo Apr 2, 2020

    foo7ji likes this.
  6. foo7ji
    Donut Apr 2, 2020

    foo7ji , Apr 2, 2020 :
    hi all, thanks for the response. I always use a headset and recently I reconnected with my Sony noise cancelling. since then this problem started but Bluetooth connection never a problem. I think it screwed up the arrangement. I never set Do not disturb mode but now I purposely switch on the DND to see if it had a reverse effect , and yes the ring tone came back for incoming calls. some software bug somewhere where it has kinda reverse toggle the DND switch. so now I actually have to turn on DND to get ring tone. and switch off DND if I really want to be not disturbed

    the_o2 likes this.
  7. the_o2
    User of the Year 2018 Apr 2, 2020

    the_o2 , Apr 2, 2020 :
    You should report this bug here

    Caomhin likes this.
  8. foo7ji
    Donut Apr 2, 2020

  9. DrJMun
    KitKat Apr 3, 2020

    Caomhin likes this.
  10. Frassefredde
    Cupcake Apr 4, 2020

    Frassefredde , Apr 4, 2020 :
    The same happend to me a couple of days ago. Incoming calls just light up the screen with a window ive never seen, no sound or vibration. Ive restarted the phone, checked the dnd thing, the alertslider. Nothing works, my phone went silent and still are.

  11. foo7ji
    Donut Apr 5, 2020

    foo7ji , Apr 5, 2020 :
    I tried wipe cache, it is still the same. I really didn't want to hard reset but I almost did it. Before I do that, I tried to delete the Trucaller app and also deleted all connected Bluetooth devices.

    It seemed to have worked.. incoming call rings are back. Consistently.

  12. Frassefredde
    Cupcake Apr 5, 2020

    foo7ji and Caomhin like this.