26
OnePlus 6: Unlock Bootloader | Flash TWRP | Root | Nandroid & EFS Backup

  1. nitin_g3
    Gingerbread Jun 20, 2018

    nitin_g3 , Jun 20, 2018 :
    Initially I also did the same but phone rebooted and took me to TWRP. Not sure how it was supposed to go.
     

    #81
  2. hendrali
    Cupcake Jun 20, 2018

    hendrali , Jun 20, 2018 :
    Hmm weird. Well what I did was before i flashed official TWRP, I had magisk installed first. So that was why my phone stuck in boot logo. Oh if you are keep coming back to twrp, you should try flashing magisk again.
     

    #82
  3. nitin_g3
    Gingerbread Jun 20, 2018

    nitin_g3 , Jun 20, 2018 :
    This time I was able to successfully boot into the system after doing factory reset using TWRP. And guess what, WiFi still not working :(
    Maybe I should try to go back to stock rom re lock bootloader and try everything again.
     

    #83
  4. mkernbach
    KitKat Jun 21, 2018

    mkernbach , Jun 21, 2018 :
    Oh, this message is there for a good reason. If someone unlocks the BL of your phone w/o your knowledge, you will see that at boot and realize that the ROM can be manipulated.
     

    #84
    Bastiaanoskam likes this.
  5. bord
    Gingerbread Jun 23, 2018

    bord , Jun 23, 2018 :
    Guys I need help. I think I accidentally flash to both partitions the twrp img taken from the official twrp site, not the img provided with this topic, and now my OP6 always reboot to twrp, not to system.

    What can I do now?
     

    #85
  6. bord
    Gingerbread Jun 23, 2018


    #86
  7. laupuy
    Honeycomb Jun 23, 2018

    laupuy , Jun 23, 2018 :
    Development on OP6 is fast !
    Official twrp is now available and recommended https://forum.xda-developers.com/oneplus-6/how-to/guide-how-to-install-official-twrp-t3801558

    Just for info about A/B slot: https://source.android.com/devices/tech/ota/ab/

    For example A is active slot and B inactive slot
    Boot twrp (slot A)
    Flash oos (slot B)
    Flash twrp installer zip (slot A/B )
    Reboot twrp (slot B)
    Flash magisk (slot B)
    Reboot system (slot B)

    Enjoy :)
     
    Last edited: Jun 23, 2018

    #87
    bord and nitin_g3 like this.
  8. jb42
    Gingerbread Jun 24, 2018

    jb42 , Jun 24, 2018 :
    Hi, I do this tutorial and i have the same problem with the wifi not working and call too. So after a factory reset, the same problem appear. After that i tried too wipe internal storage, system, data and cache, and reinstall the full ROM.
    But i have an error 255 in twrp and i can't install it. So, i havent backup the rom. Someone can help me ?
     

    #88
  9. Toraxii
    Cupcake Jun 26, 2018

    Toraxii , Jun 26, 2018 :
    try xda forums, they have plenty of guides. If you stil cant figured it out you can pm me.
     

    #89
    jb42 likes this.
  10. bord
    Gingerbread Jun 26, 2018

    bord , Jun 26, 2018 :
    If you have bootloader unlocked, try this. It worked for me.
     

    #90
  11. jb42
    Gingerbread Jun 26, 2018

    jb42 , Jun 26, 2018 :
    Thx, its work fine.
     

    #91
  12. Hulla
    Cupcake Jun 28, 2018

    Hulla , Jun 28, 2018 :
    Hello guys,

    Actually i got my OP6, unlocked it, flashed TWRP and OOS5.1.7.
    Then I created a BackUp of the system/data/etc. via TWRP and two extra backups of Modem and EFS.

    My question now is, do I need to root to create a EFS Backup via TWRP?

    And is a EFS backup with TWRP a good solution, that works or should I root my phone and copy the two EFS Files via terminal ? Are there some differences or are both ways legit for backing up efs?
     

    #92
  13. Elwess
    Cupcake Jul 7, 2018

    Elwess , Jul 7, 2018 :
    HI,
    when you say :

    Download and extract the rar file, place TWRP img on your PC & rest on your Device Internal Memory.

    What's the "& rest" ? is it all files ? where to put them exactly on phone memory ?

    Should I dezip them first ?

    What do you mean by "Flash the file" ?

    Thanks
     

    #93
  14. Steps Parku (DJ STEPS)
    Gingerbread Jul 8, 2018

    Steps Parku (DJ STEPS) , Jul 8, 2018 :
    i am getting the error that says ' Archive is Either Unknown or Format Is Damaged'
    right after downloading the zip file package provided in this tutorial. please is there any way to fix this issue? i've downloaded it over 3 consecutive times with same issue popping up.
     

    #94
  15. EricNeulaender
    Cupcake Aug 22, 2018

    EricNeulaender , Aug 22, 2018 :
    Hi, my phone get stucked at the teamwin screen, cant able to do aything, also stuck in H2 OS screeen
     

    #95
  16. EricNeulaender
    Cupcake Aug 22, 2018

    EricNeulaender , Aug 22, 2018 :
    get stucked in Teamwin screen, please help
     

    #96
  17. Kytharsis
    Nougat Aug 23, 2018

    Kytharsis , Aug 23, 2018 :
    You're stuck in TWRP?
     

    #97
  18. doveoscar
    Froyo Sep 5, 2018

    doveoscar , Sep 5, 2018 :
    Brand new OnePlus 6. Oxygen 5.1.11. So I go straight onto the OnePlus forums to find out how to root it - I'm not a rooting newbie, I've done a number of phones before including a OP2 and OP5. All is looking good until I do what it says below, which I now realise was flashing a Hydrogen OS version of TWRP.

    Phone sticks on TWRP splash screen and endless one plus boot loop when I try and enter recovery. If I just switch off and start up normally, it's just the boot loop.

    Just what I wanted. A bit of research leads me here https://forum.xda-developers.com/oneplus-6/how-to/guide-how-to-install-official-twrp-t3801558 so at least now I've got a phone that boots into TWRP. Still no boot into Oxygen though, so I'm downloading the ROM right now and I'm quite hopeful that all will soon be fixed.

    But why are these instructions still here if they break the phone?


    EDIT LATER: Hallelujah and praise the Lord, after several anxious hours I have my phone back pretty much as I started out. At least I now know how to get TWRP on it, but that's for another day now.

    Please folks don't follow the instructions at the top of this thread to root your OnePlus 6. And the posters above stuck with TWRP, to get your phone back do the following:

    1) Download the full Oxygen OS ROM to a computer from https://forums.oneplus.com/threads/...ficial-oxygen-os-roms-and-ota-updates.835607/

    2) Then goto https://forum.xda-developers.com/oneplus-6/how-to/guide-how-to-install-official-twrp-t3801558 to get the a working TWRP on your phone

    3) Flash the Oxygen OS you downloaded at Step 1

    4) Find safe instructions for rooting for the phone (mine follow, dead easy really).

    How to safely root a OnePlus with 6 Oxygen OS 5.1.11 with Magisk 17.1

    5) Install TWRP (see 2 above)

    6) Download (to your computer) patched boot image and unpatched boot image (for safety) from https://forum.xda-developers.com/oneplus-6/how-to/oos-5-1-11-pre-rooted-bootimage-t3829792

    7) Put your phone into fastboot, and with your phone connected to your computer by USB cable
    a) fastboot devices (just to check it's connected - you may need to ensure the USB mode is set to transfer files)
    b) fastboot flash boot 5_1_11_patched_boot.img

    8. Reboot phone, download Magisk manager 5.9.1 from https://forum.xda-developers.com/apps/magisk/official-magisk-v7-universal-systemless-t3473445

    9. Run Magisk manager, select to download and direct install Magisk 17.1
    zip

    10. Download Root Checker from the Play Store to see that root is working

    11. Your phone is now not certified by Google. To fix go to settings-apps (show system apps), select Google Play Store, Force Stop, Clear data. When you re-run Play Store, you'll find your phone is now certified.

    Hope this helps somebody. If you don't understand every step, don't try and root your phone because if it goes wrong, you probably won't be able to fix it.
     
    Last edited: Sep 8, 2018

    #98
    powerpig and bord like this.
  19. tOot.toOt
    Froyo Sep 18, 2018

    tOot.toOt , Sep 18, 2018 :
    I am on OOS Open beta2, OP6 . I have tried to root my device with this method, followed every step very carefully, Flashed recovery img to both partitions , but my device shows QUALCOMM Crash Dump mode while booting to recovery mode, Now it doesn't boot to OOS boot screen, everytime i try to reboot or reboot to recovery, my device shows crashdump mode. Fastboot mode is working fine. Please help me to solved the issue. thank you in advance
     
    Last edited: Sep 18, 2018

    #99
  20. Kytharsis
    Nougat Sep 18, 2018

    Kytharsis , Sep 18, 2018 :
    Flash the OB3 TWRP fix from XDA.