0
[Submitted] OnePlus 7 does not see Wifi 5 GHz

  1. Mr.Niflheim
    Cupcake Aug 6, 2019

    Mr.Niflheim , Aug 6, 2019 :
    The phone does not see Wifi 5 GHz, only 2 GHz, changed the region and channel width in the settings of the router, nothing was solved, as a result I bought and installed another router, the problem also did not go away, although the old 6T 5 GHz phone is visible and it connects.
    file - https://drive.google.com/drive/folders/1XLfOuf9vOKEGkqmuV9W6hHoHvKmG4519?usp=sharing

    Hello. I recently purchased a OnePlus 7 Chinese version with pre-installed Oxygen OS, I myself live in Kyrgyzstan. But as it turned out that there is a problem with connecting the 5GHz access point to Wifi, the phone does not see the Wifi 5GHz, and sees 2GHz and at the moment I use 2 GHz. At the same time, I have a OnePlus 6T phone that I bought in America, and he calmly sees and connects to the 5 GHz wifi. I went to check with a friend, all the same, I even bought a new router, but I can’t see the 5 GHz access point. He reset the network settings, it didn’t help, but if you reset the phone to the factory settings, the phone starts to see 5GHz Wi-Fi, but after rebooting, everything becomes as before, it feels like Google sees the region in which I am located and blocks further use of cleanliness 5GHz At the oneplus.com forum, they told me to change the region and network channel in the router settings, I tried all regions and all channels, nothing helped, installed the firmware on a stable global 9.5.4, cleaned the cache, I thought that something was wrong with my router , but in the end I bought another router and finally saw that the problem was in the firmware of the phone or in the Chinese version of the radio module.
    Maybe you can somehow fix this error in the next update. I really hope for your help.
     

    #1
  2. mariusmuntensky
    Froyo Aug 12, 2019

    mariusmuntensky , Aug 12, 2019 :
    Your 5Ghz network also has channel width.
    What are your settings for Channel and Channel width?
    Set channel on 40 and channel width on auto or 80.
     

    #2
  3. Mr.Niflheim
    Cupcake Aug 12, 2019

    Mr.Niflheim , Aug 12, 2019 :
    Worth auto mode. I tried different settings for 5 GHz, it does not help.
     

    #3