11
OnePlus 7 Pro Losing Cell Signal

  1. F1596263327575
    Cupcake Aug 12, 2020

    Last edited: Aug 12, 2020

    #61
    Hugo Hodinka likes this.
  2. F1596263327575
    Cupcake Aug 14, 2020


    #62
  3. pyztoh
    Cupcake Aug 16, 2020

    pyztoh , Aug 16, 2020 :
    I experience the same issues with the same carrier. I have tested if it comes to an connection loss if the band switches but I can’t confirm this. I loss connection although staying on band 3 all the time.

    Locking band hasn’t work for me - the suggested app is not available for the current android version.

    Right now my intermediate solution is setting the preferred network type to 2G/3G (Automatic).
     

    #63
    Y1558526519073 likes this.
  4. schneida
    Cupcake Aug 22, 2020

    schneida , Aug 22, 2020 :
    I tried the suggestion using the shortcut app, but the setting is not really applied/has no effect. If you check back after eliminating a band it is enabled again.
     

    #64
  5. O1537391579216
    Cupcake Aug 23, 2020

    O1537391579216 , Aug 23, 2020 :
    I can finally confirm that it is indeed the Switch to Band 20 that causes thesw issues! It was quite difficult to reproduce this issue since band 20 is used for long range coverage. When my op7t pro changes to band 20 everything gets stuck (wifi, gps, mobile network) and it it reconnects after ~10s to band 3 usually.

    The question is: how can we get this to oneplus and are they able to fix this?!?
     

    #65
  6. shingyau2
    Cupcake Aug 26, 2020

    shingyau2 , Aug 26, 2020 :
    I am facing same issue in Hong Kong.
    Oneplus please fix the problem! It is really annoying.
     

    #66
  7. Artemus.
    Community Hero 2020 Aug 26, 2020

    Artemus. , Aug 26, 2020 :
    Are you sure you're not on HydrogenOS?
     

    #67
  8. F1596263327575
    Cupcake Aug 30, 2020

    F1596263327575 , Aug 30, 2020 :
    I picked up my phone from the service a week ago. Based on information from the service the main board was changed. Since Friday I use Oxygen OS 10.0.9.HD01BA (the smartphone come back from the service with older version and the first few days I used 10.0.
    Currently, I do not have the problem with GSM. I will let you know if something will change.
     

    #68
  9. Willietech
    Froyo Aug 30, 2020

    Willietech , via OnePlus 8 Pro , Aug 30, 2020 :
    I recently bought the Oneplus 8 Pro and it works like a charm! I have the IN2025 and I don't have the problem of the signal dropping every time I used the data (as happened to me with the Oneplus 7T (HD1905) that I had a nightmare with for 7 months). To friends in the United States I recommend the 8Pro model IN2025. That model works excellent with carriers! I love my new cell phone! .... NOW I can say that I have a beast of a device!
     

    #69
  10. sachin saple
    Cupcake Aug 30, 2020


    #70
  11. sachin saple
    Cupcake Aug 30, 2020

    sachin saple , via OnePlus 7 Pro , Aug 30, 2020 :
    One Plus 7 pro General Support team is working on the problem or not? Are One Plus Team capable to resolve these critical network issues? Is One Plus have capabilities to develop a good phone like One Plus One??? I hope One Plus company will be no more within next couple of years. Because these services and support system is not capable.
     

    #71
  12. Artemus.
    Community Hero 2020 Aug 30, 2020

    Artemus. , Aug 30, 2020 :
    Generally, cell signal is a carrier issue, not a phone issue. Unless you bought a phone that doesn't support the bands provided by said carrier.
     

    #72
  13. barrymarkd
    Cupcake Sep 18, 2020

    barrymarkd , Sep 18, 2020 :
    I upgraded from a OP5T to 7T a few months ago (because the charger socket stopped working!) and am having the same problem....pls dont dump a load of tech speak on me OP. Pls fix - this is a phone/OS issue not a carrier issue. Thanks
     

    #73
  14. D1565422117469
    Cupcake Sep 18, 2020

    D1565422117469 , Sep 18, 2020 :
    Herstart de telefoon in veilige modus door de herstartknop ingedrukt te houden.
    After that restart normal.
    Probleem voor mij opgelost OnePlus 7 Pro Oxgen 10 latest, not Beta
    Dd 18-09-2020
     

    #74
    martin.schachinger likes this.
  15. I1603011271599
    Cupcake Oct 18, 2020

    I1603011271599 , Oct 18, 2020 :
    Can confirm the same issue from Singapore.

    This is definitely not a carrier issue.

    The mobile data connectivity drops the moment I open any apps. Both Sims on my phone face the same issue. When switching out to another phone, there are no issues at all.

    Seems to be the case when GPS/location info is switched on, data connectivity is affected. This issue only surfaced in the recent update to 10.3.4
     

    #75
  16. E1561989026898
    Cupcake Oct 20, 2020

    E1561989026898 , Oct 20, 2020 :
    Having the same issue in Singapore. This is getting irritating especially when you need to use the phone for payment.
     

    #76
  17. W1596391659259
    Cupcake Oct 31, 2020

    W1596391659259 , Oct 31, 2020 :
    Yeah this problem is well known to be a common issue with the OnePlus 7 Pro. You can see it on many reviews for this phone that this is not a "one-off" problem or a problem with only certain carriers. I've tried all types of solutions including getting a new SIM card and re-flashing my phone, but sadly none of them worked. My last option is that I recently sent my phone in for repair and am hoping that will fix the problem.
     

    #77
  18. ElSalvatore
    Gingerbread Nov 11, 2020

    ElSalvatore , Nov 11, 2020 :
    Bump!
    Has there been any solution by now?

    I've been having the exact same issues mentioned above for 2-3 months now on my OP6,y wife's OP6 started having the same issues about 2 weeks ago.

    I mean, wtf OnePlus, this issue has been known for so many months now, yet still no statement or solution has been provided?

    I'm thinking about sending in both phones for a repair (USB-C and headphone jack aren't working anymore either), but I don't know whether the struggle is worth it, since I don't even know whether a new/repaired unit won't have the same disconnection problems...
     

    #78
  19. GokulLee
    Gingerbread Nov 11, 2020


    #79
  20. Y1558526519073
    Cupcake Nov 25, 2020

    Y1558526519073 , Nov 25, 2020 :
    Facing the same issue with my 7 Pro in Austria with carrier A1/Educom on LTE Band 20 (800MHz). Oxygen OS 10.0.9.GM21BA. I will also set preferred network type to 2G/3G until there is a fix for the problem.
     

    #80