0
OnePlus 7 Pro T-Mobile No Data

  1. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :
    Hello. I have a OnePlus 7 Pro. I've had it for a month and have been using it with T-Mobile. My plan started for a new month and now data doesn't work and WiFi disconnects randomly.

    I have tried resetting the network, reset APN, removed the Sim and put back in after a restart, keep the phone off for a few minutes and back on. Nothing works.

    I can connect to tmobiles website no problem but no other site loads. I ran a speed test thru Ookla app and it did get a connection and showed great speeds but still, no webpage loads.

    I'm on the verge of returning the phone at this point but hoping someone here can help.

     

    #1
  2. Artemus.
    Community Hero 2020 Jun 10, 2020

    Artemus. , Jun 10, 2020 :
    Do you have the T-Mo version or unlocked using T-Mo services?
     

    #2
  3. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :
    Unlocked using T-Mobile.
     

    #3
  4. Artemus.
    Community Hero 2020 Jun 10, 2020


    #4
  5. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :


    Artemus.

    https://downdetector.com/status/t-mobile/

    Bookmark this link.​


    There is no outage in my area. I've also contacted T-mobile and they confirmed as much.

    It also doesn't explain why my WiFi is also disconnecting now. Both issues only started happening after I changed my plan to a lesser plan but I've since changed it back and it has the same issues.
     

    #5
  6. Artemus.
    Community Hero 2020 Jun 10, 2020

    Artemus. , Jun 10, 2020 :
    Did you try resetting the phone?
     

    #6
  7. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :
    Multiple times. Did so after clearing cache, removing the Sim card, putting it in a different Sim tray, resetting network, etc. Issue is still there.
     

    #7
  8. megoshopping
    Gingerbread Jun 10, 2020

    megoshopping , Jun 10, 2020 :
    if you have tried everything possible but to no avail. the last option is to go back to tmobile and get a new SIM card. we had a bad SIM in the past regarding data issue and after a new SIM from tmobile, everything is fine. no harm to give that a try, right?
     

    #8
    Artemus. likes this.
  9. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :
    I'm considering it after tmobile support gets back to me. Will be headed to the store and if that doesn't work, returning the phone.
     

    #9
  10. Bill1426
    Donut Jun 10, 2020

    Bill1426 , Jun 10, 2020 :
    I had the exact same issue (I'm also using an unlocked unit, and on T-Mobile). The issue for me was an app kept trying to update (the app was Google Play Music). I disabled the app, and rebooted, and everything worked again.
    A few weeks later I re-installed the app and I've had no issues since. I hope that helps...
     

    #10
  11. S1589387027181
    Cupcake Jun 10, 2020

    S1589387027181 , Jun 10, 2020 :
    I just factory reset my phone twice and the issue is still there so unless the app is one pre-installed on the phone, I can't tell what it could be.

    I did disable Google Music and the issue is still there.
     

    #11
  12. tjnewt11
    Cupcake Jun 10, 2020

    tjnewt11 , Jun 10, 2020 :
    currently having the same issue, ever since the recent update last week; seems to be tied to the GPS/ location. only happens when an app has to use the location. Did a warranty exchange and still having the issue
     

    #12
  13. S1589387027181
    Cupcake Jun 11, 2020

    S1589387027181 , Jun 11, 2020 :
    So I went to T-Mobile to get a SIM card. They couldn't activate it on my account. They said it shows there is a previous transaction pending. Before I went to T-Mobile though, I called customer support to make sure there isn't anything pending. Calling T-Mobile now to see what's up.
     

    #13
  14. tjnewt11
    Cupcake Jun 11, 2020

    tjnewt11 , Jun 11, 2020 :
    I tried a new SIM card as well...the only thing that has worked for me is having the location setting off for now. Tmo recommended wiping cache (which I did), and factory reset (did the warranty exchange), and same. it's an issue with the latest software update that came out last week. They recommended calling OnePlus, which I'm going to do tomorrow
     

    #14
  15. S1589387027181
    Cupcake Jun 11, 2020

    S1589387027181 , Jun 11, 2020 :
    Still waiting on a different TMobile rep but the first one I'm dealing with said that since my phone isn't a TMobile branded phone (I bought the phone from OnePlus and it's unlocked), that they will not be able to continue to help me despite the phone working for the past month on TMobile service.

    I'm about given up. I'm likely going to return the phone and cancel my service. I'll get a different service (though they are all expensive) and a different brand phone. Never had these issues before and this is too much hassle for a service I pay for.

    Really hope the next rep actually has a solution but if not, I'm not dealing with this anymore.
     

    #15
  16. Artemus.
    Community Hero 2020 Jun 11, 2020

    Artemus. , Jun 11, 2020 :
    I go with Metro personally.
     

    #16
  17. Bill1426
    Donut Jun 11, 2020

    Bill1426 , Jun 11, 2020 :
    When you did the Factory Reset, did you then do a restore of a backup, or did you try the phone without doing a restore from a backup ?
     

    #17
  18. S1589387027181
    Cupcake Jun 12, 2020

    S1589387027181 , Jun 12, 2020 :
    I did not restore from any backup. I individually backed up all my major data (photo's, videos and music) and put that back on but nothing else.

    Also, I did manage to get another phone to test. I tried my sim in that phone and it still didn't work for data. I switched my sim with my friends sim who is also on Tmobile and it did work and I had data from their plan.

    I think the issue is definitely on Tmobile's end now that I did that. They opened a case with their engineers to see what the issue is with my account but they still say that there is nothing wrong with my account though I couldn't activate another sim because it said there was a hold on my account that they can't find what that hold is. Psh, I'm very close to changing my phone provider to someone else.
     

    #18
  19. S1589387027181
    Cupcake Jun 13, 2020

    S1589387027181 , Jun 13, 2020 :
    Small update. TMobile closed my case and I didn't even know until I called back asking for an update.

    Anyways, I finally got a rep who looked at their backend for my service and saw that my data is being blocked. Apparently when you max out your data but change your service, the data is supposed to be reset but sometimes it doesn't. Problem is, I didn't max out my data before (I used 1/4th of the data) but guess there was some overlap when my service changed.

    So I have to wait for someone to go into my account and reset my data settings. Until then, I still have no data though my phone can access tmobiles towers.
     

    #19
  20. S1589387027181
    Cupcake Jun 14, 2020

    Best Answer
    S1589387027181 , Jun 14, 2020 :
    I'm cancelling my service. Got a 3rd sim and the issue is still there. Called T-Mobile and they closed all my cases without calling me to say why. I still have no data despite the issue clearly being a server-side issue. It's not worth the constant travelling and losing money because I have no data. Goodbye T-Mobile.
     

    #20