3
OnePlus 7 Pro type-c to type-c+3.5mm adapter issue after Oxygen OS 10.0.10 upgrade via OnePlus 7 Pro

  1. Jeewan Shrestha , via OnePlus 7 Pro , Nov 25, 2020 :
    After 10.0.10 update in my OnePlus 7 pro, the type-c to type-c+3.5mm adapter has stopped functioning. Prior to update I was able to use both (charger and earphone) at the same time but now after the update only one works at a time. I bought this phone basically for gaming but this update is ruining everything. Is anyone here aware of this issue? And is there any plans on fixing this issue by OnePlus?
     

    #1
  2. J4t1np4r3kh
    OnePlus Accessory Tester Nov 25, 2020

    J4t1np4r3kh , via OnePlus 7 Pro , Nov 25, 2020 :
    Are you definitely sure nothing is wrong with the adapter?

    I've not seen anything of the sort on the forums yet, so it may be that your specific adapter may have become faulty 🤷‍♂️
     

    #2
    Balenty, Jeewan Shrestha and Artemus. like this.
  3. mojoyoyo77
    Assistant Head Moderator Assistant Head Moderator Nov 25, 2020

    mojoyoyo77 , Nov 25, 2020 :
    Moved thread to OnePlus 7 Pro General Support
     

    #3
    Balenty likes this.
  4. Jeewan Shrestha , via OnePlus 7 Pro , Nov 26, 2020 :
    Yes I am sure. I have two adapters which were working fine prior to update. In fact I was playing PUBG right before I did the upgrade.
     

    #4
    tony1980 and Balenty like this.
  5. Jeewan Shrestha , via OnePlus 7 Pro , Nov 26, 2020 :
    It's not like it stopped working completely. The thing is I can't charge the phone and use the earphone simultaneously via these adapters now.
     

    #5
    tony1980 and Balenty like this.
  6. H1606475166079
    Cupcake Nov 27, 2020

    H1606475166079 , Nov 27, 2020 :
    Same issue with the 7t after the update.

    The funny thing is, i am using an adapter where Audio jack and charger are integrated, it starts charging and playing sound over the earphone and then it suddenly stops. Charging continues. You can hear a short humming sound on the earphones when switching.

    If I remove the charger all is working fine with the audio.

    It seems the charger is somehow disturbing the audio.

    I tested four different adapters, all have the same issue.

    It worked fine for months with no issues before.

    Would be really glad if it could be fixed, as it is hard for me to sleep without my audio books [e]1f602[/e]
     

    #6
  7. Balenty
    Cupcake Nov 28, 2020

    Balenty , Nov 28, 2020 :
    I am facing the same issue with my adapter to charge and use audio the same time.
    Whenever charging starts the audio will be rejected a few seconds after it started charging.
    A short loud beep is given through the audio port after disconnecting.

    It started with the most recent Oxygen OS Update.
    Worked before just fine.
     

    #7
    tony1980 and Jeewan Shrestha like this.
  8. Arnauc32
    Cupcake Nov 28, 2020


    #8
  9. jaydenrre
    Cupcake Nov 30, 2020

    jaydenrre , Nov 30, 2020 :
    I'm having the same problem after updating. Brand new Belkin adapter worked perfectly. Now can't charge and get audio at the same time. Audio alone works. Bus as soon as power is added the headphones disconnect.
     

    #9
  10. Djgrub
    Cupcake Dec 6, 2020

    Djgrub , Dec 6, 2020 :
    bonsoir sa arrive la même chose sur mon oneplus 7 pro
    cet vraiment la galère on plus plus écoute en même temps que chargé !! avez vous une solution merci .
     

    #10
    tony1980 likes this.
  11. tony1980
    Froyo Dec 7, 2020

    tony1980 , Dec 7, 2020 :
    same problem here.. as soon as you start charging... beep and phone forces audio to the speakers .. if u unplug or turn off power audio returns to headphones... i need a solution!!! i regret updating
     

    #11
    Jeewan Shrestha likes this.
  12. tony1980
    Froyo Dec 7, 2020

    tony1980 , Dec 7, 2020 :
    same here.. have you found a solution yet?
     

    #12
  13. G_Travis_Arnold_ooBr , via OnePlus 7 Pro , Dec 8, 2020 :
    I'm having the exact issue. Being using usb c headphones and power splitter to listen to audiobooks while charging my phone. Something in the latest stable update broke it. I've now tried 4 different brands of splitters and they don't work as expected. No headphone acknowledgement at all and I know two of the four splitters worked before the update. I also know in older devices the 3.5mm headphones work perfectly fine.

    This is a major bug. I really hope the developers see this and can take a look. I'll give bug report logs and anything else you guys might need.
     

    #13
    Jeewan Shrestha likes this.
  14. Hitzilla4
    Gingerbread Dec 8, 2020


    #14
    Djgrub likes this.
  15. V1575849787907
    Cupcake Dec 8, 2020

    V1575849787907 , via OnePlus 7 Pro , Dec 8, 2020 :
    I apologize as I posted a similar thread. Same issue. Happens regardless of the adapter used. Bought a new adapter just to be sure and still happening.

    Can play music if charger not connected but can't have charger and earphone connected at same time. When both are connected, music plays through phone's speaker only
     

    #15
    Djgrub likes this.
  16. Mohammad_Shehab
    Cupcake Dec 14, 2020


    #16
  17. Mohammad_Shehab
    Cupcake Dec 14, 2020

    Mohammad_Shehab , via OnePlus 7 Pro , Dec 14, 2020 :
    also audio disconnected when i connect the charger ( the priority for charging )
     

    #17
  18. Mohammad_Shehab
    Cupcake Dec 14, 2020

    Mohammad_Shehab , via OnePlus 7 Pro , Dec 14, 2020 :
    I have exactly the same
     

    #18

  19. #19
  20. Jeewan Shrestha , via OnePlus 7 Pro , Dec 17, 2020 :
    Oneplus don't allow to degrade the sw. It only allows to upgrade to newer one. Like from version 1 to 2 is upgradable but from version 2 to 1 is not possible. Do you have any workaround for this?
     

    #20