0
OxygenOS OnePlus 7 Pro Unable to Watch HD+ content in Prime Video/Netflix because of Widevine Level L3 via OnePlus 7 Pro

  1. blahq7
    Froyo May 10, 2021

    blahq7 , via OnePlus 7 Pro , May 10, 2021 :
    A few days after upgrading my OnePlus 7 Pro to Android 11 , it seems like my Widevine security level went down to L3, because I can't watch HD content anymore on Prime Video, Netflix, etc. This seems like a common problem, as there are other users reporting it:


    https://forums.oneplus.com/threads/windvine-downgraded.1388098/

    https://forums.oneplus.com/threads/netflix-and-amazon-video-are-sd-because-windvine-is-l3.1387637/

    https://forums.oneplus.com/threads/drm-issue.1429451/

    Does anyone know if this is something that is being addressed, and if so, when it's expected to be fixed?

    Thanks.


    1620618369650.jpg

     
    Last edited: May 11, 2021

    #1
  2. blahq7
    Froyo May 11, 2021

    Best Answer
    blahq7 , May 11, 2021 :
    Thanks, @Liehjan, your solution worked. My Widevine Level is back to L1, but I'm not sure if it'll stay like that, as the problem manifested itself about a week after updating, so we'll have to wait and see.

    These are the instructions I followed (this didn't wipe any data by the way):
    ▪️ On my computer I downloaded the latest stable build, (currently 11.0.0.2.GM21AA), from here. It'll be different if you have a different phone; choose the correct one for your phone here.

    ▪️ Then I plugged in my phone to my computer and transferred the .ZIP straight into Internal Storage.

    ▪️Then I went to Settings > System > System Updates > Click the little settings icon on the top right > Local Upgrade.

    ▪️Then I clicked the file shown there, and clicked Install, then when it was done, clicked Reboot.

    ▪️After it rebooted, I checked the Widevine Level with the DRM Info App, and it was back to L1:

    Note: As @pconleynms mentioned, you might also have to clear the storage/cache on Netflix for it to work again as normal. I did not have to clear the cache on Prime Video though, but I did have to enable the Hardware Acceleration feature in Prime Video's settings for it to work again as normal.

    [​IMG]
     

    Attached Files:

    Last edited: May 12, 2021

    #5
    P1570586637713, McJader and Liehjan like this.
  3. Liehjan
    Marshmallow May 10, 2021

    Liehjan , May 10, 2021 :
    Try to flash the same build you are on again.
     

    #2
    SRD. likes this.
  4. N1619752249345
    Cupcake May 10, 2021

    N1619752249345 , via OnePlus 7 Pro , May 10, 2021 :
    It's now been more than 20 days or so since I first encountered the problem and I have yet to find a fix. I have tried all the possible solutions and none seem to work. It's really disappointing that this hasn't been fixed yet considering many people are having it.
     

    #3
    iliyasilu and blahq7 like this.
  5. blahq7
    Froyo May 11, 2021


    #4
  6. Liehjan
    Marshmallow May 11, 2021

    Liehjan , May 11, 2021 :
    Great, let's hope it stays on L1 now :)
     

    #6
  7. blahq7
    Froyo May 11, 2021

    blahq7 , via OnePlus 7 Pro , May 11, 2021 :
    For sure. If it doesn't, I guess I can re-flash it in about 10 minutes, since I already have the installer file downloaded. It's a pain, but I guess you gotta work with what you have.
     

    #7
    AndroidManiac and Liehjan like this.
  8. pconleynms
    Cupcake May 11, 2021

    pconleynms , May 11, 2021 :
    I just wanted to say thank you guys so much this solved the problem for me as well!

    i also want to add however that i had to clear storage from netflix app for it to say i was back on L1
     

    #8
    blahq7 likes this.
  9. N1620823888058
    Cupcake May 12, 2021

    N1620823888058 , May 12, 2021 :
    I've encountered the same problem on 7t pro; and have the required rom (11.0.2 HD01AA, in my case) ready in the local upgrade path.

    Is doing this 100% safe in terms of data integrity?

    FYI, I've already wiped the app cache/storage, even recovery mode - wipe cache option without success.

    Many thanks
     
    Last edited: May 12, 2021

    #9
  10. blahq7
    Froyo May 12, 2021

    blahq7 , via OnePlus 7 Pro , May 12, 2021 :
    I did not lose any data anywhere (it told me I should backup my data, but that doesn't mean it'll wipe anything). It's basically like installing a system update when you get a notification that one is available, except you're doing it manually.

    If you have installed beta updates before, though, and you are going to stable ones, then I think it'll wipe the device, but beta updates have to be installed manually, so you'd know if you did that.

    Basically, if you're (and you should be) installing the exact same version update that you already have installed, you should be fine:

    [​IMG]
     
    Last edited: May 12, 2021

    #10
    N1620823888058 likes this.
  11. T1588194060719
    Cupcake May 14, 2021

    T1588194060719 , via OnePlus 8 , May 14, 2021 :
    What do you need to do when its installed on your phone? My phone only gives an option to restart it, but that doesnt work... What do you need to do after it is fully loaded in detail?
     

    #11
  12. P1570586637713
    Cupcake May 16, 2021

    P1570586637713 , via OnePlus 7T , May 16, 2021 :
    its not working in my phone
     

    #12
  13. blahq7
    Froyo May 21, 2021

    blahq7 , via OnePlus 7 Pro , May 21, 2021 :
    I mean...you could restart it manually also. If the restart button doesn't work in the system update widget, then restarting manually would be the same thing.
     

    #13
    tama154 likes this.
  14. blahq7
    Froyo May 21, 2021


    #14
  15. P1570586637713
    Cupcake May 24, 2021

    P1570586637713 , via OnePlus 7T , May 24, 2021 :
    Its Work...Thanks Bro....👍
     

    #15
  16. ShreeshaKaranth
    Cupcake May 27, 2021

    ShreeshaKaranth , via OnePlus 7 Pro , May 27, 2021 :
    Hello! Is it still L1? Or did it revert back to L3?
     

    #16