0
ONEPLUS 7PRO POP UP CAMERA PROBLEM

  1. Vaibhavgolu
    Cupcake Jan 18, 2021

    Vaibhavgolu , Jan 18, 2021 :
    After recent update front camera is not registering anything.
    camera just popup out and after some seconds it goes in.

    t seems that phone flashlght not workng or torch
    youtube s not workng
    vdeo s not playng


    Back camera or front cAMERa both are not workng
     

    #1
  2. drl431
    Community Hero 2020 Jan 18, 2021

    drl431 , Jan 18, 2021 :
    Try clearing the cache and storage for the camera app, then restart the phone (in that order).
     

    #2
    Tobikage likes this.
  3. pAiN_
    Honeycomb Jan 18, 2021


    #3
  4. Tobikage
    Nougat Jan 18, 2021

    Tobikage , Jan 18, 2021 :
    None of those should be related.

    Or your phone is dying.

    Try another camera app.
    What happens when whatsapp tries to access the camera ?
     

    #4

  5. #5
  6. J1610976058079
    Cupcake Jan 18, 2021

    J1610976058079 , Jan 18, 2021 :
    I have exact same issue started with front camera then main camera now YouTube. All days apart. Have submitted a bug report let me know if you get a fix
     

    #6
  7. StubbieDijits
    Cupcake Jan 19, 2021

    StubbieDijits , Jan 19, 2021 :
    Sounds like the same issue I'm having. Front camera worked fine 1/14/2021, but on the morning of 1/15/2021, the front camera would pop up, make a clicking sound with the screen blank then go back down. Tried from camera app, Messenger, telegram and zoom but all had the same result. Rear cameras were still working so I snapped a pic from the rear and figured I'd look online when I got home. Looked online and saw the clear cache/storage/reboot suggestion, but didn't change other than the rear cameras stopped working. I also noticed that the youtube app was stuck in a virtual loading loop afterwards which had been working fine that morning. Any attempt to use the camera directly or through other apps now causes the screen to go black.

    Currently running the 10.3.7.GM21AA build on my OnePlus 7 Pro (GM1915) with stock camera app v 3.10.26
     
    Last edited: Jan 19, 2021

    #7
  8. click312
    Donut Jan 20, 2021


    #8
  9. StubbieDijits
    Cupcake Jan 22, 2021

    StubbieDijits , Jan 22, 2021 :
    I called OnePlus Support and tried their suggestion to wipe camera cache/storage as well as the phone's camera/storage before trying a factory reset, but even after the cameras are still not working and now multiple apps (Amazon Shopping and YouTube) will not load. Other apps that use the camera will black out if I try to open the camera from the app. Fortunately the store that I purchased the phone from in Apr 2020 offered a 1 year warranty. I filed a claim with them and am sending the phone today for repair or replacement.
     

    #9