20
Oneplus 7pro warp charge not working

  1. koocha
    Gingerbread Jun 29, 2019

    koocha , Jun 29, 2019 :
    you're better off using engineering mode.

    dial *#808#
    Enter
    device debugging
    charging (fast charging)
     

  2. OPOBEAST
    Honeycomb Jun 29, 2019

    OPOBEAST , Jun 29, 2019 :
    So I gained only 38% within 20 minutes while Warp Charging. My 7 Pro was turned off and on 0%. I thought it should at least charge up to 50% in 20 minutes?
     

    I1561074663359 likes this.
  3. citrus13
    Froyo Jun 29, 2019

    citrus13 , Jun 29, 2019 :
    1561821204185.jpg

    hello this is on my OnePlus 7pro. I posted elsewhere until I found this thread. so I'm on 9.5.8 in Canada. warp charging was working when I received the phone. I was using the mcclaren (orange) cable and the charge block that came with the cable, ordered online. My routine is get up around 5 and plug phone in and it will be ready by 6 or 630. Well the other day plugged it in and no warp charging. Reloaded 9.5.8 and still the same. Tried the new power block that came from the box and the red cable. Also tried combinations of the cable and charge blocks. No Warp charging. Getting what I show below. Generally when I plug in the phone it's around 20%. Also I have a 10000mah power bank and it charges around 1480mah. Maybe faster then the factory plug and cable. Please see photos below. Thanks. Oh and the phone did warp charge previous. I'm just not sure when this started. Also have tried different plug outlets in my home. Same issues. No warp charging.

    **as you see above photo. when the phone was nearly charged. at 98%. the mAh is in the 300's only**
    View attachment 1054671

    1561810745625.jpg
     
    Last edited: Jun 29, 2019

  4. jan110968
    Jelly Bean Jun 29, 2019

    jan110968 , Jun 29, 2019 :
    i have just try starting my charge at 76%
    an as fare as i can see i get 1% pr minute
    an warp charge symbole is also there
    the blue icone on lockscreen im on 9.5.8
     

    Attached Files:


  5. lirannl
    Cupcake Jun 29, 2019

    lirannl , Jun 29, 2019 :
    I also stopped getting warp charge and am limited to 1400mah charging for some reason. I accidentally bought an extra warp charger and cable, I didn't realise there was one in the box, so I tried the other one. No effect.

    I'm on .8, but warp charge worked yesterday, and there have been 0 changes to my system since then (same OTA version, same kernel, I don't think I did anything that requires root in the past 24 hours and it worked just fine then). I sometimes intentionally connect my phone to a less powerful charger to charge overnight (no need to warp charge if there's plenty of time), but warp no longer works at all.
     

  6. citrus13
    Froyo Jun 29, 2019

    citrus13 , Jun 29, 2019 :
    Hi. This is what I get but my warp charger starts around 1400 then by the time the charge is 98% it's down to around 350mah. Have tried different warp charger blocks and cables.
     

    Attached Files:


  7. Menahjatwa
    Eclair Jun 29, 2019

    Menahjatwa , Jun 29, 2019 :
    Warp Charge goes super slow once your phone goes in 90% of the battery is being charged, that's quite normal, the warp charge kicks in from 0-50% then it'll hover around 3400 mA and then decreases as it go along.
     

  8. citrus13
    Froyo Jun 29, 2019

    citrus13 , Jun 29, 2019 :
    yes. but I don't get Warp. as I stated. it starts around 1400mah. and ends at 350mah. before the update my phone was over 4000mah.
     

  9. PeacefulS
    Cupcake Jun 29, 2019

    PeacefulS , Jun 29, 2019 :
    I found the solution (for me):
    Before the bug i had installed Oxygen OS 9.5.8 via fastboot +TWRP 3.1.3 + Magisk 19.4+ Renovate ICE 3.0 Magisk module

    What i did:
    - In TWRP i wiped everything (devlik, cache, system, internal storage, vendor) except for usb.
    - After that format data
    - Reboot in recovery
    - Copied the clean firmware zip (it can be found here https://forums.oneplus.com/threads/...a-oxygen-os-repo-of-oxygen-os-builds.1033129/ ) to internal storage through USB cable while i was in TWRP mode (this is the reason i haven't erased the USB storage)
    - flashed the zip firmware
    - reboot to system
    - now the warp charge should work.

    I also locked the bootloader.
    - build number 7 times
    - in developer options go to debug USB and advanced reboot and activate both of them
    - laptop side: in any adb terminal type "adb devices" (you should receive a pop up on the phone to allow it")
    - reboot to bootloader
    - laptop side: in a terminal type "fastboot devices". If your device shows up, next step type "fastboot oem lock"
    - phone side: use your volume buttons to lock the bootloader. This will wipe all your system settings and will install the stock recovery.

    Done. Back to stock Oxygen OS 9.5.8 GM21BA with stock recovery and locked bootloader.
     
    Last edited: Jun 30, 2019

    ducted and I1561074663359 like this.
  10. Menahjatwa
    Eclair Jun 29, 2019

    Menahjatwa , Jun 29, 2019 :
    Is it possible for the phone to be bricked by doing this?
     

  11. PeacefulS
    Cupcake Jun 29, 2019

    PeacefulS , Jun 29, 2019 :
    If you miss the format data step, i guess so.
    even if you'll run into reboot loop, just flash the TWRP recovery through fastboot--- format data in recovery mode---flash the firmware zip .
    Just make sure to flash the. img recovery file.
    Unfortunately, there are a lot of useless tutorials on YouTube regarding slot a or slot b. Forget those. Simply flash TWRP through "fastboot flash boot recoveryname.img" in a terminal.
    I ended up in countless loops doing that slot a slot b sh*t.
    Old way, best way.
     
    Last edited: Jun 30, 2019

  12. FreStyle
    Donut Jun 29, 2019

    FreStyle , Jun 29, 2019 :
    Same here, Warp charging was working fine till yesterday. but now its not working.
    1561833614079.jpg

    1561833614116.jpg
     

  13. citrus13
    Froyo Jun 29, 2019

    citrus13 , Jun 29, 2019 :
    The fix is even easier. Seems if rooted the issue lies with Magisk updating to Canary (beta) 19.4. You need to go into settings then update channel to stable, go back to Magisk and it will show you having 19.4 installed but 19.3 available to install on the top install button. Install 19.3 and reboot and warp charging will work. Not my work. I found this on XDA. Cheers.


    1561840976126.jpg

    1561840976162.jpg

    1561840976191.jpg
     

    FreStyle and PeacefulS like this.
  14. PeacefulS
    Cupcake Jun 30, 2019

    PeacefulS , Jun 30, 2019 :
    i think you're right! Never thought about downgrading the Magisk...
     
    Last edited: Jun 30, 2019

    citrus13 likes this.
  15. citrus13
    Froyo Jun 30, 2019


  16. koocha
    Gingerbread Jun 30, 2019


  17. FreStyle
    Donut Jun 30, 2019


    citrus13 likes this.
  18. sschaky
    Cupcake Jun 30, 2019

    sschaky , Jun 30, 2019 :
    What about those that have vanilla and unaltered, complete stock Android OnePlus 7 pro? No root, no magisk, no TWRP and have to wait 5-6-7 hours for a full charge because the phone recognizes the Warp charger as an USB charging cable plugged to a laptop...!?!? Jeeezus!
     

    koocha likes this.
  19. VulvaSniffer
    Cupcake Jun 30, 2019

    VulvaSniffer , Jun 30, 2019 :
    Confirmed, downgrading to 19.3 restored warp. fookin shite, i almost shipped my unit back. i thought the thing was faulty. anyway here's what i did:

    1. download Magisk uninstaller, put it on root storage and boot to recovery, make sure Magisk 19.3 is also on your root storage
    2. flash uninstaller, do not boot to system after it's completed. go back and reboot to recovery (again)
    3. flash magisk 19.3, boot to system. voila, donezo!
     

  20. koocha
    Gingerbread Jun 30, 2019