0
OnePlus 7T Changes to Vibrate on its Own?

  1. jbouton176
    Gingerbread Dec 12, 2019

    jbouton176 , Dec 12, 2019 :
    I got my new OnePlus 7T and noticed that it was randomly setting itself to vibrate even though the slider was in the ring position. After multiple hard resets and contact with support, I returned the phone thinking the switch might be defective. I bought a second 7T and within an hour and a half, the thing set itself to vibrate! This tells me that it's a software issue, but the only option support can offer is to remote into my phone. I am curious if anyone else has come up against this issue? It's a relatively clean phone, with common apps installed. I can't imagine one of those would be the culprit.
     

    #1
  2. Tedescir1
    Donut Dec 14, 2019

    Tedescir1 , via OnePlus 7T , Dec 14, 2019 :
    You're not alone. I have seen this behaviour too. I am also on a second 7T device. In my case, I'm fairly certain that the issue only occurs once I pair a Bluetooth device, or as a consequence of then adding that device as 'trusted'.

    I'm currently working with the support team to try to isolate the issue.

    What I noted is that the alert slider functions dropped down one notch (bottom becomes vibrate, middle becomes silent, and top is also silent). When I have the issue, pushing slider to the top, then back down to ring, temp fixes it.

    As things stand today, I have no trusted Bluetooth devices, and no vibrate issue. In a few days, I'll add my Garmin devices, and will later make them trusted.

    Maybe there's a fix in 10.0.7.
     

    #2
  3. jbouton176
    Gingerbread Dec 14, 2019

    jbouton176 , Dec 14, 2019 :
    Thanks for this. I was suspecting BT but wasn't positive. I have removed all "Trusted Devices" and will report back if the issue occurs again for me.
     
    Last edited: Dec 14, 2019

    #3
  4. jbouton176
    Gingerbread Dec 14, 2019


    #4
  5. kazprotos
    Donut Dec 15, 2019

    kazprotos , Dec 15, 2019 :
    This happens when I press power and volume up with screen on. Shows a notification on the bottom of the screen, but the vibrate icon doesn't appear on the status bar.
     

    #5
  6. jbouton176
    Gingerbread Dec 15, 2019

    jbouton176 , Dec 15, 2019 :
    That's not the issue here. Phone is sitting on the table, not in a case, untouched and it goes to vibrate.
     

    #6
  7. jbouton176
    Gingerbread Dec 15, 2019

    jbouton176 , Dec 15, 2019 :
    I am curious, do you have a smart watch connected to the phone? The trusted devices trick didn't work for me. Now I am just leaving Bluetooth off to see if it's one of the connected devices.
     

    #7
  8. Tedescir1
    Donut Dec 16, 2019

    Tedescir1 , via OnePlus 7T , Dec 16, 2019 :
    Could easily be a smart watch. I have a Garmin that connected to Garmin Connect (though it's not paired with the phone). I note that my phone is again in vibrate mode this morning.

    I'll undertake a bit of test syncing, then I'll do the same. I'll disable BT temporarily.
     

    #8
  9. jbouton176
    Gingerbread Dec 16, 2019

    jbouton176 , Dec 16, 2019 :
    I will do the same. I set the phone to Silent last night and at 3am I heard notifications. Looked at the phone and it was in Ring mode even though switch was all the way up. Going to turn off BT for the day and see what happens as well. I may just give up and return this phone.
     

    #9
  10. Tedescir1
    Donut Dec 16, 2019

    Tedescir1 , via OnePlus 7T , Dec 16, 2019 :
    FYI. A bug has been raised for this by another user.

    I'm personally no closer to isolating the cause, though my 7T phone has switched to vibrate twice today.

    https://forums.oneplus.com/threads/the-phone-is-changing-to-vibrate-mode-by-itself.1154496/

    I do have the request to update to 10.0.7. If there was a full bug fix list I'd prob update now. Maybe I will anyway.

    In the mean time, my Bluetooth is switched off. I'll monitor over the next 24 hours.
     

    #10
  11. Tedescir1
    Donut Dec 16, 2019

    Tedescir1 , via OnePlus 7T , Dec 16, 2019 :
    Hmm, I may need to eat some humble pie. Fault has ocurred on my phone whilst BT was switched off.

    I'm now going to stop Garmin Connect.

    For anyone else affected, do you use Garmin Connect, or is that a red herring?

    Have also requested a detailed bug fix list for 10.0.7 in case there is info/resolution in that release.
     

    #11
  12. jbouton176
    Gingerbread Dec 16, 2019

    jbouton176 , Dec 16, 2019 :
    I've had BT off all day and so far, stable. Not conclusive. Going to let it go another day and see. I was suspecting maybe Samsung Wearable was culprit, but I have a friend with the same 7T and Samsung Wearable and no issues. Not sure if smart watch was the way to go, but worth exploring. If it stays stable another day with BT off, I will turn BT back on and delete all devices and see what happens.
     

    #12
  13. jbouton176
    Gingerbread Dec 16, 2019

    jbouton176 , Dec 16, 2019 :
    Ah, just had the issue with BT off. Noticed this happened after coming home. I wonder if Trusted Places has anything to do with it, so I deleted Trusted Places completely. Probably just throwing darts at this point.
     

    #13
  14. Tedescir1
    Donut Dec 17, 2019

    Tedescir1 , via OnePlus 7T , Dec 17, 2019 :
    So, I deleted Garmin Connect, and have BT off, but this morning phone is in silent mode (which is new). I too have my home location as trusted, so I'll follow suit.
     

    #14
  15. jbouton176
    Gingerbread Dec 17, 2019

    jbouton176 , Dec 17, 2019 :
    This is the first night that the status didn't change for me. So far, so good. We'll see how the day goes. Looking forward to your update.
     

    #15
  16. jbouton176
    Gingerbread Dec 17, 2019


    #16
  17. Tedescir1
    Donut Dec 18, 2019

    Tedescir1 , via OnePlus 7T , Dec 18, 2019 :
    I did not clear my cache, at any stage, so had one instance of the phone going to vibrate after removing my trusted location. However, since shortly after my last post the fault has not recurred.

    so, I'm still not certain if it's a trust or Bluetooth issue, but seems very likely that it's one of them.

    I'll be leaving both off today.
     

    #17
    jbouton176 likes this.
  18. jbouton176
    Gingerbread Dec 18, 2019

    jbouton176 , Dec 18, 2019 :
    Interesting. I didn't think to reboot or clear cache, however, I have not encountered the error since clearing Trusted Location. I am leaning toward it being an issue with Location services rather than BT. I used the heck out of BT yesterday with no issues. In another day, if still no bug, I will add a device to Trusted Devices and see what happens.
     

    #18
    Tedescir1 likes this.
  19. Tedescir1
    Donut Dec 18, 2019

    Tedescir1 , via OnePlus 7T , Dec 18, 2019 :
    Still Getting this issue (twice in the last 24hours), but my address was still greyed out in 'trusted places'. I have been unable to completely remove it (it's come from Google maps), but a cache clear has sorted that. Now completely gone.

    So, starting a new test period, and still on 10.0.6.
     

    #19
    jbouton176 likes this.
  20. Tedescir1
    Donut Dec 19, 2019

    Tedescir1 , via OnePlus 7T , Dec 19, 2019 :
    24 hours in. No recurrence of the issue. Seems very likely to me that smart lock is the root cause. Specifically trusted sites/devices in my case.

    I'm going to re-enable Bluetooth, as my testing infers that's not the problem. I'll obviously ensure that none are set as trusted.
     

    #20