8
OnePlus 9 Android Auto not working

  1. A_man_27
    Donut Apr 8, 2021

    A_man_27 , Apr 8, 2021 :
    This is the most frustrating thing ever, just upgraded from the OP6T, android auto working fine, I was even using a Amazon basics cable. Now I have the OP 9, using hte OnePlus cable, AND IT WILL NOT CONNECT. It just keeps connecting and disconnecting over and over and over...... I've tried enabling USB Debugging and changing the USB type to PTP, which worked, ONCE. I've uninstaleld and reinstalled the AA app, it's also up to date.

    This is a know issue if you do a simple Google search. WHY?
     

    #1
  2. Caomhin
    OnePlus 9 Series Expert Community Expert Apr 8, 2021


    #2
    Tokolozi likes this.
  3. MDMujtaba999
    Jelly Bean Staff Member Apr 9, 2021

    MDMujtaba999 , Apr 9, 2021 :
    We are sorry to hear that you are facing this issue. It would be our pleasure to resolve the issue that you are facing, as we have contacted you for the required information to analyze it further via direct message.

    Regards,
    Mujtaba
     

    #3
    vgyani likes this.
  4. idbl_fanatic1
    Ice Cream Sandwich Apr 9, 2021


    #4
  5. marian.andrei
    Cupcake Apr 10, 2021


    #5
    soupsandwiches likes this.
  6. antfoulds
    Donut Apr 10, 2021

    antfoulds , via OnePlus 9 Pro , Apr 10, 2021 :
    I have exactly the same problem. Android auto launches when I connect my USB to the car, the immediately shuts down, launches, shuts down. Over and over again.
    I have tried all recommended fixes - debugging, changing USB, resetting the software on my car, clearing cache and storage.
    Nothing has worked.
     

    #6
  7. Enochraj
    Cupcake Apr 11, 2021


    #7
  8. Ruqhaiya Taskeen
    Ice Cream Sandwich Staff Member Apr 11, 2021

    Ruqhaiya Taskeen , Apr 11, 2021 :
    We may have to check this further. Kindly check you're inbox we've dropped you a direct message. It'll be of great help if you could share the required information. 

    Regards,
    Ruqhaiya Taskeen
     

    #8
  9. soupsandwiches , via OnePlus Community App , Apr 12, 2021 :
    This is what I was going to recommend, it's typically the solution for me if an AA feature doesn't work, i.e. waze isn't recognized.
     

    #9

  10. #10
  11. NikisSmikis
    Cupcake Apr 12, 2021


    #11

  12. #12
  13. U1618326217069
    Cupcake Apr 13, 2021

    U1618326217069 , Apr 13, 2021 :
    I was looking to see if any of the fixes resolved your problem. I am trying to decide whether to buy a Samsung or OnePlus phone but if Android Auto won't work, that's a deal-breaker for me as I rely heavily on Android Auto.
     

    #13
  14. D0RKl0rD
    Cupcake Apr 13, 2021

    D0RKl0rD , via OnePlus 9 , Apr 13, 2021 :
    I have the same exact issue. Had a 6t prior with everything working fine. My op9 fails to connect.
    I did find a work around. Pulling down the notification and changing usb type to PTP or File Transfer fixes the issue and allows it too connect. However even then the connection is not great. Music plays fine but assistant voice is laggy and sometimes cuts back into music before it finished speaking.
    Using a usb-if cable from Amazon. Also tried my original 6t cable. Same issue. The car is a 2018 honda civic si.
    I emailed support and and also sent them a video, but I'm not sure if anyone is actually looking into this. Really horrible to have this type of bug on a brand new phone. This is a core feature for a lot of people! Please fix this !
     

    #14
  15. U1618326217069
    Cupcake Apr 13, 2021

    U1618326217069 , Apr 13, 2021 :
    Thanks, F_Art_Mazur_wWrb! From what I've been reading online so far, one site is recommending the Google phone for best Android Auto support. I suppose it makes sense but the Google phones are a bit generic and the UI is not as sleek as the OnePlus phones but it looks like that may be the best option going forward.

    I currently have the same issue with my old LG V20 phone. It sometimes will connect to my car and other times it doesn't. There doesn't seem to be any rhyme or reason as to why it won't work consistently.

    Has anyone here had consistent results using Android Auto or would you say it's hit-or-miss similar to F_Art_Mazur_wWrb's experience?
     

    #15
  16. D0RKl0rD
    Cupcake Apr 13, 2021

    D0RKl0rD , via OnePlus 9 , Apr 13, 2021 :
    Just keep in mind that the one main thing you want to rule out with AA is that your usb cable is not the problem. Purchase a high quality usb-if certified cable from Amazon to see if it helps as 90% of the time that is the problem.

    In my situation I have fully ruled out the cable and can replicate this bug and a work around.
     

    #16
  17. soupsandwiches , via OnePlus Community App , Apr 19, 2021 :
    Usually you need to clear the cache and memory from the android auto app, it should do the trick. And like the others said before, check the settings to see how your cable connection is setup, how it's read from the device. Also check your cars software and see if there's is an update available that may change something.
     

    #17
  18. wescrock
    Cupcake May 9, 2021

    wescrock , May 9, 2021 :
    Same issue on my OP9. I see a lot of reports on the OP9 Pro. I assume it's the same issue.
     

    #18
  19. Akshat Sehgal
    Ice Cream Sandwich May 9, 2021


    #19
    Q1608923630891 likes this.
  20. barathrajss
    Gingerbread May 10, 2021