3
OnePlus 9 pro HDMI Out

  1. simmondp
    Froyo Apr 14, 2021

    simmondp , Apr 14, 2021 :
    I'm trying to find out whether the OP9 Pro supports HDMI in 2k and/or 4k via the USB-C port. There seems to be no information one way or the other!
    I've tried two USB-C adaptors I have, one does not work and one seems to cause the OP9 to lock-up / crash!
     

    #1
  2. Couches
    Froyo Apr 14, 2021


    #2
  3. ksr11
    Eclair Apr 19, 2021

    ksr11 , via OnePlus 9R , Apr 19, 2021 :
    I tried in oneplus9R. It's working fine. No settings required. I have used Pibox usb c to hdmi. So I think 9 pro is more expensive than 9R it might definitely it supports.
     

    #3
    drl431 likes this.
  4. AbandonedTrolley
    Jelly Bean Apr 19, 2021

    AbandonedTrolley , Apr 19, 2021 :
    https://www.amazon.co.uk/gp/product/B075V5JK36/

    This works perfectly fine

    Cameratest.jpg
     

    #4
    Swejuggalo likes this.
  5. Couches
    Froyo Apr 19, 2021


    #5
    AbandonedTrolley likes this.
  6. AbandonedTrolley
    Jelly Bean Apr 20, 2021

    AbandonedTrolley , Apr 20, 2021 :
    It certainly should do, I mainly use for with my Lenovo ThinkCentre (Plex server) but it switched straight away with no issues when plugging in to the OP9 Pro
     

    #6
  7. Couches
    Froyo Apr 23, 2021

    Couches , Apr 23, 2021 :
    Just tried it.. unfortunately no luck. I really appreciate the suggestion though. This cord is a pretty high quality feeling one so I'll probably hold onto it. I've tried different ways such as doing usb c first or hdmi first, different connections that accept usb c to hdmi such as a capture card, then tried a monitor, tv and laptop. Same exact thing happens which is it acts like it is wanting to load, then it completely shuts down on me. I'll keep at it and post if there's any changes.
     

    #7
  8. RT33
    Cupcake Apr 23, 2021

    RT33 , Apr 23, 2021 :
    Same here, phone chrashes if plugged in via hdmi. Usb-c to hdmi cord is a quality cord, and worked fine with oneplus 7t.

    @Swejuggalo Here is bug for you to report,:)
     

    #8
  9. G_V._M._sKKA
    Eclair Apr 23, 2021


    #9
  10. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 23, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 23, 2021 :
    Guess I need a collection of cords and adapters 😜 Might even buy one or 2 😉 (almost bought a second 8 Pro just to allow testing of stable and beta at the same time... Was hard to resist. On 9 Pro I will actually be able to do just this! Hurray. Double the fun)
     
    Last edited: Apr 23, 2021

    #10
  11. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 23, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 23, 2021 :
    Besides the cables used, also mention the hdmi port standard on the screen just incase it is the difference between it working and not working.
    I just decided to buy a cable 😜
    I also have a wireless screen adapter... But work is currently borrowing it
     

    #11
  12. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 23, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 23, 2021 :
    No problem at all here by showing the screen. My computer screen only has 1.4a though. Not 2.0. Do your port have 2.0?
    I don't have a television so... 😜
    Shit... Now I got the urge to upgrade my screen. But I'll save that for much much later.
    Anyway... I found a other bug that I'll report later. It works very well for a moment but then the screen turns off at the same time all the time. So somehow it timeout and act like if there was no input.
    Correction. It was HDMI 2.0. Other HDMI port is 1.4a. Will that one too later.
     
    Last edited: Apr 23, 2021

    #12
  13. RT33
    Cupcake Apr 23, 2021

    RT33 , Apr 23, 2021 :
    Plugging the phone to a LG UN7300 tv`s 2.0hdmi port causes the phone to shut down without warning.
     

    Attached Files:


    #13
  14. Swejuggalo
    OnePlus 9 Series Expert Community Expert Apr 23, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , Apr 23, 2021 :
    Solved my own problem. Upgraded firmware of my screen and switched port. Read about issues with that port being picky about used standards and such. Working PiP as my phone as second device.

    Don't think I can help much more. Unless a shop allows me to connect to every display TV they got 😜
     

    #14
    RT33 likes this.
  15. O1617797714960
    Cupcake May 4, 2021


    #15
  16. Swejuggalo
    OnePlus 9 Series Expert Community Expert May 4, 2021

    Swejuggalo , via OnePlus 9 Pro Stellar Black , May 4, 2021 :
    Other than report it via the feedback tool and replicate it with the logging on that they most often want you to do I don't really have a good tip.

    This seems to be triggered only by certain combinations.
     

    #16
  17. RT33
    Cupcake May 9, 2021

    RT33 , May 9, 2021 :
    Seems to work with an older tv, but not with current models, at least from LG and Sony.
     

    #17
  18. prestonjb
    Eclair Jun 6, 2021

    prestonjb , Jun 6, 2021 :
    my experience

    older tv 1.4 it works but only if I plug in hdmi after I plug in USB.... however resolution is 720p max. tv is 4k

    new tv. crashes until I locked hdmi to 2.0. however resolution is 720p max. tv is 4k

    on a 2k computer monitor it looks really good... however no sound.

    I also have an HDMI recorder box. used to capture hdmi to a PC ... it kinda works. connected to my 4k tv(s) the resolution looks high... however no audio and when playing Netflix or Amazon or HBO the screen will flicker and the app thinks it's a disconnect and stops playing.

    what we need is sw like Samsung Dex or huawie p30 pro desktop (display port alt mode?) so that the oneplus drives the output resolution (asks for it) instead of letting monitor (tv) default (tv default is 720p and I don't see settings to fix ATV to a different resolution)
     

    #18
  19. X1622916089384
    Cupcake Jun 19, 2021


    #19
  20. Couches
    Froyo Jun 20, 2021

    Couches , Jun 20, 2021 :
    Nothing new so far. I submitted a bug report a couple times. I've tried a ton of different cords and methods and nothing's worked so far.
     

    #20