1
OnePlus Buds Pro Constantly Updating Firmware {help]

  1. jdm9499
    Froyo Nov 9, 2021

    jdm9499 , Nov 9, 2021 :
    Hello all, I received the Buds Pro yesterday and set up the sound profile, etc. via the HeyMelody app. Last night I received one firmware update, and this morning I received 4 in the past hour. Now it's showing there is another update in the HeyMelody app. Is this a known glitch? I don't know what to do, because I can't use the headphones while they are constantly updating. Any advice would be appreciated.
     

    #1
    lehno likes this.
  2. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    Try to use them without app HeyMelody but with OnePlus Oficial app

    Before starting to use it you shall uninstall HeyMelody, than you can install it and pair Buds
     

    #2
  3. jdm9499
    Froyo Nov 9, 2021

    jdm9499 , Nov 9, 2021 :

    I would if I could, however, my phone is the Google Pixel (I should have mentioned earlier), so I'm only able to use the HeyMelody app.
     

    #3
  4. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    No, you didn't...anyway, are you not able to install the app I linked? O__o''
     

    #4
  5. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    Probably just OnePlus devices are supported to install it...ok.
    Check which HeyMelody Version is and let me know
     

    #5
  6. jdm9499
    Froyo Nov 9, 2021

    jdm9499 , Nov 9, 2021 :
    Unfortunately, no. It will not install on the Pixel. The HeyMelody app is version 100.0.26.
     

    #6
    Merlinlegend likes this.
  7. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    Strange...because my most recent version available on Play Store is 100.0.21. Try to uninstall and instal again HeyMelody App
     

    #7
    jdm9499 likes this.
  8. jdm9499
    Froyo Nov 9, 2021

    jdm9499 , Nov 9, 2021 :
    I have deleted and reinstalled, also cleared the cache/data, and have now reset the Buds Pro. Still, every time I open the HeyMelody app, I'm prompted with a 489 firmware update.

    [​IMG]
     

    #8
  9. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    WHAT DAH HECK! to be honest, the bug is something like a graphic glitch nothing more...
    Have you tried to install all of them? :D kidding

    Man, you have to send a feedback to OP devs HERE
     

    #9
  10. eddyros
    Ice Cream Sandwich Nov 9, 2021


    #10
  11. eddyros
    Ice Cream Sandwich Nov 9, 2021

    eddyros , Nov 9, 2021 :
    Anyway, people just solve it by reinstalling HeyMelody like I suggested beofre...
    Have you also rebooted your device?
     

    #11
  12. jdm9499
    Froyo Nov 9, 2021

    jdm9499 , Nov 9, 2021 :
    Very interesting. Same thing for me! Ok, will report it as a bug. Thank you.

    I have yeah. I just did it all again, and even cleared the cache/data bluetooth settings on the phone just in case. I started everything new again. Opened the app just now and boom, same 481 firmware update. I wrote HeyMelody and submitted the bug with OnePlus. We'll see if I ever get a reply.
     

    #12
    eddyros likes this.
  13. Merlinlegend
    Eclair Nov 10, 2021

    Merlinlegend , Nov 10, 2021 :
    I updated using the app from under macos.
     

    Attached Files:


    #13
  14. lehno
    Cupcake Nov 10, 2021

    lehno , Nov 10, 2021 :
    Did u find a solution for that?
     

    #14
  15. jdm9499
    Froyo Nov 10, 2021

    jdm9499 , Nov 10, 2021 :
    I have not, no. Tried everything all over again today, the same problem. The firmware just doesn't load at all. I'm trying to find someone with an iOS device and see if I can try it on their phone. Other than that, no idea why they are not updating.
     

    #15
  16. johnvjohn
    Cupcake Nov 10, 2021


    #16
  17. jdm9499
    Froyo Nov 10, 2021


    #17
    lehno likes this.
  18. rovman
    Cupcake Nov 14, 2021

    rovman , Nov 14, 2021 :
    I have the same issue. Just got the buds today, installed HeyMelody (awful experience btw - looks like some dodgy app you wouldn't want in your phone, I expected the app to be branded by, and released by OnePlus)...

    Anyway. The earbuds connected just fine and I was offered the firmware update which was "successfull"... But then the app just keeps offering the update, so presumably it didn't really install at all.

    Reinstalled the app several times, run the update countless times. It doesn't work.

    Tried on:
    Google Pixel 6 (android 12)
    Google Pixel 4 (android 12)
    Samsung j6 (android 10)

    No dice.

    Edit: Got hold of an iPhone to try form a different platform and still no update. The iPhone app shows a little more info, so out of the box, the buds are on version 467, and trying to update to 489.

    I'd really like an answer to this, as I'm aware in the future Dual Connection will be available through an update, but if the Buds can't update then they are essentially faulty as far as I'm concerned.
     
    Last edited: Nov 16, 2021

    #18
    Arragorn likes this.
  19. U1637224400865
    Cupcake Nov 23, 2021 at 6:56 AM

    Last edited: Nov 27, 2021 at 11:23 AM

    #19
  20. T1629787092152
    Cupcake Nov 25, 2021 at 12:22 PM

    T1629787092152 , Nov 25, 2021 at 12:22 PM :
    Yea, I've been having the same issue here too. My buds work just fine, however the update just doesn't seem to install even though it said it was successful. I use them on my Z Fold 3.
     
    Last edited: Nov 27, 2021 at 6:34 AM

    #20