1
Oneplus Buds pro keeps thinking it's out of my ears

  1. H1612242052273
    Cupcake Jan 19, 2022

    H1612242052273 , Jan 19, 2022 :
    I use the noise cancelling on them and suddenly, it stops and one of the ear turns on transparency mod so I have to push the bud in the other ear to reenable the noise cancelling. It's really annoying, especially when I'm outside biking or skiing. Sometimes it even pauses the music, which is even more annoying.
     

    #1
    N1630874791341 likes this.
  2. Shailender Sharma
    Nougat Jan 19, 2022

    Shailender Sharma , Jan 19, 2022 :
    Have you tried to reset the buds pro? It might help! Could you suggest something here @Liehjan ?
     

    #2
    Liehjan likes this.
  3. Liehjan
    The Lab Reviewer - OnePlus Buds Pro Community Expert Jan 19, 2022

    Liehjan , Jan 19, 2022 :
    Thanks for the tag.
    It's most likely the in ear detection that is causing this, so you could try to disable that. When the bud thinks it's not in the ear, it turns off the ANC. The sensor seems to give out a false positive depending on how deep inside the ear you have the bud.
     

    #3
    Shailender Sharma likes this.
  4. N1630874791341
    Cupcake Jan 27, 2022

    N1630874791341 , Jan 27, 2022 :
    Same issue here, everytime i put them out of the case, the last one that i wear think it is out. So i have one on noise cancelling and the other no. I have to remove it and put it back on my ear
     

    #4
  5. H1612242052273
    Cupcake Jan 28, 2022

    H1612242052273 , Jan 28, 2022 :
    The problem with that suggestion is that there is no option to disable the detection... there is only an option to disable it from stopping the music.
    My main problem is that right now, I have both earbuds in my ear, the furtest I can go and then, randomly one of the sensors doesn't want to detect my ear anymore. It happens sometimes in one ear and sometimes in the other...
     

    #5
  6. Liehjan
    The Lab Reviewer - OnePlus Buds Pro Community Expert Jan 28, 2022

    Liehjan , Jan 28, 2022 :
    Seems to have changed in later firmware. When I got the buds there was that option in the buds app. But now when I checked it there wasn't anymore. Only disable auto pause like you said.

    If you have another device that isn't OnePlus branded you could try Heymelody and see if the option is there?
     

    #6
  7. H1612242052273
    Cupcake Feb 4, 2022

    H1612242052273 , Feb 4, 2022 :
    It's not... Is there a way to fake the ear detection
     

    #7
  8. Liehjan
    The Lab Reviewer - OnePlus Buds Pro Community Expert Feb 4, 2022

    Liehjan , Feb 4, 2022 :
    One way would be to put tape on the sensor? I really don't have a good solution to give you.
     

    #8
  9. GiaNN
    Cupcake Feb 19, 2022

    GiaNN , Feb 19, 2022 :
    i'm having the exact issue, it's really annoying... i have to keep getting them in and out in different position to make them work. hope that in some next firmware they add the option to disable this feature
     

    #9
  10. H1612242052273
    Cupcake Mar 4, 2022

    H1612242052273 , Mar 4, 2022 :
    Yeah... really freaking annoying!
    It's the only problem I have with these buds, otherwise they are great, it really pisses me off
     

    #10
    GiaNN likes this.
  11. Skillz1975
    Cupcake Apr 26, 2022

    Skillz1975 , Apr 26, 2022 :
    I had the same problem. I turned off high quality audio. Been fine since I made the switch. Was going to throw them out before.
     

    #11