2
Oneplus Buds Pro stopped working after firmware upgrade via OnePlus 7 Pro

  1. umikam
    Donut Nov 30, 2021

    umikam , via OnePlus 7 Pro , Nov 30, 2021 :
    I purchased new Oneplus buds pro. As soon as I unboxed it, everything worked just fine. I was really happy with the performance.
    I had a firmware update after which my buds won't connect to bluetooth anymore.
    I tried holding the setup button for 10 seconds to reset the headphones multiple times but it won't help me discover Bluetooth.

    Now when I open the charging case, I see a constant red light when the headphones are inside the case. (I think it used to be green when I used it first)
     
    Last edited: Dec 1, 2021

    #1
    jccrepeau and B1636085140706 like this.
  2. TibiTibi
    Photography Expert Community Expert Dec 1, 2021

    TibiTibi , Dec 1, 2021 :
    Did you tried this?

     

    #2
    Artemus likes this.
  3. umikam
    Donut Dec 1, 2021

    umikam , Dec 1, 2021 :
    Hi,
    Yes I tried it, but unfortunately it's not working. The indicator light keeps glowing red when the headsets are in the charging case 😩
     

    #3
  4. B_Wrath
    Junior Moderator Junior Moderator Dec 1, 2021

    B_Wrath , Dec 1, 2021 :
    If it is constant red, it means it doesn't have charge. Did you charge it?
     

    #4
  5. umikam
    Donut Dec 1, 2021

    umikam , Dec 1, 2021 :
    Yes, I tried charging it also. It glows constant red only when the buds are in the charging case. As soon as I remove the buds from the case, the case gives a green indicator light. So I guess it has enough charge.
     

    #5
  6. TibiTibi
    Photography Expert Community Expert Dec 1, 2021

    TibiTibi , Dec 1, 2021 :
    Just an option.
    Try to completely discharge the box and then charge them all.
     

    #6
  7. umikam
    Donut Dec 1, 2021

    umikam , Dec 1, 2021 :
    Do you have any idea how I can do that without letting it discharge by itself? Because that could take days.
     

    #7
    TibiTibi likes this.
  8. TibiTibi
    Photography Expert Community Expert Dec 1, 2021

    TibiTibi , Dec 1, 2021 :
    Could you pair the buds with other device, tablet, notebook...? Or you can play the Zen sound only. Turn on ANC - ANC will discharge them faster.

    Meanwhile you can contact the support to get some other advice.
     

    #8
  9. umikam
    Donut Dec 1, 2021

    umikam , Dec 1, 2021 :
    No, I cannot pair it to any devices. The buds won't send Bluetooth signals.
    Also it does not respond to any pinch command on it bar either. So I cannot switch on ANC or play Zen music.

    I contacted the support by phone and found out that many users are facing this issue after a firmware update through HeyMelody app. Hope they resolve it soon, or I will have to return back the Buds Pro.
     

    #9
    TibiTibi likes this.
  10. TibiTibi
    Photography Expert Community Expert Dec 2, 2021

    TibiTibi , Dec 2, 2021 :
    So you don't have a oneplus phone?
     

    #10
  11. TibiTibi
    Photography Expert Community Expert Dec 2, 2021

  12. ji.bala94
    Cupcake Dec 2, 2021

    ji.bala94 , Dec 2, 2021 :
    I don't think so. But I am facing exactly the same scenario. Brand new buds pro, tested with song once, then using the HeyMelody app updated to 467 firmware and then after that my left ear bud has stopped working. The case is always red although the battery says 90%.
    My left ear bud is basically not detected at all.
    Tried factory resetting multiple times but, still same scenario.

    Also tried connecting with a OnePlus 6 and still the same.

    Such an expensive ear bud and it bricks right away. Very disappointed.

    Please send a fix ASAP.
     

    Attached Files:

    Last edited: Dec 2, 2021

    #12
  13. umikam
    Donut Dec 2, 2021


    #13
    TibiTibi likes this.
  14. umikam
    Donut Dec 2, 2021

    umikam , Dec 2, 2021 :
    The indicator light in the charging case will indicate the life of both the ear buds when both of them are left inside the case. If you remove one of the ear bud, it should show the life of the ear buds which is left in the case and finally when you remove both the buds, it should show the life of the charging case.

    So, you can try removing the non working bud from the case and hopefully the indicator light should glow green.

    Of course, this does not solve the issue. I just wanted to share this information so it might come in handy some other time.
     

    #14
    TibiTibi likes this.
  15. TibiTibi
    Photography Expert Community Expert Dec 2, 2021

    TibiTibi , Dec 2, 2021 :
    I'm a forum member only like you. I can give you only hints or help with troubleshooting.
    If the problem is in the HW you should contact the service.
    If the problem is in the SW you can report a bug via feedback.

    For oneplus phones you should use the oneplus buds app not the Hey melody.
     

    #15
  16. Martinmupp
    Cupcake Dec 2, 2021

    Martinmupp , Dec 2, 2021 :
    I have exactly the same problem, started after I updated the firmware yesterday
     

    #16
    jccrepeau, mystiqu and umikam like this.
  17. umikam
    Donut Dec 2, 2021


    #17
  18. rui.d.afonso
    Cupcake Dec 2, 2021

    rui.d.afonso , Dec 2, 2021 :
    Just had the same issue, I already asked for replacement. But it is really frustrating and a little bit scary to update the replacement unit once they send it to me. But let's hope that this is an issue that does not affect all the units.
     

    #18
    umikam likes this.
  19. TibiTibi
    Photography Expert Community Expert Dec 2, 2021

    TibiTibi , Dec 2, 2021 :
    May I ask you all to provide the following information?
    1. Phone model
    2. App:
      • Oneplus buds
      • Hey melody
    Thank you.
     

    #19
  20. Z1636039455974
    Cupcake Dec 2, 2021


    #20
    umikam likes this.