11
[Submitted] OnePlus Gallery app not updating on OxygenOS 11 Stable update

  1. @PriyanshuSaxena
    Froyo Oct 10, 2020

    @PriyanshuSaxena , Oct 10, 2020 :
    I just installed the stable update of OxygenOS 11 on my OnePlus 8 Pro. I am not able to update the OnePlus Gallery app from Play Store. I can see there is 91 MB update, I click on update and the update gets 100% downloaded. When it shows "Installing", thats where it shows an error notification as seen in the screenshot.

    [Update]: Apart from Gallery, same issue with Asphalt 9, Call of Duty: Mobile, World Cricket Championship 3 (and a lot more which I might not have discovered!)
     
    Last edited: Oct 26, 2020

    #1
  2. Borsyuf
    Cupcake Oct 10, 2020

    Borsyuf , via OnePlus 8 Pro , Oct 10, 2020 :
    Yes, I tried clearing cache and data but still was unable to install Gallery. Additionally, there are few other apps for which in facing the same issue
     

    #2
  3. jobaniora
    Cupcake Oct 11, 2020

    jobaniora , via OnePlus 8 , Oct 11, 2020 :
    I have the same experience after updating to OOS11. I also followed the suggested steps by Google Play but still unable to complete the install process.
     

    #3
    Srikanth1022v likes this.
  4. Y1597846946088
    Cupcake Oct 11, 2020


    #4
  5. U1597384761205
    Cupcake Oct 11, 2020

    U1597384761205 , Oct 11, 2020 :
    Facing the same issue after oxygen OS 11udpate. Currently installed app version is 4.0.70. The version in play store is 4.0.77
     

    #5

  6. #6
  7. morfarjinko
    Cupcake Oct 11, 2020

    morfarjinko , Oct 11, 2020 :
    I havet exactly THE same problem. Upgraded to Oxygen 11 today and Oneplus Gallery fails to install version 4.0.77 from 4.0.70
     

    #7
    cls55 likes this.
  8. @93Sithu
    Cupcake Oct 12, 2020


    #8
  9. Y1597846946088
    Cupcake Oct 12, 2020

    Y1597846946088 , via OnePlus 8 , Oct 12, 2020 :
    Thanks so much. This worked to me. It's very easy to find.
     

    #9
  10. HappyBullFrog
    Cupcake Oct 14, 2020

    HappyBullFrog , Oct 14, 2020 :
    I tore my hair out about this all weekend, until I found this thread. The 4.0.77 apk package from APKmirror installed easily.

    Thanks!
     

    #10
  11. cls55
    Froyo Oct 14, 2020

    cls55 , via OnePlus 8 Pro , Oct 14, 2020 :
    Thank you...
     

    #11
  12. HappyBullFrog
    Cupcake Oct 15, 2020

    HappyBullFrog , Oct 15, 2020 :
    I was able to install OnePlus Gallery 4.0.77 from apkmirror.com.

    But the Google Play Store update problem remains. Yesterday it could not update to 4.0.81, because Gallery is a System App and seems to have with some sort of weird restriction. I have tried all the suggestions offered here and by Google, as well as deleting Gallery's cache and data.

    I think we will have to wait for a patch from OnePlus to OxyenOS 11.
     

    #12
  13. xrage
    Cupcake Oct 16, 2020

    xrage , Oct 16, 2020 :
    Same problem in my oneplus 8 pro. Don't want to side load apps because of security concerns. I feel we all should wait for official fix.
     

    #13
  14. @PriyanshuSaxena , via OnePlus 8 Pro , Oct 16, 2020 :
    Although I agree side loading shouldn't be done since it might have security concerns, I went ahead with downloading the apk package from apkmirror, after looking at a lot of people giving positive reviews that is is safe since they just keep the play store packages after rigorous security checks. It worked fine for me.
     

    #14
  15. HappyBullFrog
    Cupcake Oct 16, 2020

    HappyBullFrog , Oct 16, 2020 :
    Side loading 4.0.81 from apkmirror.com works fine for me also.

    But I think the problem will repeat itself with the next update to OnePlus Gallery, until there is a patch to OxygenOS 11's System app.
     

    #15
    PriyanshuSaxenaLive likes this.
  16. ChrisLuton
    Cupcake Oct 20, 2020

    ChrisLuton , Oct 20, 2020 :
    I'm having the same issue which is not a OnePlus Gallery app issue. It's appears to be an issue with the Google Play store. Not only am I unable to update several apps, I'm unable to download an unpredictable subset of apps on the Play store. Some things download; some do not. And it seems completely random. Is this a bug in the OxygenOS11 stable release? Has anyone found a work around?
     

    #16
    Srikanth1022v likes this.
  17. HappyBullFrog
    Cupcake Oct 21, 2020

    HappyBullFrog , Oct 21, 2020 :
    I just updated 20 apps from the Play Store with no difficulty.

    After updating to the US version of OxygenOS 11 I had difficulty with only 2 apps -- Messages (which would crash while loading) and Gallery (which can be sideloaded from ApkMkrror.com, but will not update later from the Play Store, probably because it is a System App. I believe an OS patch will be required. Meanwhile you can continue to sideload updates whenever they are released.)

    TRY THIS:
    1. Go to Apps, Google Play Store, then clear both Storage and Cache.

    2. Click on Advanced, then scroll down to the bottom of the page and write down the version of PlayStore app you have installed and compare it to what is a available from the Play Store.

    I now have:
    version 22.3.15-21 [0] [PR] 336769479

    If necessary install the latest Play Store app version, then clear Storage and Cache again (might be unnecessary).

    3. Fully close down your cell, then restart it.

    4. Now try updating all your apps again.

    This might take a long time, because your Play Store app may have to check the. version numbers of all your apps against what is available to download. It probably lost some of that info when you cleared Storage.

    5. Good luck! Let us know whether or not my suggestion has worked for you.
     

    #17
  18. HappyBullFrog
    Cupcake Oct 21, 2020

    HappyBullFrog , Oct 21, 2020 :
    I forgot to mention that after updating a lot of apps, it sometimes seems necessary to close down the PlayStore app, then restart it and check again for updates.

    In other words, some apps will update only after other apps update first.
     

    #18
  19. ChrisLuton
    Cupcake Oct 21, 2020

    ChrisLuton , via OnePlus 8 Pro , Oct 21, 2020 :
    I'd already tried to clear cache/data for the play store as the error that occurs provides a link to a help article that recommends several things. All of which I have done. I've been unable to find a resolution anywhere for this unfortunately. 🥴
     

    #19
  20. HappyBullFrog
    Cupcake Oct 21, 2020

    HappyBullFrog , Oct 21, 2020 :
    Follow my instructions again carefully, especially the part about closing down your phone completely, then restarting.

    Restarting is necessary to clear out anything that might remain in working memory.

    If that doesn't work, you might have some sort of corruption in the operating system. I am no expert, but I think you might have to backup all your data and then restore your phone to factory settings and start over.

    That would be an act of desperation and a massive pain in the butt!
     

    #20
    Srikanth1022v likes this.