843
Guide

OnePlus One - How to Unlock Bootloader, Install Custom Recovery and Root

  1. tobluc Cupcake Jun 1, 2016

    tobluc, Jun 1, 2016 :
    Please help! I can't install twrp! My oneplus one is running oxygen os 2.1.4. I can run the commands fine but when I try to reboot my phone into the recovery it gets stuck. It is just a black screen with the oneplus logo (nothing else). It stays like this for 20+ mins. What can I do?
     

  2. sachin surana Froyo Jun 2, 2016

    sachin surana, Jun 2, 2016 :
    i am on COS 12. Can i use this method to unlock bootloader, flash recovery and ROOT and also flash new ROM after doing this?
     

  3. dersise Cupcake Jun 3, 2016

    dersise, Jun 3, 2016 :
    The same thing is happening to me. Please can someone help?
     

  4. daniga74 Jelly Bean Jun 4, 2016


  5. jbh433 Eclair Jun 5, 2016

    jbh433, Jun 5, 2016 :
    Thanks for the link/info. Took almost 2 hours for the erase function to work
     

  6. asadrajput Cupcake Jun 7, 2016


  7. Hatimcool Eclair Jun 8, 2016

    Hatimcool, Jun 8, 2016 :
    HELP!!!!
    guys im in a pickle right now. my opo has some rebooting issue of lately. so i want to backup my current rom. i have installed twrp but am unrooted on stock rom. do i need to root my phone before backup or not. please also tell me what all to backup for eg: boot,system,data efs, etc. do i need to check any of the 3 boxes below storage option{skip md5,compression,etc}. please reply asap,
    thank you in advance
     

  8. Optimista Eclair Jun 9, 2016

    Optimista, Jun 9, 2016 :
    hey guys, can any1 help, i managed to get custom boot image and when i need to transfer supersu it says device not found, and when i go to fastboot and type fastboot devices it's there.... help pls

    ---------------------------------------
    edit
    installed a driver that recognized adb as android device but i cant copy the file to phone. i says it cant find supersu.zip in that folder although i tried several times and even renaming it...
    ------------------
    edit 2:
    extensions was not show, that's why it said no file found... but now that i converted it from .rar to .zip it says it's missing md5 file.... grrrr..... step by step i'll get there

    --------------------------------------
    edit 3:
    Seems like the supersu file i downloaded first was crap, downloaded another 1 installed like charm.. Android is starting... I was never more happy to see that written on the screen :D

    1st root gone well after 7 hours hahahha
     
    Last edited: Jun 10, 2016

  9. daniga74 Jelly Bean Jun 10, 2016

    daniga74, Jun 10, 2016 :
    backup: boot, system, data, efs;
    try to backup without root
     

  10. Hatimcool Eclair Jun 10, 2016

    Hatimcool, Jun 10, 2016 :
    I think you misread my problem or might have replied to the wrong person.
    Anyways thanks
     

  11. Hatimcool Eclair Jun 10, 2016

    Hatimcool, Jun 10, 2016 :
    Sorry I replied to the wrong comment
     

  12. EdwinB44 Cupcake Jun 17, 2016

    EdwinB44, Jun 17, 2016 :
    If the phone is stuck in a bootloop (or bricked, i'm not sure), is there a way to flash? I can get it to fastboot but because it won't boot normally, i can't set USB debugging and CM recovery settings
     

  13. daniga74 Jelly Bean Jun 18, 2016

    daniga74, Jun 18, 2016 :
    If you can access in fastboot mode use fastboot command but you'll lost all your data
     

  14. Renyson Robert Donut Jun 19, 2016

    Renyson Robert, Jun 19, 2016 :
    Fix This -> https://forums.oneplus.net/threads/ghost-issue-in-oneplus-one-low-microphone.451194/#post-14977469
     

  15. bigdogdon Cupcake Jun 23, 2016

    bigdogdon, Jun 23, 2016 :
    COS 13.1, can't unlock

    So, I was rooted and running COS 13.0. Recently, I flashed the latest COS 13.1 stock ROM using TWRP... I thought I had de-selected "Update Cyanogen Recovery", but apparently not because it has locked the bootloader and installed the Cyanogen recovery.

    Now I am unable to unlock the bootloader... the tamper bit is set to true. When I use
    fastboot eom unlock
    It simply re-boots to the Cyanogen recovery.

    Is there something different about COS 13.1 that doesn't allow the bootloader to be unlocked with the usual method? Has anyone else had this problem?
     

  16. Shi Enn Donut Jun 25, 2016

    Shi Enn, Jun 25, 2016 :
    Hi guys, I was following this guide, but right now I'm stuck with the rooting step. I have adb driver installed as per the link given, but when I tried to execute the command "adb push update-supersu.zip /sdcard", I got the error that says "device not found".

    1. Have I executed the command wrongly in any way? I did rename my zip file to supersu
    2. Could it be I have conflicting adb drivers installed? I tried "adb version" and I got a return msg of "adb version 1.0.31"

    Any advices pertaining to this adb push method will be greatly appreciated. Thanks!
     

  17. lucasochs Cupcake Jun 26, 2016

    lucasochs, Jun 26, 2016 :
    So I think something is up. When I unlocked bootloader, I ran "fastboot oem unlock" but my data did not get erased. I kept going with the process, and my phone shut off like it was supposed to, but now I cant get it into fastboot. The phone boots up just fine right now, and all my data is still there, so I'm kind of at a loss for what to do.
     

  18. bigdogdon Cupcake Jun 27, 2016

    bigdogdon, Jun 27, 2016 :
    Solved it by using the Qualcomm service tool.
     

  19. daniga74 Jelly Bean Jun 28, 2016

    daniga74, Jun 28, 2016 :
    look below: Qualcomm service tool
     

  20. daniga74 Jelly Bean Jun 28, 2016

    daniga74, Jun 28, 2016 :
    http://www.makeuseof.com/tag/android-wont-connect-windows-adb-fix-it-three-steps/