843
Guide

OnePlus One - How to Unlock Bootloader, Install Custom Recovery and Root

  1. hibernick Cupcake Jul 8, 2016

    hibernick, Jul 8, 2016 :
    Hi guys,

    I have the following configuration:

    the phone is onepluse one,
    stock recovery,
    bootloader is locked,
    USB debugging is off
    OS - ubuntu 15.10
    adb version - the latest
    update.zip - signed zip from cygn.com

    COS13.1 the latest OTA update.
    The phone boots but right after booting I can not unlock the screen.
    When I swipe the screen It just hangs and goes to reboot.
    So I can not activate developer options to enable USB debugging.

    when I set phone to adb sideload mode:
    $adb devises
    89xxxxx sideload
    but
    $adb sideload update.zip
    error: protocol error (no status)

    Does anybody know why It doesn't work?
     
    Last edited: Jul 8, 2016

  2. EmanuelTimo Cupcake Jul 18, 2016

    EmanuelTimo, Jul 18, 2016 :
    Help guys! I followed every step, until the phase of
    Code:
    fastboot flash recovery recovery.img
    the cmd replies with
    Code:
    error: cannot load 'recovery.img'
    Anyone?

    edit;

    SOLVED: Filename was recovery.img of which it dubbed into recovery.img.img so I just had to erase .img so filename were only recovery
     
    Last edited: Jul 18, 2016

  3. kuganrv Cupcake Jul 21, 2016

    kuganrv, Jul 21, 2016 :
    i followed all until opening the recovery mode. my OPO when in recovery mode, i can't press anything. then it reboots. what's the problem? i can't root
     

  4. rosearkana Cupcake Jul 22, 2016

    rosearkana, Jul 22, 2016 :
    I followed this guide to a tee, but when I get to the adb push I get (error: devince not found"), i've looked around and tried every possible solution and none work, and now I can't boot my phone. I've tried restoring it, wiping it, everything, and it just sticks at the Cyanogen Mod ready splash screen. any help?
     

  5. skd Cupcake Jul 24, 2016

    skd, Jul 24, 2016 :
    Hi,
    My OnePlus One was running on CynogenMod 13. Yesterday, google play services tried to get access of location and after that phone got stuck in bootloop. Is there any possibility to recover without losing data.
    thanks.
     

  6. lieven marques Cupcake Aug 2, 2016

    lieven marques, Aug 2, 2016 :
     

  7. lieven marques Cupcake Aug 2, 2016

    lieven marques, Aug 2, 2016 :
    Hi,I managed all untill 3. rooting: upon command
    adb push UPDATE-SuperSU-vX.XX.zip /sdcard/ I get reply error : device not found..
    any clue what goes wrong (or what could happen)
    fyi : i am as instructed in recovery mode : i can see i installed TRWP 2.8.5.1
    tx a lot
    Lieven
     
    Last edited: Aug 8, 2016

  8. lieven marques Cupcake Aug 8, 2016

    lieven marques, Aug 8, 2016 :
    solved
    the adb push had to happen in normal mode (not in recovery mode)
    rooting succesfull tx
     

  9. success Cupcake Aug 8, 2016


  10. G_susan_lau_SNEt Cupcake Aug 9, 2016


  11. Waelvis Froyo Aug 24, 2016

    Waelvis, Aug 24, 2016 :
    How do you get into normal mode?

    I'm also stuck on the "device not found".


    When I plug my OPO into my laptop, I hear the connecting sound. So there's definately something.
    When I start my OPO in "normal mode", all I get is the Cyanogen start logo.

    When I try the push command then, i get the error: "Device unauthorized. Please check the confirmation dialog on your device"


    Edit: nevermind, I came up with the idea to copy the files to a USB drive and connecting them to my phone with a OTG cable. And it worked. Phone is installing my Apps at the moment..
     
    Last edited: Aug 24, 2016

  12. Hemul36 Cupcake Aug 26, 2016

    Hemul36, Aug 26, 2016 :
    I have the same problem like Waelvis:
    I tried the same solution, found the superSU and installed it. I got the successful message. But still can't start my OPO. Is stuck at the Cyanogen screen. What can I do? Is there a way to restart the proccess?


    Edit: Used a newer version of superSU and it worked!
     
    Last edited: Aug 28, 2016

  13. Rahuvich Honeycomb Aug 26, 2016

    Rahuvich, Aug 26, 2016 :
    After rooting my phone, I keep getting the notification that says that there is a new update on Oxygen. What happens if I try to update it from here (I mean not from recovery) and how do I update to the newest Oxygen? Thanks in advance and sorry for my bad english
     

  14. Jayrathore Cupcake Sep 16, 2016


  15. F_Long_Ho_RfsI Cupcake Sep 17, 2016

  16. daniga74 Jelly Bean Sep 19, 2016

    daniga74, Sep 19, 2016 :
    Which oxygen's version? Ported from OnePlus X?
     

  17. NeerajiB Cupcake Oct 6, 2016

    NeerajiB, Oct 6, 2016 :
    Can anyone help how to root my recent updated cm 13.1.2 one+one smart phone
    Thanks in advance
     

  18. fullingdale Cupcake Oct 14, 2016

    fullingdale, Oct 14, 2016 :
    I have tried to follow this guide, but something isn't quite working right for me. I downloaded the TWRP and SuperSU files; did the fastboot unlock and reboot. Altered the settings for the updates and did the fastboot flash recovery - all without any problems.

    Step 3 is where I have issues. I get the phone started in recovery and try the adb push, but I keep getting "device not found" other threads said to make sure the Android Phone is showing in the device manager, which it is. Listed with "Google Nexus ADB Interface"

    If I let the phone boot normally, to start with it would get stuck on the "logo" screen and after retrying the first steps, it gets stuck on the "Android +1" screen (before the logo)

    Any help/advice appreciated
     

  19. leokook Cupcake Oct 18, 2016

    leokook, Oct 18, 2016 :
    Thank you for this guide, it helped a lot. However, I used the files linked in the first post, and a lot of them are not updated for the current version of COS 13.1. I flashed the SuperSU for android M, and not the one for Android L, despite of that, the root and the phone work great. I'd like to flash the right version for superSu, but I'm not sure if i have to uninstall the current version or should i just flash the .zip file without hesitate.

    Thank you for your reply.
     

  20. Shahab1013 Cupcake Oct 25, 2016

    Shahab1013, Oct 25, 2016 :
    I am stucked t only one step and that is the fastboot devices step and it does not show me my device and also I got the adb devices step but every one time I do that again I have to restart my laptop in order to again show my device In the adb devices