843
Guide OnePlus One - How to Unlock Bootloader, Install Custom Recovery and Root

  1. Dhina
    Eclair Feb 18, 2017

    Dhina , Feb 18, 2017 :
    Can someone give the link to download "slimmed version containing only the essential components Android SDK" please ?
     

  2. daniga74
    Jelly Bean Feb 21, 2017

  3. G_Rehan_Sharma_oAaQ
    Cupcake Feb 28, 2017

  4. VceliaV
    Donut Mar 1, 2017

    VceliaV , Mar 1, 2017 :
    Your shitty "slimmed version" got me adware so you can **** right off
     

    cool_runnings likes this.
  5. James1989
    Gingerbread Mar 2, 2017

    James1989 , Mar 2, 2017 :
    The SuperSU bit of the OP's post has screwed me over. I'm using my OnePlus One, got as far as the rooting section, then it says to to
    adb push UPDATE-SuperSU-vX.XX.zip /sdcard/

    Well, the SuperSU version I downloaded wasn't named like that, and it gave me an error. Now it won't detect my phone. I wish i'd have known this before hand otherwise i'd have put the file on my phone earlier.

    How do I get that zip onto the phone in TWRP? Thanks

    EDIT: I used my USB stick that doubles up as a USB > USB mini to move the file across from within TWRP to the SD Card, followed rest of the procedure, rebooted, says i'm not rooted... given up. Can't connect to Google either now. :-(
     
    Last edited: Mar 2, 2017

  6. karungrover
    Cupcake Mar 16, 2017

    karungrover , Mar 16, 2017 :
    I am trying to root OPO 6.0.1 having CM 13.1. Initially it fastboot devices was not giving any result. I installed OPO USB driver and it showed the device serial number. But no progress after that .

    adb reboot bootloader is not rebooting the phone.

    error : device not found

    can you please suggest what is the problem and how to resolve it.
     

  7. daniga74
    Jelly Bean Mar 17, 2017

    daniga74 , Mar 17, 2017 :
    to root the phone you need first to install custom recovery via fastboot and then flash root package via recovery.
    enable debug usb in developer options
    to install recovery boot the phone in fastboot mode (volume up + power) and the issue the command:
    fastboot flash recovery 'revocery_name.img'
     

  8. Qacnterp
    Cupcake Mar 27, 2017

    Qacnterp , Mar 27, 2017 :
    For data recovery , the data will not be removed easily on Android phone , until the data was deleted with erase tool or the daya has been covered by new data , in this case , youn can never recover lost data back on your Android phone , if not , there are some recovery tool can help you found lost data on Andorid phone ,
    If you want to ask how to root phone device without lost ? you'd better try the AnyRooter ,
     
    Last edited: Mar 30, 2017

  9. Sahib bhatia
    Froyo Mar 31, 2017


  10. nXceptions
    Eclair Mar 31, 2017

    nXceptions , Mar 31, 2017 :
    I can't find the link for downloading the full version of the SDK on the android website, and the download for the slim version doesn't work. Someone help me please.
     

  11. Omerdadon1
    Cupcake Apr 11, 2017

  12. aris
    Jelly Bean May 17, 2017


    dr.ade likes this.
  13. dr.ade
    Cupcake May 18, 2017


  14. Lithium84
    Cupcake Jun 1, 2017

    Lithium84 , Jun 1, 2017 :
    Hi,

    I followed the guide and installed custom recovery. I then flashed android ROM using this guide. https://forums.oneplus.net/threads/official-4-4-4-oneplus-aosp.65482/
    I also applied SuperSU.
    Now when i start the android OS, there is a message asking to install root SuperSU using google play. When rebooted into the recovery to flash gapps it won't start, the logo screen is flashing.

    Any help is greatly appreciated. Thank you,
     

  15. sthapl
    Cupcake Jun 4, 2017

    sthapl , Jun 4, 2017 :
    hi, I am stuck here please help me out. I tried this method and just before the 3rd step of rooting where you have mentioned, Don't use the "Fastboot Reboot" Command Instead Unplug Your phone then Manually turn it off by pressing and holding power button until it switches off.. I actually used the command, "fastboot reboot" to reboot my device and it got stuck at the cynogen mod reboot screen. Then I wiped all data using the wipe data and now it is stuck at 1+ screen. Please help me as I dont know what to do now ?? :(:(
     

  16. daniga74
    Jelly Bean Jun 6, 2017

    daniga74 , Jun 6, 2017 :
    can you enter in recovery mode by pressing VOL DOWN + POWER?
    which recovery you enter stock or twrp?
     

  17. G_Etem_SKENDEROVIC_CpLy
    Cupcake Jun 14, 2017


  18. Pikiokos
    Cupcake Aug 13, 2017

    Pikiokos , Aug 13, 2017 :
    Okay, firstly, thanks a lot for helping us noobs out with this task!
    Second, I run into some issues and probably bricked my opo...

    I followed your preparation and first step carefully.
    I unlocked the bootloader, and then you mention that "The phone will reboot. Wait until the phone has fully booted up into android, then adjust the following settings on the phone".
    Well, my phone never rebooted fully. I waited 5'-10' and then shut it down. That probably did it.
    I then tried and succeeded at installing the recovery (I also tried some other versions of the TWRP later).

    The status now is that when the phone is in Fastboot, my computer recognizes it, and shows the serial number when I press "fastboot devices" in the command prompt window.
    When I go into recovery, no matter what, neither do I find the device nor can I "push" anything in it. I constantly get the message "adb error failed to get feature set: no devices/emulators found".

    I also tried drawing the lineage .zip into the phone through a usb stick using the otg cable, but the phone doesn't "see" anything in any of my usb sticks...

    Is there anything I can try in order to save it, or should I sell it for parts?
     

  19. highdiver_2000
    Ice Cream Sandwich Aug 14, 2017

    highdiver_2000 , Aug 14, 2017 :
    Boot into Recovery. Flash a full update, preferably the same version as you had.

    Restart phone. Phone will now boot.

    I got into the same problem trying to change my build prop file and it got into a boot loop or black screen.

    If you were on Lineage, reflashing method should still works.
     

  20. Pikiokos
    Cupcake Aug 14, 2017

    Pikiokos , Aug 14, 2017 :
    The "adb push" command, does not respond. It only gives the message "adb error failed to get feature set: no devices/emulators found". Correct me if I'm wrong, but by flashing an update, you mean to push it into /sdcard/ and then install it, right?
    Moreover, the phone won't recognize the .zip from a usb flash drive using the otg cable.
    Thank you for the help response highdiver_2000!