843
Guide OnePlus One - How to Unlock Bootloader, Install Custom Recovery and Root

  1. jeroenraap
    Eclair Sep 25, 2014


  2. shrinathji
    Ice Cream Sandwich Sep 25, 2014

    shrinathji , Sep 25, 2014 :
    Hello, is it possible to root without wipe. I really dont want to wipe and just would like to flash Franco kernel. Any help will be appreciated please.I have rooted my S2 quite a lot but this method is something new for me and want to avoid wiping my device.
     

  3. pjbeee
    Donut Sep 25, 2014

    pjbeee , Sep 25, 2014 :
    Rooting report: On brand new phone, after upgrading to latest firmware, (11.0-XNPH33R), unlocked bootloader using ADB commands, installed TRWP 2.8.0.1. Went without a hitch, except that TWRP asked to install SuperSU (and root with it), looked like it worked, but it didn't - phone was not yet rooted. In any event, it was easy from there. Forgot exactly what I did next, but I think I looked up SuperSU in the play store, and after that I was given the choice of "Play" or "TWRP" to install SuperSu and root; "TWRP" worked. Phone is now happily rooted, and of course TWRP recovery also works.

    My last phone was an S3 (i747). How nice it is to not worry about an OTA update (or replacement phone) trying to kill your ability to unlock the bootloader and/or root the phone. I love the huge screen on the One, but my main reason was really to get out from under the fear that some future phone would be a total pain to bootloader-unlock. The S3 is still a stellar device, even a couple of years after its release, but for not much more than a brand new (and now, hard to fully unlock, with its Samsung 4.3+ firmware) S3, I'm happy to give the "One" a good workout!

    And my old working S3 is safely in the drawer as a spare.
     
    Last edited: Sep 25, 2014

  4. add1ct3dd
    Gingerbread Sep 25, 2014

    add1ct3dd , Sep 25, 2014 :
    Hey guys, not sure what to do.

    Installed the ADB drivers etc fine, got custom recovery on all went dandy. After installing my custom ROM etc and just wanting to use MTP mode now, I cannot get it to work! (to transfer files over).

    I get the following:

    [​IMG]

    I've tried removing all drivers, and only installing these etc, but it does not work!

    Do we know exactly which device (MTP and One), correspond to which driver? Letting windows do it automatically sadly does not work.

    I'm not bothered by ADB support now as it's flashed and rooted, I just want MTP working again :).

    Any help much appreciated!

    Cheers
     

  5. hayes
    Honeycomb Sep 25, 2014

    hayes , Sep 25, 2014 :
    I can't seem to sideload anything these days. Any zip or img I flash I always end up stuck at the boot logo.
     

  6. elpapo
    Cupcake Sep 26, 2014


  7. chipples
    Gingerbread Sep 26, 2014

    chipples , Sep 26, 2014 :
    Thanks the guide. One thing, after flashing the recovery, my PC woudn't recognise the device. In device manager it has a warning sign next to "One" as if it doesn't have the drivers, and adb devices wouldn't list in when either in recovery or normal mode. However, CM automatically asked me if I wanted to install SuperSU via TWRP, so I let it do that and it seemed to work fine.

    However, you may need to tweak the guide slightly... I'm not sure what I need to do to fix the ADB thing, since I already have the drivers installed as far as I can tell.
     

  8. chipples
    Gingerbread Sep 26, 2014

    chipples , Sep 26, 2014 :
    ^^ you can ignore that. I don't think I installed the ADB driver. Embarassing ;)
     

  9. add1ct3dd
    Gingerbread Sep 26, 2014


  10. Enes_97
    Honeycomb Sep 26, 2014


  11. l92king
    Cupcake Sep 26, 2014


  12. Biglou
    Cupcake Sep 26, 2014


  13. reverenddak
    Ice Cream Sandwich Sep 27, 2014

    reverenddak , Sep 27, 2014 :
    It's actually really crazy how easy it is to do these steps. The biggest hurdle for me was to get the drivers right. Samsung ADB drivers worked for me, really well. The only thing I wish I was able to figure out was how to backup the apps and data before I did the wipe. Because now I have to re-install everything. Don't know why the Stock Recovery doesn't do backups, install ZIPS/ROMS, so we can just ROOT if we wanted to. There are enough steps to root that it doesn't make any sense that this phone doesn't just allow it without wiping.
     

  14. sultanzademurad
    Gingerbread Sep 27, 2014


  15. gmack523
    Froyo Sep 27, 2014


  16. sharkbitten741
    Ice Cream Sandwich Sep 27, 2014

    sharkbitten741 , Sep 27, 2014 :
    Help please?
    I'm on a windows 8.1 and when I tried step number 5. The cmd box appears and then disappears, and nothing else happens..
     

  17. mmd1989
    Cupcake Sep 27, 2014

    mmd1989 , Sep 27, 2014 :
    i already downloaded the requierd files to be ready when i get invite to buy it :D
     

  18. Titan-Z
    Ice Cream Sandwich Sep 27, 2014

    Titan-Z , Sep 27, 2014 :
    LOL
    True that!
    I've seen it happen.

    Oh newbs.
     

  19. Bakr
    Honeycomb Sep 28, 2014


  20. mannan_akmal
    Eclair Sep 28, 2014