844
Guide OnePlus One - How to Unlock Bootloader, Install Custom Recovery and Root

  1. sayso
    Gingerbread Dec 10, 2014

    sayso , Dec 10, 2014 :
    Had a few problems with the ADB drivers as its the 3rd phone i have rooted on this PC i had all sorts floating about, funnily enough the OPO was picked up by the Samsung drivers i had 3 phones back.
    Also had a few strange things happening with the phone, getting into Fastboot could only be done when unplugged from PC and i had a few reboots where i wasn't expecting them...all in all it took about 20Mins with 10 of those sorting out the ADB driver problem.
    Thanks for your guide now a proud owner of a Rooted phone with TWRP :)
     

  2. rubyyy
    Froyo Dec 10, 2014

    rubyyy , Dec 10, 2014 :
    Thanks for the guide dude! Mine is a christmas present and this is literally the first thing I'm doing ;)
     

  3. silvagroup
    Honeycomb Dec 10, 2014

    silvagroup , Dec 10, 2014 :
    Could have corrupted file. Might also want to try to download it again.
     

  4. bsanser
    Cupcake Dec 11, 2014

    bsanser , Dec 11, 2014 :
    Hi! I was following the guide but after unlocking the bootloader, when I started going through the second part (Installing a custom recovery) I could not boot the phone into fastboot mode. And what's more, I could not turn on the phone unless I pressed the power button for about 20 seconds, which is weird and had never happened to me before.

    Any suggestions on why I can't boot into fastboot? I was able to do it when unlocking the bootloader...

    Thank you very much!
     

  5. silvagroup
    Honeycomb Dec 11, 2014

    silvagroup , Dec 11, 2014 :
    Is your computer seeing your device.
    Can you see device when you do Fastboot devices in terminal?
     
    Last edited: Dec 11, 2014

  6. ultimatum
    Gingerbread Dec 11, 2014

    ultimatum , Dec 11, 2014 :
    In the command prompt, it says path not found...How do I solve this. (Big Noob here ;) )
     

  7. troublekick
    Donut Dec 11, 2014

    troublekick , Dec 11, 2014 :
    Well, I even tried using the oneplus toolbox ... After I click on unlock bootloader. Once the command prompt opens it just stay at <waiting for device>,

    , I tried most of the drivers I could find on the forum .... Fastboot device does not show the phone s/n.
     

  8. sryan1987
    Honeycomb Dec 11, 2014


  9. silvagroup
    Honeycomb Dec 11, 2014

    silvagroup , Dec 11, 2014 :
    Make sure your in the directory with your directory with your tools or add them to your path.
     

  10. troublekick
    Donut Dec 11, 2014

    troublekick , Dec 11, 2014 :
    ;)Finally Worked !!!
    Finally I was able unlock bootloader and install TWRP, and root !

    i am not sure what really was the problem, i tried this on the 3rd laptop --- it just worked fine without any hiccups.

    had a tough time for 2 days, since i got my phone with this driver thingy and fastboot device not detecting! phew..

    Thanks a lot for this post
     

  11. kibbt5224
    Ice Cream Sandwich Dec 11, 2014


  12. hilooo
    Cupcake Dec 11, 2014

    hilooo , Dec 11, 2014 :
    Was able to get TWRP onto the OPO, but SuperSU won't load onto it through the command prompt, it isn't recognizing my device at this last point. Any tips?
     

  13. dasoul
    Honeycomb Dec 11, 2014

    dasoul , Dec 11, 2014 :
    Could someone please post a valid way, how to update to newer versions?
     

  14. abhifusion
    Froyo Dec 11, 2014


    apoorvthacker likes this.
  15. eijigen
    Cupcake Dec 11, 2014

    eijigen , Dec 11, 2014 :
    After updating 44S via OTA I lost my root as expected, but now I cannot root it again!
    I flashed SU via TWRP but nothing happens...
    Should I factory reset and try everything again? Or Am I forgetting something?

    :D
     

  16. i.C.U
    Froyo Dec 11, 2014

    i.C.U , Dec 11, 2014 :
    Pretty good guide, I found easier but it does the job especially for noobs. Well done.
     

  17. ITS_NOM
    Froyo Dec 12, 2014

    ITS_NOM , Dec 12, 2014 :
    Need some help. I've unlocked the bootloader and confirmed it's unlocked.

    Booted into fastboot and flashed TWRP 'successfully'. However when i try to boot into recovery from off state using volume down+power, it will boot into Stock Cyanogen Recovery. What gives? I'd really like to root so I change the DPI on this phone.
     

  18. apoorvthacker
    Honeycomb Dec 12, 2014

    apoorvthacker , Dec 12, 2014 :


    this tool makes it quite easy!
     

  19. Ankitsukhani@gma
    Cupcake Dec 12, 2014

    Ankitsukhani@gma , Dec 12, 2014 :
    So eventually Cyanogen is not providing for any update to Indian users of OnePlus One. So are the current phones in India delivered with the CMod? Also the lollipop version of CMod will not be available to Indian users. Then How do we get the particular update and how to update it on the phone?
     

  20. zsharp
    Cupcake Dec 12, 2014