16
Oneplus One not getting 4G LTE. Global Version

  1. Kokorone
    Honeycomb Jun 27, 2014

    Kokorone , Jun 27, 2014 :
    Has anyone been having issues connecting to 4G LTE? The best connection I have gotten so far is H+. I am sure I have the global version of the phone.

    EDIT: After reading up on it, it seems that CM11 has some issues with LTE connectivity. I'm not sure if the same thing is happening to my Oneplus but I hope that with the next update it will be fixed. Still going to talk to Oneplus support

    EDITED EDIT: Well, it looks like AT&T has some bullshit system that asks your phone for its IMEI as soon as it tries to connect to the network. The Oneplus One shows up in their system as an "Unknown Manufacturer" and is immediately downgraded to HSPA+ at best. According to them, the phone cannot get LTE so long as it is not affiliated with AT&T, something that Oneplus won't do because it is unlocked, off contract to begin with. Looks like any AT&T user is in for a bad time with the international version of the phone. We waited for LTE band connectivity, only to be denied by AT&T. T-Mobile doesn't do this BS IMEI number crosscheck so Oneplus One's on their network will have fine LTE connectivity.

    EDIT SOLUTION: I talked to AT&T again and it seems that the "Unknown Manufacturer" status doesn't tell their system that what I am using is a smartphone, therefore only allotting it HSPA+ as a maximum, since non-smartphones only need that much. I will be attempting to register a new sim as a galaxy s4 and just sticking that in my Oneplus One

    FIXED: Ok, after going into the AT&T store again, getting flocked to by numerous sales rep wanting to take pictures with my phone, I managed to get one of them to override the system IMEI with a HTC ONE M8 IMEI. This fixed my problem.
     
    Last edited: Jun 29, 2014

    #1
  2. applepiezz25
    Ice Cream Sandwich Jun 27, 2014


    #2
  3. Reflect Stratos
    KitKat Jun 27, 2014


    #3
    mahvi and Orbettino like this.
  4. liu4gre
    Gingerbread Jun 27, 2014


    #4
  5. brittonraya
    Lollipop Jun 27, 2014


    #5
    Hassan_Abdul, mahvi, gmo8492 and 6 others like this.
  6. Manyareto
    Ice Cream Sandwich Jun 27, 2014


    #6
  7. Eliitti
    Gingerbread Jun 27, 2014


    #7
  8. Infinityespi
    Cupcake Jun 27, 2014


    #8
  9. Kokorone
    Honeycomb Jun 27, 2014

    Kokorone , Jun 27, 2014 :
    Yes I am sure I have 4G LTE. I have talked to ATT
     

    #9
  10. Manyareto
    Ice Cream Sandwich Jun 27, 2014

    Manyareto , Jun 27, 2014 :
    Did you get the phone on eBay or another website where they change the ColorOS for Cyanogenmod and the rear cover also?
     

    #10
  11. elimanetor
    Honeycomb Jun 27, 2014


    #11
  12. Kokorone
    Honeycomb Jun 27, 2014

    Kokorone , Jun 27, 2014 :
    Nope, I got mine directly from Oneplus with an invite
     

    #12
  13. na5m
    Jelly Bean Jun 27, 2014

    na5m , Jun 27, 2014 :
    If you cant figure this issue out for yourself, then you do not deserve this phone.
     

    #13
    Yapapi and neutrino like this.
  14. Kokorone
    Honeycomb Jun 27, 2014

    Kokorone , Jun 27, 2014 :
    I have done everything in my power(Talking to Att, new sim card, etc). You would fare no better. I have already opened a ticket with support.
     

    #14
  15. deejay01
    KitKat Jun 27, 2014


    #15
    feelingsleepyyet and DougH like this.
  16. Manyareto
    Ice Cream Sandwich Jun 27, 2014

    Manyareto , Jun 27, 2014 :
    OK I don't remember if I read in this forum about someone with the same problem but with touch something on APN settings he fixed the problem. There is something with CyanogenMod and the Networks settings. I will try to remember :confused:
     

    #16
  17. Adam Krisko
    KitKat Community Expert Jun 27, 2014

    Adam Krisko , Jun 27, 2014 :
    Also make sure that the 4g option is checked under network settings. (just making sure.
     

    #17
    sundoggy1112 and joeg30 like this.
  18. Vector
    Jelly Bean Jun 27, 2014

    Vector , Jun 27, 2014 :
    Haha. That and women getting fat.
     

    #18
  19. Manyareto
    Ice Cream Sandwich Jun 27, 2014

    Manyareto , Jun 27, 2014 :
    I guess there is something about "energy saver" that it has to be 'tap' in the settings.
    Damn it! If the phone were a bit "reachable" ... It's hard trying to be "guessing" ... with the air...
     

    #19
  20. Vector
    Jelly Bean Jun 27, 2014

    Vector , Jun 27, 2014 :
    Thanks for sharing this BTW. Its good and important information. If LTE doesn't work anyway, why not just get an international one other than price if you're tired of the wait.
     

    #20